Unable to switch to Coherence in Parallels 7 with a Windows 7 guest

Discussion in 'Installation and Configuration' started by ServerSage, Sep 9, 2011.

  1. ServerSage

    ServerSage

    Messages:
    7
    So I just recently (about 12 hours ago) decided to give Parallels a shot. I've been using VMWare for about 2 years with great success, but after hearing great things about P7 I thought why not?

    Well, things seem ok as long as I don't want to use Coherence. As soon as I select it I get:

    <SNIP>
    Unable to switch to Coherence

    The virtual machine display configuration could not be applied...yada yada
    </SNIP>

    I've tried removing and reinstalling the tools, no success. I've verified that the only display adapter listed is the parallels display adapter in the device manager. I also edited the VM's config file and changed MaxDisplays to 4, which is how many I have.

    Now, about my system.

    Mac Pro (Early 2009)
    OSX Lion 10.7.1
    2.93GHz Quad Xeon
    8GB RAM
    Dual ATI 5770 video cards
    3 x Dell 2408wfp monitors (1920x1200)
    1 x Viewsonic VX2035wm (1680x1050)
    90GB SSD (Main boot drive)
    640GB HDD (Boot Camp drive)
    1TB HDD (Home directory)

    The virtual machine is my bootcamp partition running Windows 7 Pro with all the latest updates. I've given it:

    1 CPU
    1024MB RAM
    256MB Video

    Pretty much the defaults. Any help is greatly appreciated. Thanks!
     
  2. strells

    strells Product Expert

    Messages:
    536
    Whoa. Before worrying about your extra displays, get it working on a single monitor first. Disconnect the others or just disable multi-monitor use for Coherance.

    Then increase the VRAM in your VM. I think PD7 lets you go up to 1 GB of VRAM.

    And what exactly are you doing in the config file? I don't think there should be any need for you to do that, at least not yet.

    Steve
     
  3. ServerSage

    ServerSage

    Messages:
    7
    I don't seen an option to disable multi-monitor use for Coherence. If I go:

    Virtual Machine->Configure->Options->Coherence

    There are 4 options:

    Use Crystal Mode
    Show Windows...
    Allow applications...
    Disable Windows Aero

    Where is the multi monitor option? Unhooking the displays is going to be a PITA in the middle of the work day, so I'll have to do that later. As for the config file, as I said in the OP, I changed the MaxDisplays from 0 to 4 per another forum thread's suggestion.

    Thanks for your quick reply, as soon as I try unhooking displays I'll report back.
     
  4. ServerSage

    ServerSage

    Messages:
    7
    Okay, so I gave up on *real* work and decided to unhook some monitors. After unhooking all by the primary monitor, Parallels 7 will enter Coherence, but it's not usable. All VM windows are blank white windows. I've attached a screen shot of an open explorer window, and the start menu open to show what I mean.

    I tried to disable "Use Crystal Mode" in the options and then trying Coherence again, but that did not have any effect.
     

    Attached Files:

  5. LiamS

    LiamS

    Messages:
    1
    I am also having the same problem.

    MacPro (late 2011)
    2.8ghz Nehalem
    16g ram
    Dual ATI 5770 video cards
    4 x Dell 2007FP Monitors (1600x1200)
    Lion 10.7.1

    Guest:
    Windows 7 64bit Ultimate
    4096MB ram
    256MB Video memory

    Nothing I've done makes coherence works in P7. Parallels 6 worked perfect. If nothing is fixed soon I guess i'll downgrade... ugh

    liam
     
  6. Craig Givant

    Craig Givant

    Messages:
    24
    Add me to the List

    Early 2008 MacPro with DUAL video cards supporting 4 monitors. VM will NOT enter Coherence. And NO I am not disconnecting my monitors to "fix" what wasn't broke in version 6.

    ---------------------------Edit--------------
    Added specific machine information
    ---------------------------------------------

    MacPro 3,1 (Early 2008)
    Dual 2.8 GHz Quad-Core Intel Xeon Processors
    12 GB 800 MHz ECC DDR2 FB-DIMM Memory
    Dual NVIDIA GeForce 8800 GT 512 MB (4 monitors)
    2 x DELL 2005FPW Monitors (1620x1050)
    2 x ASUS VH236H Monitors (1920x1080)
    Mac OS X Server Lion 10.7.1 (11B26)

    Guest:
    Windows 7 64bit Enterprise
    4 CPU's
    3952 MB ram
    512 MB Video memory (tested different settings)
    Coherence: Tried both Crystal mode and non-crystal mode
     
    Last edited: Sep 15, 2011
  7. PatrickJ

    PatrickJ

    Messages:
    87
    Make sure you have the latest Parallels Tools installed (v14922 - Reinstall Parallels Tools under the Virtual Machine menu). I couldn't enter Coherence either until PT was updated.
     
  8. Craig Givant

    Craig Givant

    Messages:
    24
    Parallels Tools was automatically installed when booting the VM for the 1st time after upgrading from version 6. Currently shows 7.0.1.14922 so I guess that is the "latest".

    Thanks for your post but I believe my issue is different than the one you were experiencing. I have submitted a ticket and will update here as soon as more information is learned.
     
  9. kjw

    kjw

    Messages:
    4
    Update.

    Notice in this article that was published yesterday that you have to go into configuration and uncheck the checkbox. Did you try that?


    Click on the Virtual Machine menu --> Options --> Full Screen and remove the checkmark from Use Mac OS X Full Screen:


    I haven't upgraded yet, been waiting on that fix, hopefully that fixes the multiple monitors issue.
     
  10. Craig Givant

    Craig Givant

    Messages:
    24
    Yes I have tried removing the checkmark. Coherence doesn't work either way.

    I have also tried increasing the VRAM, same issue.

    Also, I was lax in providing specific machine details. They follow in case anyone else finds the info helpful:

    MacPro 3,1 (Early 2008)
    Dual 2.8 GHz Quad-Core Intel Xeon Processors
    12 GB 800 MHz ECC DDR2 FB-DIMM Memory
    Dual NVIDIA GeForce 8800 GT 512 MB (4 monitors)
    2 x DELL 2005FPW Monitors (1620x1050)
    2 x ASUS VH236H Monitors (1920x1080)
    Mac OS X Server Lion 10.7.1 (11B26)

    Guest:
    Windows 7 64bit Enterprise
    4 CPU's
    3952 MB ram
    512 MB Video memory (tested different settings)
    Coherence: Tried both Crystal mode and non-crystal mode
     
  11. Sugerman

    Sugerman

    Messages:
    3
    Same Exact Results as ServerSage with Parallels 7

    "Unable to enter Coherence mode" with multiple displays on HD 5770.

    With only one display connected I enter Coherence mode and only see blank white spaces where each Windows application should be.



    Model Name: Mac Pro
    Model Identifier: MacPro5,1
    Processor Name: Quad-Core Intel Xeon
    Processor Speed: 2.8 GHz
    Number Of Processors: 1
    Total Number Of Cores: 4
    L2 Cache (per core): 256 KB
    L3 Cache: 8 MB

    Chipset Model: ATI Radeon HD 5770
    Type: GPU
    Bus: PCIe
    Slot: Slot-1
    PCIe Lane Width: x16
    VRAM (Total): 1024 MB


    Windows 7 Ultimate 64 bit installed on a separate hard drive with boot camp.

    I've updated Parallel Tools.
     
  12. Craig Givant

    Craig Givant

    Messages:
    24
    What a Joke

    I received the following from Parallels Support:

    Hello Craig,

    Thank you for contacting Parallels Technical Support.

    As I understand, you are unable to use Coherence mode.

    I regret the inconvenience caused.

    In order to resolve the issue please follow the steps given below:

    1. Start the Virtual Machine and login to Windows 7 Operating System.
    2. Click on Start and click on 'Control Panel' and select 'Programs and Features'.
    3. Uninstall Parallels Tools if present.
    4. Navigate to Mac and click on 'New' on Menu bar and select 'New Finder Window'.
    5. Mac HD/Library/Parallels/Tools/ there you can see 'prl-tools-win.ISO' double click on it.
    6. Then you can see 'Setup.exe' double click to install Parallels Tools.

    Craig, as per the ticket work flow, I am placing this ticket on resolved status as of now.
    However, this ticket will be automatically reopened upon your reply within the next 14 days.
    Please feel free to get back to us if you have any further questions. We will be more than happy to help you.
    Also you have free email support till 'Mar 14 2012', so please do not worry you will be able to create any number of tickets until 'Mar 14 2012'.

    Thank you for choosing Parallels.

    Awaiting your response.

    Have a nice day.

    Thanks,

    Jagadeesh.

    Technical Support Engineer.
    Parallels Desktop ||





    I reopened the ticket with the following response:

    The "canned" response that was provided to fix this issue did NOT work. Parallels Tools had already been updated to the latest version but to satisfy the requirements of your support staff I un-installed it and re-installed it, Coherence mode still DOES NOT WORK.

    Also, might I offer that if you are going to use canned responses you might as well get the steps proper.

    Double clicking on an .iso file by navigating to it in the Mac system serves no purpose other than "mounting" it to the Mac system. The proper way to install Parallel Tools from the .iso image is to mount the image under Parallels as follows:

    1. Click on the window in which your VM is running to bring up the Parallels Menu
    2. Go to Virtual Machine >> Configure
    3. Go to the Hardware Tab
    4. Highlight CD/DVD and in the "connect to" box click "choose Image File"
    5. Navigate to the Image file and select it

    The Parallels Tools .iso Image will now appear as a CD ROM within your VM and you can open that CD to navigate to the Setup.exe

    With all this said please OPEN THIS TICKET and kindly provide me with a proper researched resolution to this matter. I and others who have posted on the Parallels Forum are counting on it.

    ****Edit*****

    Well.... I guess since .exe files have been registered to Parallels, double clicking it from within the Mac environment does allow it to be installed in the VM so my steps (even though in my opinion they are "cleaner") were NOT required. My apologies for my snarky attitude but honestly I'm fed up with this whole mess.

    I guess the bright side is that after uninstalling "tools" I created a snapshot. At least that will make my migration BACK to version 6 a little easier
     
    Last edited: Sep 15, 2011
  13. ServerSage

    ServerSage

    Messages:
    7
    The lack of assistance in this matter is a little frustrating. I'd be content with at least a "We are aware of this problem and are working towards a solution." But instead we get canned responses that don't work. I've reinstalled the tools a half dozen times to no effect.

    I will say that P7 works a treat on my Macbook Pro with just 1 display. But throw two displays at it, and it all goes out the window. For now I guess I go back to Fusion, I see they just released V4. It's downloading now. :)
     
  14. BobTheDog

    BobTheDog

    Messages:
    44
    Mine started doing this today as well after installing Eset NOD32 version 5.

    Tried to put a support call in and got a page saying they were busy.

    Tried to log a problem from the app and it said I had a problem with my network.

    I am beginning to go off Parallels here!
     
  15. LilMac

    LilMac

    Messages:
    2
    Mine was working and just stopped.

    Very disappointed with this upgrade. Seems exactly like 6 except 6 actually worked.

    I'd like a refund before switching to VMware.
     
  16. Craig Givant

    Craig Givant

    Messages:
    24
    What about Multi Monitors (More than two)

    Hey guys,

    I also created a ticket and started a new thread regarding my issues with multiple monitors. I'm shocked that no one has replied to it. Please see that thread and kindly comment if you are experiencing the same issues.

    As Sarge stated: "But throw two displays at it, and it all goes out the window" so I assuming that these issues may be somehow related.

    I guess what I'm wondering is.... how many monitors do you folks that are having the "coherence" issue have?

    I want to see if anyone that is running JUST TWO can get this to work and if adding a third or more is the beginning of the problem.

    Thanks!
     
  17. LilMac

    LilMac

    Messages:
    2
    I'm using a MBP with it's built-in screen attached to a Cinema display via thunderbolt, and a third display attached via a USB adapter.

    Coherence worked fine with no monitors attached.
     
  18. pf23

    pf23

    Messages:
    1
    I am having the same problem. Coherence worked fine in 6 and now doesn't work in 7. I also have a 27" iMac w/ two external monitors attached.
     
  19. Sugerman

    Sugerman

    Messages:
    3
    I was given the below instructions which unfortunately did not work for me. They might work for someone else so I'm posting them here:


    In order to resolve the issue please follow the below mentioned steps :

    1. Virtual Machine > configure > option > full screen > Use all displays in full screen should be un checked.

    2. Apple logo > system preferences > Display > Arrangement Tab > un check "Mirror Display"

    3. Put the Virtual Machine into window mode and drag it to external display then change the view mode to Coherence Mode in external display.
     
  20. Craig Givant

    Craig Givant

    Messages:
    24
    I can confirm that the above steps as suggested to Sugerman DO NOT work. For that matter these steps were tried before I even contacted Parallels Support.
     
    Last edited: Sep 16, 2011

Share This Page