USB Video Grabber not recognized

Discussion in 'Windows Guest OS Discussion' started by Don Lulejian, Nov 16, 2009.

  1. Running Parallels Ver. 5 and WinXP Pro and any of three USB video capture devices I've tried are not recognized. They are all recognized in Boot Camp and of course any PC I've hooked them up to. All the drivers are on here since they have been run under boot camp.

    I have been hoping since version 3 that they would have solved this issue.

    Don
     
  2. Alexander Haltman

    Alexander Haltman Parallels Team

    hi, Don Lulejian.

    Please, do the following:

    1. Select checkbox Parallels Desktop -> Preferences -> General -> Use detailed log messages
    2. Reproduce the issue:
    - connect your usb-device to virtual machine and try to work with it.
    3. Make a problem report:
    - go to menu Help and click Problem Report...
    - fill in the details in a window that opens (details about device malfunction, exect model of your device or url to device description, softaware which you use to work with this device)
    - wait for report submission to complete (you'll get a notice with your report ID)
    4. Post report ID here
    5. Remove back "Use detailed log messages"
     
  3. Filed a report. ID 887089
     
  4. Alexander Haltman

    Alexander Haltman Parallels Team

    Hi, Don Lulejian.
    Thank you for feadback. Your issue will internaly referanced as bug #458291.

    Please, provide us additional info:

    1. Run Terminal application (find here: Applications->Utilities->Terminal)
    2. Copy-past next string to Terminal and press enter (this microsript will collect info from io-registry tree of your system when device not grabbed by parllels usb kernel extesion):
    ioreg -l | zip ~/ioreg1.zip -
    3. Reproduce the issue:
    - connect your usb-device to virtual machine.
    4. Copy-past next string to Terminal and press enter (this microsript will collect info from io-registry tree of your system when device grabbed by parllels usb kernel extesion):
    ioreg -l | zip ~/ioreg2.zip -
    5. Send files ioreg1.zip and ioreg2.zip from your home folder to my email (find it in my profile)
     
    Last edited: Nov 23, 2009
  5. Alex,

    I wasn't able to complete your instructions. I don't know what to copy and where to paste and where are these zip files that get generated. Home folder/my profile?

    Please give me some more detail instructions.

    Thanks,

    Don
     
  6. Alexander Haltman

    Alexander Haltman Parallels Team

    1. Run Terminal application
    - open Finder and go to Applications->Utilities->Terminal (pic-1)
    - run Terminal aplication (pic-2)

    2. Copy-past next string to Terminal and press enter (this microsript will collect info from io-registry tree of your system when device not grabbed by parllels usb kernel extesion):
    ioreg -l | zip ~/ioreg1.zip -

    3. Reproduce the issue:
    - connect your usb-device to virtual machine.

    4. Copy-past next string to Terminal and press enter (this microsript will collect info from io-registry tree of your system when device grabbed by parllels usb kernel extesion):
    ioreg -l | zip ~/ioreg2.zip -

    5. After this steps you will have Terminal application look like pic-3

    5. Send files ioreg1.zip and ioreg2.zip from your home folder to my email (find it in my profile)
    - open Finder and go to your home folder - like on pic-4


     

    Attached Files:

  7. I sent the files you requested Nov. 27th via your email address.
     
  8. Alexander Haltman

    Alexander Haltman Parallels Team

    Hi, Don Lulejian.

    Sorry for silence.

    I have recieved your email on Nov.27, but for now we have not resolution for your problem.
    We will order this device to fix problem, but before we will do this please:

    1. Update your Parallels Desktop 5 to latest version (for now it is Parallels Desktop 5.0 build 9308 (December 21, 2009)) and ckeck your device once more.

    2. If device not working with latest version of Parallels Desktop 5.0, please:
    - Select checkbox Parallels Desktop -> Preferences -> General -> Use detailed log messages
    - Reproduce the issue
    - Make a problem report and specify exect device name in problem report's comments (link to web site with device description will be better)
    - Post report ID here
    - Remove back "Use detailed log messages




     
  9. The problem report has been sent to the Parallels Support team with ID 1989876.
     
  10. Alexander Haltman

    Alexander Haltman Parallels Team

    Thank you, Don Lulejian.
    We track your issue internaly as bug #458291.

     
  11. Frame Grabbing via USB

    Hi,
    I am considering using Parallels to run Windows XP or later on a Mac. In Windows I will need access to ...

    1. A USB web cam video stream (frame grabbing)
    2. A USB to serial port adapter device

    Does Parallels support these? This thread seems to say ... "not really" for the framegrabbing.

    >We track your issue internaly as bug #458291.

    What is the status of this issue?

    Thanks.
     
  12. Robert,

    When using parallels the frame grabber brand and model matter. My ADS Video Express will not work in parallels but will with WinXP using boot camp. I believe the Dazzle DVD Recorder from Pinnacle may work in Parallels v5.0.
    I run video doing astronomy and have to boot my Mac in WinXP and all runs fine.
    Hope this helped.

    Don
     
  13. Follow up on USB video capture - Success

    I wanted to post my USB framegrabbing experiment conclusion... it worked.

    Quick summary... I installed the latest Parallels 5.x, running on latest Mac OS X, running on an 2-3 yr old MacBook Pro, with Guest OS as Windows XP w/ all service packs & updates.

    I had some framegrabbing software running successfully on a native Windows XP box using a Logitech USB "webcam 250" and ran it under Parallels VM running Windows XP (once I had installed the drivers there too).

    The frame per second rate dropped (vs. native Windows XP) pulling 640x480 color frames (RGB24) and the device shows up differently in the Device Manager but overall it works.
     
  14. Nov 17, 2009, filed a report. ID 887089.
    Your issue will internaly referanced as bug #458291.
    Jan 11, 2010, problem report has been sent to the Parallels Support team with ID 1989876.
    Your issue internaly as bug #458291.

    Mac OS 10.6.3; Parallels 5.0 Desktop for Mac
    I am trying to get pinnacle ultimate 14 with pinnacle composite video capture hardware. When I try to capture video, the the import S/W hangs. Has this issue been resolved (see above?) As of the January timeframe it does not appear to have been resolved in the general case.
     

Share This Page