1 Step Forward 3 Steps Backwards - 3.0 is alpha at best

Discussion in 'Installation and Configuration of Parallels Desktop' started by cmayaud, Jun 19, 2007.

  1. cmayaud

    cmayaud Junior Member

    yeah, I tried the "burning CD" approach but, of course, you need "The Tools", which you can't install, already installed to read the CD in the first place ... duh!

    I'll try the "reading iso from the VM" approach next and see if that works ... thanks
  2. paulj

    paulj Junior Member

    THIS COMPANY IS A JOKE - they have no clue

    Now that they've had me install an OLD version of Parallels, it can't be updated to anything other than 3.0, which is NOT FUNCTIONING.
  3. Rachel Faith

    Rachel Faith Hunter

    Well, last week, I had finally HAD IT up to hear with these kinds of issues, both the technical and the personal or rather complete lack thereof. I finally got a PM and email from 3 different folks... on Friday... all saying they would get back to me next week "We Promise" sorta thing...

    Its the end of the day in 2 hours and that leaves 2 days left in the week... My green light is now YELLOW again...
  4. DaveyP

    DaveyP Bit poster

    I think you're still not following what I'm saying: You absolutely don't need to burn any CDs with what I'm trying to explain...

    1. Launch your VM
    2. Launch Windows Explorer and expand My Computer so that you can see the CD Drive (D:)
    3. From the Parallels menu select Actions - "Install Parallels Tools..."
    4. OK the Parallels warning
    5. After a few seconds (3-5 for me), the CD Drive should show "Parallels Tools setup disk"
    6. You can then launch PrlTools.exe from the root contents of the CD Drive to install the tools

    If this is what you've followed step-for-step already, then I apologise, but it doesn't sound like you have and from my experience this has worked every time (and I'm only saying this to impress that I believe it's a viable solution).

    I also apologise to Rachel if I'm the smug haughty guy of her earlier post: I don't mean to be, I know how frustrating it can be when you're trying to get something to work. I'm just trying to assist and I'm not sure I've explained thoroughly in earlier posts.
  5. Olivier

    Olivier Forum Maven

    Yes, with much success and using it all day long to work.
  6. balkanboris

    balkanboris Member

    No problems at all with 3.0 Sorry for those that have. Noticeably faster with much better memory management. Installation also went without issue. Running XP Pro VM.
  7. cmayaud

    cmayaud Junior Member

    No, I did understand and tried that ... it didn't work but it's the reason it didn't work that offers the solutions to the problem which I will post separate but it's you guidance that lead me to the solution ...

    the trouble is that if the upgrade fails to install Parallels Tools the first time through, the VM itself is "crippled because it can't "see" any CD Drive (iso or otherwise) because it doesn't have the necessary drivers ... this is why you can no longer use the installer to install Parallels Tool because it must "see" the ISO ...

    BUT you can't see the "iso" using explorer nor can you use an install disk because it can't use your CD Drive so creating a CD doesn't work either (it has nothing to do with configuring the VM, the guest operating sytem doesn't have the driver installed which are require for it to read the installer ISO)

    So the problem to solve becomes: how to get a copy of the Parallels Tools Installer "inside" a VM which doesn't have the drivers required to read CDs (neither real CD Drive nor ISOs are Readable without the new drivers) ...

    Although it has taken me a couple of hours I have the solution which I'll post separately ...

    Thanks a million DaveyP, you at least got me to focus on the path that leads to the solution!!!!!
    Last edited: Jun 20, 2007
  8. cmayaud

    cmayaud Junior Member

    SOLUTION: How to Install Parallels Tools after the 3.0 upgrade failed to

    The Situation:

    You are upgrading an existing VM to 3.0

    [in my case I was upgrading a Vista Enterprise Guest VM on a MacBook Pro Duo ... but that turns out to be irrelevant]

    The Parallels Software on the Host Mac Grades fine and the VM appears to upgrade to the new format. You start up you upgraded VM. Yes you have problems starting it up (yes you have to reduce your memory to 1000 from 1500 and yes you have to unclick the MacOS resoltuion check box talked about elsewhere on these forums) but you finally get it to start up and the screen resolution problem is solved.

    Now you try to install "Parallel Tools" from the ACTIONS menu ... it seems to run okay but nothing happens in the VM. so you try restarting a few times and still the Parallels Tools won't install ...

    Welcome to the "VM Twilight Zone"

    Nothing you can do now will install the Parallels tools because you now have a VM which no longer has the Drivers required to see either ISO Disk images (required for the automated install) nor can you just create a CD image of the Parallels Installer because your VM can't read CD's anymore ...

    So the Problem to solve reduces to --

    "How can I manually get a copy of the Parallels Installer into a VM which can't read ISO or real peripheral devices because it nolonger has the required drivers ....


    STEP 1: Create or Use another BOOTABLE VM

    [In my case I've been using Parallels for awhile so I have learned to not only make frequent rotating VM backups but I also have "RESCUE VMs". A "Rescue VM" is another bootable VM in the same OS as your normal VM BUT it only has a virgin install of the OS plus you favorite disk repair utilities ... The "Rescue VM" is configured so that one of it's hard drives is the VM you want to rescue ... That way if your production VM suddenly doesn't boot or becomes corrupt, you just launch your rescue VM and often just the process of launching the rescue VM will repair the attached Corrupt VM, if it doesn't, you can still use your disk utilities to try to fix it, and if that doesn't work you can just grab all the files on the VM which have changed, or are new, since your last backup ... that way, even if you have to REVERT to a backup, you at least haven't lost ANY data ...]

    It turns out the 3.0 upgrade CAN upgrade VMs without too much trouble IF THEY ARE simple (meaning just the OS and not much else) ... so you can try upgrading a rescue VM like I did or you can create a new bootable VM from scratch (remember to save a copy of this VM cause you don't want to have to do this every time you need a new bootable VM)

    STEP 2: Configure your NEW VM to launch your OLD VM as a HARD DRIVE

    STEP 3: Configure your New VM to Share the entire Mac Hard drive

    (this is in "the shared folders" settings -- you have to create a share icon which refers to THE ENTIRE MAC Hard Drive -- not just a folder on your Mac)

    STEP 4: Configure your NEW VM to launch an additional CD-ROM
    which is based on an ISO (not real CD-ROM) called vmtools.iso (the path is Library\Parallels\Tools\vmtools.iso ... if you can't find it, remember there are 2 Library directories on your mac -- it's NOT in the Users\Library\Parallels directory)

    STEP 5: Launch Your new VM

    Once you are booted up on y9ur new VM you should now be able to click on you old VM and open it like a peripheral Hard Drive.

    You should also be able to open your new CD Rom which runs the vmtools.iso. If you can't read my note at the end of this post for another approach.

    STEP 6: create a new folder on in the DESKTOP directory of your OLD VM and copy all the contents of the vmtools.iso into it

    now you have the Parallels Tools Installer manually copied to a folder on the desktop of YOUR OLD VM.

    STEP 7: shut down your new VM and startup your OLD VM

    STEP 8: Now launch the Parallels Installer located in the folder you created on your desktop of your old VM...

    Voila! Parallels Tools now installs both the proper drivers and all the new features of 3.0...

    Whether or not this process was worth it remains to be seen .. but it works ...

    NOTE: I bypassed Step 4 because, in the process of discovering the solution I had already converted the vmtools.iso into a CD-ROM so I used the CD-ROM as the source for the installer ... remember, you still need the rest of the steps because your old VM can't read CD-ROMs until you finish the upgrade so you need the New VM to effect the manual transfer of the installer to you old VM ...

    Took forever ... but it works and I've been able to reproduce that it works several times ... now if only the Parallels Support People would look at this forum once in awhile we might save alot of heartache among disgruntled Upgraders :)
    Last edited: Jun 20, 2007
  9. dkp

    dkp Forum Maven

    Nice work!
  10. DaveyP

    DaveyP Bit poster

    Glad you got it sorted! Sorry I kept banging on!
  11. ihadmeavision

    ihadmeavision Bit poster

    My install worked kinda...

    I had no issues installing v.3 over my previous one. The only problem was that I couldn't get any network connection although Windows XP said everything was dandy. I finally got it to work after I launched Parallel Tools from the Taskbar, selected Network Driver and unchecking the Enabled box for the driver options. It then proceeded to quickly install something (which surprised me), and I don't know what it installed as it did it too quickly. I think it was a driver although I thought I was disabling it?!? Anyway internet connectivity finally happened. Just though maybe this could help someone else. ::I::

    Mac Pro
    Mac OS 10.4.9
    Parallels v.3
    Windows XP Pro SP2
  12. rgh1parallels

    rgh1parallels Bit poster

    I admire the persistence that cmayaud exhibits in pursuit of this solution. And even though I came into the forum looking for precisely this solution, I decided not to try it because I simply did not wish to waste more time than I already had by buying, downloading and installing 3.0 only to find that I had to uninstall it and start from scratch to get back to where I had started. I do not use Parallels for fun; I use it for work. When I buy a tool to work with I expect it to function as advertised. When it doesn't I move on to the something else. It should be apparent to the Parallels folk by now that they have a problem with this release. They should at a minimum be addressing that in their KB. So far the only solution I have really gleaned from this thread that I find attractive is asking for a refund. Anyone happen to know how that might work?
  13. brkirch

    brkirch Pro

    I understand that the Parallels Tools install fails and leaves the CD/DVD driver in a broken state, but can't you go to the device manager and reinstall just the CD/DVD driver? After all the initial CD/DVD driver should just be a generic one, that was from the Windows install CD.
  14. dep11

    dep11 Bit poster

    For "Ihadmeavision"---I tried what I thought you suggested but when I highlight "network driver" in the Parallels Tool Center I get, under Network Driver Options the following: "Your virtual machine configuation does not include network adapter" and there is nothing 'enabled' for me to uncheck. What am I missing?
  15. rkuberek

    rkuberek Bit poster

    Backing Out

    Is there a way to back out 3.0 to 2.5x?

  16. gecko

    gecko Bit poster

    sorry I bought the 3.0 upgrade

    I tried upgrading to 3.0 last week from Build 3188, which was working great. I then couldn't get Windows XP Pro to work in my VM at all. I figured it was me, so I had my husband try (software developer with 15+ years experience). After 4 hours of scouring this forum for tips and trying various things, he gave up. He rolled my system back to 3188 and everything was fine again. I wasn't trying anything fancy, I just wanted to boot up my VM and run my Quickbooks and I couldn't. I can't even run v 2.5.

    I have sent a request for a refund today, and hopefully I get it soon.
  17. dpie79@gmail.com

    dpie79@gmail.com Bit poster

    Lack of communication

    I was sad to hear that you received no reply to your email request for support. It seems to be an issue with the entire company as I sent in an email to their customer service department with some general questions and never received a response either. When I finally decided to call them a week later (at the number that their auto response email sent me) I was forwarded to their sales department and they did not seem to know anything about a customer service department or what number I might call to get in touch with them.

Share This Page