10 Key Doesn't work

Discussion in 'Installation and Configuration' started by NoSpamMan@mac.com, Feb 23, 2008.

  1. NoSpamMan@mac.com

    NoSpamMan@mac.com

    Messages:
    4
    Hi All,

    One of our Parallels installs was specifically to run QuickBooks Pro 2006 for PC. They're running the very latest flavor of Tiger (10.4) and the very latest version of Parallels (version 3) and still the 10 key on the extended keyboard does not work. Has anyone else seen or heard of this before? When I try to search these forums or Google for an answer, I can't seem to find anything.

    Any thoughts on how we might fix this, or is it a bug?

    Thanks!

    Mick
     
  2. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello Mick,

    You can use F10 with Apple / Command key.

    Or you can disable F10 on Mac side (Mac OS X System Preferences - Keyboard & Mouse - Keyboard Shortcuts). This will let you to use the key on Windows side.

    Best regards,
    Xenos
     
  3. NoSpamMan@mac.com

    NoSpamMan@mac.com

    Messages:
    4
    Thanks for the reply, but my query is not about the F 10 key, but rather the "10 key" on the apple extended keyboard. That's what accounts call the number pad on the far right of the keyboard and it doesn't seem to work in QuickBooks 2006 for PC under Parallels. Do you have a fix for that?

    Thanks!

    Mick
     
  4. Hugh Watkins

    Hugh Watkins

    Messages:
    953
    a duh :)
    i have made the same mistake too.-)

    I use a Windows keyboard - an old PS2 - which is fine with a modern 2 wire link to usb

    but I have to remember to press Num Lock on start up because the default is to arrow keys

    Num Lock has a different name on the Apple keyboard but works the same way under Windows on Parallels

    BTW the MS Basic Optical mouse works well with the Parallels Tools and is very effective under Mac OS too with a handy zoom from the wheel

    but do not install other drivers - just use the diffaults

    enjoy

    Hugh W
     
    Last edited: Feb 25, 2008
  5. NoSpamMan@mac.com

    NoSpamMan@mac.com

    Messages:
    4
    Hmm... I'll have to see if they have tried that yet. Thanks.

    BTW, it IS called "num lock" on the Apple Keyboard too, but I think that's only for people working on a laptop or shorter keyboard. I "think" the extended keyboard should just work out of the box without searching for "num lock," right? I don't see it on the Apple Extended keyboard, but it's on the Mac Book Pro keyboard I'm typing on now. It's purpose is to turn a regular keyboard into a 10-key. Unfortunately, you won't have access to the full alphabet if you do that, and QuickBooks is more than just numbers.

    I'm just surprised that I've never seen this bug mentioned here before. Is anyone else having trouble with this? QuickBooks for PC is still a superior product compared to it's ugly stepsister, QuickBooks for Mac.

    Much Obliged,

    Mick
     
  6. Hugh Watkins

    Hugh Watkins

    Messages:
    953
    it is not a bug but user error under windows

    I use a windows mouse an dkeyboard plugged into a MacBook pro

    windows key = apple key

    Hugh W
     
  7. NoSpamMan@mac.com

    NoSpamMan@mac.com

    Messages:
    4
    So I still don't get the solution you're proposing. Since there is no "num lock" on the extended keyboard, how would you get it to work on a Mac running Parallels.

    Are you suggesting using an old Windows keyboard? Surely there is a way to get the Apple Keyboard to respond, no?...

    Thanks!

    Mick
     
  8. MrWhimple

    MrWhimple

    Messages:
    1
    Hi Mick,

    On the Apple extended keyboard the numlock key is on the keypad. It is the key above the number 7, marked clear on the Apple keyboard. Hitting the clear button should toggle the keypad on and off!
     
  9. Hugh Watkins

    Hugh Watkins

    Messages:
    953
    it really pays to use a windows keyboard because of the Alt Gr key

    Hugh W
     
  10. infitom

    infitom

    Messages:
    2
    Getting a 10-key to work with Macbook in Bootcamp (and possibly OSX)

    I've got one of the older MACBOOK 15" Pro's and wish that it DIDNT have the "feature" of changing letters on the keyboard to emulate a 10-key pad, but that an external 10-key pad on an external keyboard would work properly (or a dedicated 10-key pad as welll).

    I wish that therewas a FIRMWARE patch or configuration item that would allow me to turn it off. This way I'd be able to use the 10key options of an external keyboard properly.

    IN BOOT CAMP: I finally hit on using INPUT REMAPPER to redirect the 10-key in an external keyboard to their number equivalents when NOT IN NUMLOCK mode. This way, instead of the number [2] on the 10-key pad generating an [DownArrow], it generates an "2" character. Because these scancodes are different from the [@2] key above the letter [E], and not the same keyscan code as the [K] key, it will type numbers now (forced numlock for the 10-key keyboard) and my arrow and letter characters.

    This also fixed my issue with a stand-alone 10-key added to my MacBook--it allows me to use the built-in keyboard for letters and numbers along the top edge of my macbook, but use the 10-key without having to toggle the [NumLock] key on and off all the time.

    I'm sure I can find a similar remapper for OSX, and will now look for that as well.

    Just a suggestion for people that HATE the numeric-keypad emulation that Apple only partially implemented on their Macbook Pros. If they did it like every other laptop manufacturer, when you numlock, it changes the keys on the built-in keyboard only--not on any external keyboard plugged into the laptop.

    Oh well--they've done so many great things on this laptop, I can forgive them this one flaw--now that I know how to work around it.

    I hope this helps someone else with their desire for a true 10-key on their Macbook Pro.
     
  11. John@Parallels

    John@Parallels

    Messages:
    6,450
  12. lalalew

    lalalew

    Messages:
    1
    numeric keypad not working in Parallels

    6/13/13: My numeric keypad suddenly stopped working when I was working in Quickbooks and I was stumped. I kept thinking F16 was the num lock key, but now I know it's the CLEAR key, right above the 7. It works now! Thanks!!


     

Share This Page