100% Disk Usage - Parallels 11 for Mac Pro

Discussion in 'Windows Virtual Machine' started by NewZeroRiot, Jan 6, 2016.

  1. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    To paint the picture; i'm currently running Parallels 11 for Mac Pro, with Windows 10 being installed on bootcamp. My Mac is the 2015 iMac, 16gb RAM, 1TB HDD and retina 4k display, newly installed and arrived on my doorstep. I have assigned 500gb HDD to the Windows partition and 8gb RAM.

    When I run my windows machine using parallels desktop, I have constant, 100% disk usage that doesn't go down, without running any programs, it takes almost 10 minutes to start and just acts totally sluggish, running Visual Studio 2015 community (the only running application) is painful and unusable.

    I tried to turn off Windows Defender, but this makes no difference, and also the opacity and transition effects in Windows 10. Any ideas on what to do next?
     
  2. marat_t

    marat_t Pro

    Messages:
    287
    Hi,
    I'd suggest booting in Boot Camp directly and running chkdsk /r
    btw, isn't it a usb hdd?
     
  3. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    Cheers Marat; It's a brand new machine, partition and installation on the internally fitted disk.

    I've run check disk with no errors, the machine also runs perfectly in terms of disk usage when going in directly with boot camp.
     
  4. marat_t

    marat_t Pro

    Messages:
    287
    Hi,

    Does the issue still persist after that? Is Task Manager saying smth useful in regards to the most disk voracious processes when booted in VM? Finally, if you uninstall Parallels Tools will the issue still persist?
     
  5. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    I'll try that next, since the update it's taking over 10 minutes to even boot into the machine.

    Do you mean uninstall the tools from on the virtual machine?
     
  6. PaulChristopher@Parallels

    PaulChristopher@Parallels Product Expert Staff Member

    Messages:
    3,110
    Yes, you may uninstall Parallels Tools from the virtual machine: Control panel-> Add or remove programs->Uninstall Parallels Tools and then check how it works. Thanks!
     
  7. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    That seemed to work , and reinstalling worked for a short time and its back to 100% disk usage again a few days later. (i wanted to give it a week of use before replying again)

    It seems to be looking for windows updates, i think that might be the issue, it, however is tediously slow and i can't be doing this every day.

    Can i provide more useful information?
     
  8. marat_t

    marat_t Pro

    Messages:
    287
  9. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    Right Marat, i've got it. What it turned out was that it was Windows update - if there were any available updates it would completely lock the disk usage to 100% until they were complete, regardless of them being downloaded or not.

    Thanks for the help, i'd flag this to the team to look at because it was really frustrating with it locking my iMac every time i just wanted to login, my work around though is to boot straight into Windows, let it do the update then load up OSX.

    Cheers again for the help
     
  10. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    So it seems that this the latest update, this problem has gotten worse, i how have to wait upwards of 40 minutes for the 100% disk usage to settle and eventually be able to use my virtual machine. Has this been reported by anyone other than myself?
     
  11. OneMHz

    OneMHz Bit poster

    Messages:
    3
    +1

    I'm still getting this. Seems to be since the last time I updated Parallels. It's Parallels Control Center, Antimaleware Service Executable and 'System and compressed memory" fighting to be the biggest disk hog. Each taking turns using up to 20+ MB/s while the computer is otherwise idle. Makes for a terrible experience trying to run anything in it.
     
  12. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    This problem just hasn't gone away at all, i've now uninstalled Parallels completely and running Windows natively. No 100% disk usage any more, i'm pretty disappointed that this went nowhere.
     
  13. burnar

    burnar Bit poster

    Messages:
    1
    Thanks for good information
     

    Attached Files:

  14. PaulChristopher@Parallels

    PaulChristopher@Parallels Product Expert Staff Member

    Messages:
    3,110
    Hi, please shut down your Windows virtual machine and open VM config (configure -> Hardware -> Boot Order -> Advanced Settings -> Boot flags):
    devices.hdd.fsync=3
    After setting the boot flag, please check to work with the VM for a while and to reply us back with your feedback: whether it helped or not, how it works.
     
  15. NewZeroRiot

    NewZeroRiot Junior Member

    Messages:
    10
    Cheers for the note Paul but I can't justify spending more hours on this issue soon. I'll give it a go when work calms down, but for the moment I need efficiency, not a 'have a go at this solution'. I just can't sit in the morning in the hope that the disk usage goes down, sometimes it's an hour, sometimes longer; it's actually faster to reboot each time i need to swap from Windows to OSX right now, i'm quite literally unable to do anything on the machine at all with Parallels running.
     
  16. Raj@Parallels

    Raj@Parallels Guest

    Messages:
    453
    To force stop Windows virtual machine from Mac menu Actions > Stop refer this steps for more information.
    Please feel free to reach us, if you have any issues related to Parallels support.
     
  17. EdwardD3

    EdwardD3 Bit poster

    Messages:
    2
    I'm having the same issue and that flag didn't do anything. This seems to happen every time there is an update to Parallels Tools for me... and to be honest, it's getting annoying having to always debug this product.

    The CPU runs excessively high and the disk makes the VM completely unusable (I've had to change my settings to prefer Mac performance over VM just to keep my host running)


    **Update: Looking at the Windows VM, Parallels Control Center (prl_cc.exe) is performing 180,000+ I/O reads, the next largest is the runtime broker service at 16,521.

    So what exactly is Prl_cc trying to read from the VM disk and WHY??? having an unusable system is not what i'm paying for.
    For reference, I have 5 Windows VMs, every one has this issue after the last update.

    A temporary fix for this is to disable Windows folder sharing to the Mac. It would appear that the Mac is trying to index the entire guest VM and not doing a very efficient job of it. Adding an exclusion to Spotlight didn't work at all.. so while you lose the ability to transfer files from host to guest, you at least get a working guest.
     
    Last edited: Aug 13, 2016
  18. CraigD2

    CraigD2 Bit poster

    Messages:
    1
    Can confirm. This disk I/O has been annoying as heck, especially as an SSD user. I was close to moving to another solution. Disabling sharing of Windows folders w/ Mac host puts prl_cc.exe back in check. This should be looked at.
     
    Maria@Parallels likes this.
  19. JamieL2

    JamieL2 Bit poster

    Messages:
    1
    I'm so disturbed that this continues to be an issue, with literally no response from Parallels? What a waste of time and money.

    I can confirm that this continues to be an issue with Parallels.
     
  20. DavidJ15

    DavidJ15 Bit poster

    Messages:
    1
    Yep. Same here. I just run with the 'Access Windows folders from Mac' unchecked under Sharing/Shared Windows and it works fine. As soon as I turn it on disk usage goes nuts. Has anyone tried running the virtual machine on an external drive? I know this would not fix the disk usage problem but the disk usage would be on the external drive and hopefully would not slow the Mac down as much. I have spent hours/days trying to fix this problem to no avail. I am on Parallels 12 and still have the same problem. Come on Parallels!
     

Share This Page