2X Client crash - MsRdp ActiveX

Discussion in 'Parallels Remote Application Server' started by spjohnson, Aug 31, 2007.

  1. spjohnson

    spjohnson Guest

    One of our end users is experiencing a problem with the 2X Application Client. In particular the client crashes whenever she opens the client program. The crash is accompanied by an error message with the following information:

    "2X Application Client -
    MsRdp ActiveX failed to initialize (hr = 0x80070057). Please check your connection settings"

    However, the client is able to connect to the 2X server by using the Microsoft Terminal Services Client (MSTSC.exe). It is only when using the 2X client that this error message and crash occurs.

    The client is using Windows XP SP2 and 2X Application Client build 275. The server is running Windows Server 2003 SP2 and 2X ApplicationServer and LoadBalancer build 275.

    Has anyone seen this before?
     
  2. nixu

    nixu Guest

    Hi there,

    That is not a crash but initialisation failure,

    What i suggest is to reinstall Microsoft's latest RDP, and reconfigure all you client settings. From regedit rename HKEY_CURRENT_USER\Software\2X to some thing else and relaunch the client.

    Nixu
     
  3. kerzi

    kerzi Guest

    I have the same problem, and it is the newest RDP client that is causing the problem. Once I remove it everything works fine, but we need it because of the screen resolution problem on a machine with two monitors.
     
  4. nixu

    nixu Guest

    What is the exact error message you are getting?
    Nixu
     
  5. kerzi

    kerzi Guest

    Same error as posted above.
     
  6. kerzi

    kerzi Guest

    I noticed this was not fixed with the newest version of the 2x client. Has anyone else had this problem and found a fix?
     
  7. jasonjayhawk

    jasonjayhawk Guest

    I just encountered this error for the first time.

    By disabling the "Span across all windows" option in 2X, the error goes away. It seems linked (in my case) directly to allowing a dual screen span across monitors.
     
  8. nixu

    nixu Guest

    Hi there,

    Could you please paste the Control Version of the RDP Client.

    Open 2X ApplicationServer Client -> Help Control Version

    Nixu
     
  9. jasonjayhawk

    jasonjayhawk Guest

    Sure. It's 6.0.6001 (61)

    Oddly, "Span Desktops on all monitors" works on some machines with two monitors, and not on others.

    We ensured the screen resolution was the same on the dual-monitor configurations. Even tried an older version of 2X (6.0) but it gives the same error. MsRdp ActiveX failed to initialize (hr = 0x80070057)

    When I Googled for the error to see if anyone had a fix, I discovered this thread in the 2X forum. But it looks like no solution has been found.
     
  10. nixu

    nixu Guest

    Hi jasonjayhawk,

    Could you compare the following properties between the working machine and the one with the problem:

    1) Control Version
    2) Color Depth
    3) Screen resolution
    4) Screen Sizes
    5) Number of screens
    6) Screens orientation (eg screens are side by side or one on top or the other, diagonally etc.. )

    Make sure that both clients are connecting to the same Terminal Server.

    Nixu
     
  11. pfcit

    pfcit

    Messages:
    9
    I had this exact problem this morning. This is how I fixed it.

    I ran a sfc /scannow and it found the following files corrupted:

    mstsc files corrupted:

    mstsc.exe
    mstscax.dll

    After a reboot 2X automatically added a new connection. Mind you I did nothing to 2X prior to the sfc fix. The new connection allowed me to start the application normally. I hope this helps someone in the future.
     
  12. icrittendon

    icrittendon Guest

    We had the exact same problem. This is what fixed the issue for us

    Under the Connection properties tab in 2xclient go to the experience tab and check the connection settings from modem to Lan. You can then uncheck all the boxes under the lan settings if needed. Save settings and click refresh. Then try and connect with the application.


    Thanks
     

Share This Page