2X Universal Printing broken on 2008 R2

Discussion in 'Parallels Remote Application Server' started by mikaelshim, Mar 8, 2010.

  1. mikaelshim

    mikaelshim Guest


    We have a client who have been running 2X AS, SMB on a 2008 X64 Server without any problems so far, the 2X universal printing module is a daily must have for them.

    They ar enow upgrading some servers and we started build their new TS server , which now is 2008 R2, we also decided to evaluate the new Version 8. Everything works great, but 2X universal printing does not. All documents just sits in the Que and nothing happens.

    Any idea or solution to what may cause this? or does the 2X universal printer simply not work in 2008 R2?
  2. gmitch64

    gmitch64 Guest

    > 2X universal printing does not. All documents just sits in the Que and nothing happens

    We're having the same issue here, have been fighting it since Friday. If you install V7 on R2, printing works till you reboot the server. With V8, we get a setup driver error. When you install it manually, we get a 'this is not a supported version of windows' error.

  3. Do you use 64 bit version of 2008 R2 ?
    If you create shortcut to setupdrv.exe of printer, and set compatibility mode to 2008Sp1 it will help to install it properly.
  4. gmitch64

    gmitch64 Guest

    > Do you use 64 bit version of 2008 R2

    There only is a 64bit version of 2008R2, there is no 32bit.

  5. gmitch64

    gmitch64 Guest

    Manually installing it with compatability mode allows the install to complete, but still doesn't let us print.

    Interestingly, if you install the agent thru the console, it gets installed in Program Files, if you install it manually, then it gets installed in Program Files (x86), which is where it should go I think, since it's still a 32 bit application running in syswow.

  6. mikaelshim

    mikaelshim Guest

    First of all, thank you all for the fast inputs and replies.

    To say the least... since im not alone and this is an obvious problem. 2X dev´s need to take this matter seriously and correct the issue. We are already consulting alternative solutions only due to this, apart from the print issue we are and our client very happy with 2X. But broken Universal printing in R2 renders it a useless product.

    Most of you seem to have had problems getting the driver to install .... in fact it installed for us and didnt complain at all. However, you simply cant print any with it. All documents just sits in the printing que and never gets redirected to the Client.

    For our client, and for us as their IT partner, this is a serious matter, and if it cant be solved as is right now under 24-48 hours they and we are forced to change direction and scrap 2X. Sad but true


    20 mins of googling turns up plenty of universal printing solutions for TS and RDP that are all 2008 R2 compatible. R2 is hardly a new product ..... this is embarassing guys.... how could you miss this?
  7. chouinard

    chouinard Guest

    Re: Temp Fix - 2X Universal Printing broken on 2008 R2

    This same problem happens to me on version 7.1 build 743 and 8.0 build 827.
    On 7.1 If you resinstall the agent via the 2x console printing will Work until you restart your Server. After that you will need to resinstall the agent via the console again. If you receive an error installing the 2x agent (2xRis.rep) you need to restart the Gatway server and try again (no idea why the gateway) After a restart try the agent install again.. Works every time for me

    Now with version 8.1 when you install the agent I get an interactive services detection error popup. Message title LOCAL PORT
    Setupdrv.exe Error
    I've tried doing the runas administrator and compatibility mode but that doesn't work at all.
    To fix this problem you NEED to turn off DEP on the 2008 Server. Once you do that the message goes away and the agent will install cleanly. But once again if you restart the ts server your printing will break. So resinstalling the agent fixes the issue.

    The real bad problem with resinstalling the agent is if users are connected you cannot reinstall the agent.. So you need to get everyone off and restart then resinstall. But it atleast will work.

    I have an open ticket with support Ticket 116077 but everytime I call support to give them this update they keep disconnecting me.. Awesome.

    Anyway hope this helps
    - Ray
  8. mikaelshim

    mikaelshim Guest

    Re: Temp Fix - 2X Universal Printing broken on 2008 R2

    Thank you very much Ray, i will check if this works, However its an absolutely unacceptable solution. I just tried Elusiva Universal Printer, worked out of the box and a few mins setup. Not that my clients is gonna pay for that. But 2X is completely out the window within 48 hours if theres no response or proper fix to this. As is now, even the crappy MS Easy Print and running a standard TS gateway is better.... its sh*t.. but its better then 2X currently on 2008R2 , having one of its (in my opinion) strongest and greatest features broken. TS printing has always been a pain in the arse for as long as its been possible, and Citrix attempts to fix it failed completely, the new driverless Easy print introduced in 2008 is a step forward, but still crap and pure headache for the endusers, especially when you have plenty remote ones.

    As for TS servers, we usually kill DEP completely with bcdedit sincle client often experience odd behaviours or crashes of their programs, being anything from simple Viewers to advanced Autocad solutions.

    Bottomline is ... not a word about this, and no response on your support ticket. ... they are obviously clueless
  9. chouinard

    chouinard Guest

    A workaround for the 2xRis.rep Error is to copy the application server msi locally on the tsserver and install it via administartor cmd. That will reinstall the agent and printing will work again until a restart. Atleast saves you a gateway restart.

    Finally got a hold of someone in the sales department. He was going to let support know i was calling. Apparently there busy.. Doesn't explain why they have no voicemail
  10. mikaelshim

    mikaelshim Guest

    They were busy doing donuts and coffee
  11. Shaggy

    Shaggy Guest

    I've always received quick responses from support and is ALWAYS my first contact when I have a problem with software. That is what we pay for. When I hear back from support I usually post in the forums incase someone else is having a similar problem.
  12. danmitrea

    danmitrea Guest

    Is this problem solved?
    I have the same problem and I'm looking for a solution.
  13. davidsaliba

    davidsaliba Guest

    Hi guys.
    Regarding this 2X Universal Printing broken on 2008 R2 I would like to mention a few points.

    1) 2X are aware of this issue and are working on a solution.
    2) We have many clients using 2008 R2 successfully and this includes the 2X Universal printing.
    3) We do full testing on 2008 R2 regularly on newly installed machines using fully patched OS no particular settings just a terminal server profile and NOT Domain Controllers since the execution right on DCs are different..
    4) We have only managed to reproduce this issue once and we do have a workaround for it (see later).
    5) This issue appears on a very small percentage of systems depending on the roll outs.
    6) For immediate response kindly make sure you open a support ticket. Your ticket Will be answered.

    Workaround :

    Only 2X Universal Printer should make use of XX Port monitor.

    a) Check all printers and make sure they are not using this port.

    (In the next steps VDS might be named ASLB depends on your product)

    b) Under your C:\Program Files\2X\VDS\VirtualPrinter\x64 locate the file setupdrv.exe
    c) This needs to be run under 2008 compatibility right click on the executable from explorer and set it so.

    from the cmd run as administrator
    d) Use C:\Program Files\2X\VDS\VirtualPrinter\x64\setupdrv.exe /U to uninstall the printer.
    e) Run C:\Program Files\2X\VDS\VirtualPrinter\x64\setupdrv.exe. to install the printer.
    f) Test universal printing.

    ( On some systems restarting the server appears to cause the failure to re-present itself. So if you need to restart your server you might need to repeat steps d and e )

  14. btsnc

    btsnc Guest

    We have tried the work around and the printer is still not working. Does anyone have another solution to this problem? We really need this universal printer to work.

  15. pilotsoft

    pilotsoft Guest

    Thanks it worked for us ..

    The guy above hit the nail with the "NOT Domain Controllers" part since the issue was we had an all in one machine !! including the TS and the VDI and DC hardly a desireable setup.

    We setup on an new 2008 R2 VM tested with it not in the domain at first and it worked fine added to the domain and added GPs and needed abit of tweaking there.


    hope this helps
  16. deltyme

    deltyme Guest

    I am also having MAJOR problems with printing. Windows 2008 x64 R2

    John Olinger
  17. mikaelshim

    mikaelshim Guest

    Not much in means of "fixing" has occured since my initial post.

    The claim that this is a "rare" effect of 8.1 on 2008 R2 seems abit bs to me. I have had it reproduced on several
    2008 R2´s, different HW, different setup. None has been DC´s

    Sure the "workaround" works although it presents quite a few other problems:

    1. NOONE must be logged on to the system via 2X when you do it
    2. NO 2X AS processes must be running, u have to manually kill all along with kicking out any live or idle user sessions connected.

    3. If there are failed documents in the 2X univ printerqueue u need to uninstall the printer first.

    4. The problem _CERTAINLY_ seem to introduce the same problem again every time the server reboots, i think all systems affected by this "bug" have had that issue.

    Not acceptable in production environment. My client grew tired and changed to Terminal Services Unlimited 3.0 which apart from its debatable but claimed legitimacy pretty much works without any problem at all when it comes to the Universal Printing feature. There are other Universal printing solutions working fine aswell available (use Google) but they are hardly for free.

    2X inability to adress this issue, which i think is by far more important then alot of the other enhancements and "fixes" development hours have been spent on since the first beta was made available. Has unfortunately quite greatly affected my feelings towards 2X on a whole. And the attention to this problem has been pretty sub-par. However i have not lost faith completely and i hope to see this serious issue solved soon.
  18. pilotsoft

    pilotsoft Guest

    Hey guys this seems to work too on a machine that is not DC I had the same issue :

    this helped:

    following davidsaliba's "workaround" : viewtopic.php?f=3&t=3570&p=12986&hilit=universal+printing+under+2008#p12986

    1. NOONE must be logged on to the system via 2X when you do it
    2. NO 2X AS processes must be running, u have to manually kill all along with kicking out any live or idle user sessions connected.
    3. If there are failed documents in the 2X univ printerqueue u need to uninstall the printer first.
    4. The problem _CERTAINLY_ seem to introduce the same problem again every time the server reboots, i think all systems affected by this "bug" have had that issue.

    see post here: viewtopic.php?f=3&t=3570&p=13110&hilit=2008+R2#p13110

    Thanks for this mikaelshim.

    These hints worked for me .

    p.s. did not happen when restarting !!

    I had to be domain admin when installing... so . maybe a credentials allowed when they push is screwing up...

    Hope they sort this out.. it the only bad thing I encountered till now the res of what I tried including VDS work fab...
  19. davidsaliba

    davidsaliba Guest

    Hi mikaelshim ,

    While your hints on improving the interim solution are appreciated, I assure you we are doing what we can for this issue.

    There are large changes taking place in the printer system and this type of delay shall not need to happen again.
    In 2008 R2 there have been massive changes that effected parts of the technology used up to 2008. The issues are not even consistent and vary from one setup environment to another.

    Thanks for the comments and the patience.
  20. davidsaliba

    davidsaliba Guest

    As a workaround for the printer needing to be re-installed on startup the following might help:
    create a batch file with steps d & e above :

    Then using the scheduled tasks add the batchfile to run at system startup, make sure you disable "run only if logged on" rest of the options are self explanatory in the wizard.

    Simple but I hope this helps.

Share This Page