2X Universal Printing broken on 2008 R2

Discussion in 'Parallels Remote Application Server' started by mikaelshim, Mar 8, 2010.

  1. davidsaliba

    davidsaliba Guest

    Then you might not have upgraded the TS with version 8.1.905.

    It should now be set to C:\WINDOWS\system32\spool\PRINTERS\2XSpool

    Then pushing the agent, make sure no one is connected and all sessions logged off.

  2. nxtgen

    nxtgen Guest

    2010-08-25 23:29.27.185: Job#129: EMF file found #1 size=1020
    2010-08-25 23:29.27.185: The 2X Universal Printer printing agent was not found.
    Please reboot computer or re-install the application.

    I've done both. Reboot and reinstall the agent with the same results.
  3. davidsaliba

    davidsaliba Guest

    And with 905 you still did not manage to get the key set properly ?
    very strange ...

    I shall try here and see if I can come up with something that breaks this !

    Will let you know if I find anything.

  4. nxtgen

    nxtgen Guest

    Correct, on 905 the key was not there so I created it manually. Once I created the key, then the log error message changed and that is what I posted above. So now the key is there but it says it cant find the printing agent.
  5. preterion

    preterion Guest

    Hi everyone,

    I wasn't sure if I should start a new thread or not so please accept my apologies if I post in the wrong place.
    I have almost exactly the same problem with 2x Universal printing and maybe this can bring a bit of new information into the issue:
    I have a Windows 2003 Terminal Server that had to be re-joined to an identically named domain after a major crash of the SBS server. Multiple problems after that, as you can imagine, but everything is sorted out except printing with 2X Universal Printer.

    2X was installed ONLY after the re-joining so I have no idea if it would have worked before. Version: 8.1 build 930

    I first checked the registry keys:
    HKLM\Software\2X\Universal Printer\Client Application = C:\Program Files\2X\VDS\\2XPrinterRedirector.exe (note the double "\")
    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\2X Universal Printer\Spool Directory = <BLANK>
    I tried editing it as per one of the posts and all I got was Error 3 instead of Error 2 in the log file.
    When printing to 2X Univ. Printer, a couple of files are created in the default spooler folder. However, the log file shows "error 2"

    I would appreciate if someone could make some suggestions what to try next. The client is eager to use 2X and replace Citrix and they would love the UNiversal printing so any help will be greatly appreciated.


Share This Page