3.0 and CPU utilization

Discussion in 'Parallels Desktop for Mac' started by Neuron, Apr 8, 2006.

  1. non-troppo

    non-troppo

    Messages:
    51
    Shubb, have you tried turning off sound and USB to see if that reduced your CPU load?

    Testing on a friends 3.0 demo:

    * Fresh start of XP, no running apps: parallels uses 13% (V2.5 uses ~11%), But it is quite variable.

    * Windowserver goes up to 100% use once in a while, OS X mouse (outside the VM) loses control / jumps about. Cannot use OS X at all while this happens, even app switching stops working.

    * Paused and hidden, Parallels uses 2.6% CPU (V2.5 I got down to 1.3% with turning sound support off).

    Generally performance is not too great in my very cursory 2nd-hand experience -- just playing an MP3 for example shot CPU up to ~48% in the host!!!
     
  2. shubb

    shubb Bit Poster

    Messages:
    15
    Yeah, I have tried that and it helps, but that is a workaround, not a solution to the problem.
     
  3. Rachel Faith

    Rachel Faith

    Messages:
    234
    This 3.0 is the biggest HOG of RAM I have ever seen in any app PERIOD. Its nearly UNUSABLE and takes 20 Minutes to BOOT when that green disk light will finally SHUT OFF.

    PISSED PISSED PISSED !

    I should have NEVER upgraded....
     
  4. kououken

    kououken

    Messages:
    2
    GoogleTalk one possible culprit

    Just thought I'd share my experience with the cpu activity problem, in hope that it might help someone working on the problem.

    I'm running a WinXP guest on the Mac Mini Core Duo, and have always had between 30-40% cpu usage from parallels; this spread out evenly between the two cores, but still 30-40% total. Disabling USB, Network, etc troubleshooting, never lowered the usage more than about 5%, but one thing that did make a huge difference was Google Talk.

    WinXP Idling without google talk running = Parallels at 7%

    WinXP Idling with google talk running = Parallels at 35%

    Even though task manager says the processor is near 0%, parallels is burning up 35% of two cores dealing with google talk (in my case at least). Logging off or disabling network connections didn't make a difference. As long as Gtalk was up, so was cpu usage.

    Not sure if this helps to solve the problem, but thought I'd share. Can anyone else confirm this?
     
  5. mmischke

    mmischke

    Messages:
    155
    Same here. I disabled USB & sound and was seeing ~7.2% utilization at idle with 3188 (XP image). Now I'm seeing ~10.1% with 4128. Virtualization will always have some overhead and I'm pretty happy with these numbers.
     
  6. non-troppo

    non-troppo

    Messages:
    51
    shubb: I didn't mean to imply the workaround was acceptable ;-)

    Rachel: If you backed up your VM, you can roll back to V2.5... Not everyone is experiencing these issues either. Are you using a bootcamp partition or stright VM? And RAM usage appears much improved in V3.0 in the little I tested it, much better than V2.5 - the problems I saw were clearly CPU related.
     
    Last edited: Jun 13, 2007

Share This Page