3188 Problems

Discussion in 'Parallels Desktop for Mac' started by maynard, Mar 14, 2007.

  1. austinso

    austinso

    Messages:
    9
    migrating 3188 VM to 1970 VM?

    Hi.

    Just wanted to know if anyone has done this. I have been using Parallels since the end of July 2006 (I think I started before the 1970 release), and have diligently updated with each release without a single hitch.

    I have absolutely had no problem with Parallels until the 3186 and the 3188 release.

    I run a Macbook (black) with 2 GB ram, and had allocated 1 gb to Parallels (I know it is high, but I have never had a problem with performance) since the 1970 release.

    I have never used a bootcamp partition (I never saw the point).

    I suppose I wouldn't be so annoyed, but my computer (!) became increasingly unstable with these recent releases, even to the point that I've had to reinstall OSX on top of putting in a fresh VM. I have continuously used the shared folder to write files to and share across OSX and XP pro.

    Of course, it may have nothing to do with Parallels, but as I said, I never had a problem until now. And today, I'm finding stability issues yet again.

    I absolutely love Parallels, and it was the reason I dropped the PC. But I'd rather have something rock-solid rather than gimmicky...so aside from creating yet another VM with 1970, can anyone suggest a method to migrate down a VM created in 3188 to 1970?

    Cheers

    austin
     
  2. Hugh Watkins

    Hugh Watkins

    Messages:
    943
    my own MacBook Pro is boringly stable since June 2006

    just use the Parallels defaults

    have you got enough memory on the HD?
    I just got a LaCie fire wire disk from the apple store and removed many gb of files

    31 gb free out of 111 gb hard disk

    I moved all my parallels clones onto the firewire disk
    and deleted the originals

    cloning Parallels took a lot of space

    but one good back up of the latest version is essential
    "just in case"

    Hugh W
     
    Last edited: Mar 19, 2007
  3. austinso

    austinso

    Messages:
    9
    So I had actually tried just reloading the VM created in 3188 in 1970, and it refused to modify the settings because it did not want to overwrite the newer settings with the older ones.

    I suppose that I can just create a VM copy everytime I use it, but that is not the issue. The main issue is that my computer is becoming unstable. And it appears to relate to the 3186/88 release of Parallels since that is the only change I have made to my system.

    Austin
     
  4. rhys

    rhys

    Messages:
    5
    3186 and Warning message

    I upgraded from 1970 to 3186 yesterday and everything seemed fine. Today when I run the VM with a shared folder turned on I get a Warning message that says:

    "Virtual machine cannot be started because of the following Problem: Unable to get the geometry of the virtual hard disk. Perhaps... is not a valid virtual hard disk image file."
    (... is a listing of my hdd file and it's location) and there is an OK button in the lower right of this Warning message/box.

    In fact the virtual drive with XP is loaded and functioning - if I click on OK a configuration window appears and says "Stopped" then lists my configuration. If I close that window everything continues to function - apparently normally.

    I have two pvs files - one to have the shared file function turned on and one to have it turned off. With either pvs everything seems to be normal untill, with the on one, I try and open or use the shared folder. When I do the warning message/box appears - I am able to access and use anything in the shared folder though.

    Anyone have any idea what is going on - how to stop this - what I have done wrong - am I taking a chance on damaging my data or my VM setup?

    New Parallels Tools Installed after upgrade. MBP 2GB mem 384MB for VM XP SP2 with all updates. Am running the VM on an external Firewire HD which never caused a problem under 1970.

    ***Same thing just started on the setup with shared folder turned off. It now happens as soon as I run any of the programs under XP.

    ***Raising mem for VM to 512 doesn't help.

    ***Only seems to be some of my programs that cause the Warning box to appear - so far only Quicken 2005 and TomTom Home. Firefox and Valueline Analyser work and connect to the internet without causing the box to appear.

    Any help appreciated!

    rhys
     
    Last edited: Mar 19, 2007
  5. Hugh Watkins

    Hugh Watkins

    Messages:
    943
    you do not define the memory issue of your computer

    1gb is wrong out of 2 gb

    best 300 to 500 mb

    Hugh W
     
  6. drval

    drval

    Messages:
    490
    I'm finding that 768 is working quite well for me. I had been using 1GB but I think that 768 is actually working better than 1GB and better than 512, at least on my MBP C2D.
     
  7. mmischke

    mmischke

    Messages:
    155
    I've found that 1 GB for XP & 1 GB remaining for Tiger is just about perfect (Mac mini 1.66). I use Tiger heavily all day for 'regular' stuff and XP (VM) all day for .Net development. Seems like the perfect balance. No lag on either side. FYI - I don't use Coherence, since I rely on having a Windows desktop available to me. This may partially account for my positive experience.
     
  8. ChrisG

    ChrisG

    Messages:
    5
    I had the same problem...coherence not working. I followed advice for un-installing Parrallels Tools from within add/remove programs in Windows. Then re-installed them and coherence seems to work fine again. I'm on 3188.
     
  9. ricardo

    ricardo

    Messages:
    23
    I've received a reply from the Parallels team about the processor usage - they said it was a bug and would be fixed in futur eversions. I've asked if they have an idea of the fix timeline, I'll let you know if I hear back.
     
  10. rhys

    rhys

    Messages:
    5
    Problem solved -
    1) Parallels prefs was pointing at a generic location for the hdd file even though it was loading the file from the location I use. Since I travel I have an encrypted dmg file that opens with all the parallels files.
    So - I pointed parallels prefs the right way.

    2) Then on startup parallels informed me that the fdd file was unavailable and asked if I wanted to continue without it. If I said yes then everything worked as it should.
    So - the next time I started up and it asked again if I wanted to start without the fdd I said no and repointed it to the fdd that existed in my opened dmg and everything now works purfectly(sic).

    If any of this doesn't make sense to anyone having the same problem - if I'm not absolutely unique in this then let me know in this thread. I will try to keep my eye on it for the next several days - and then only every so often.
     
    Last edited: Mar 19, 2007
  11. rhys

    rhys

    Messages:
    5
    Not sure why my 2 posts were moved here - they have nothing to do with 3188, they should not have been split, they had nothing to do with a memory problem as it now appears.

    I hope it wasn't to make a legitimate upgrade problem disappear - and I admit I have no reason to suspect that. Just bafflement why it ended up here at the end of 4 pages it has nothing to do with.

    rhys
     
    Last edited: Mar 20, 2007
  12. mkstevo

    mkstevo

    Messages:
    40
    Not sure how some of my posts were collated into this list of 'general moans' . I am not entirely convinced that it will have the desired effect , probably just annoy the hell out of the developers ( then again , that might be the intention of the author ... ) .

    I do have a problem using USB flash disks with 3188 , but I have a more than satisfactory solution , and await the new build with interest .

    I run 3188 on a Mac Mini with just 512Mb RAM , and find it runs at a reasonable speed . I can't say that it seems that much slower than any other builds . I would recommend that if using Parallels on a low memory footprint to run a Windows XP machine , don't allocate more than 128Mb RAM to the VM , if you try to allocate more it will slow both the host ( OS X ) , and the guest ( XP ) down to a very slow crawl . Your experience may be different , but 128Mb works very well for me .
     
  13. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Only tell them what you need to... And maybe a little more if it slants things in your opinion. Just figure out how they tick and then act... I am usually very successful in getting things from the call centers when I need them, just remember, they ARE humans just like you are. They ARE operating in a system where they have certain procedures they MUST follow or lose their job, seeing they are human, they want to keep their job. If you need to get to a higher level or manager, explain any common procedures that you have already done, follow the basics they have to make you do, assure them that they have helped you 'as much as expected, and you will be quite happy if you can now be transfered over to *insert manager or higher level of technical support'. It works like a charm. If they don't help out, thank them, hang up. Call back. If you have a long period on hold, complain about it to the manager and the 'extra calls needed to have your product resolved'. They usually will compensate you for wasted time, I just got a Treo 700p instead of the 650 I was replacing under warranty because of the pain I had getting to the right department. Where I pulled all that from, go figure.

    Anyway, 1 GB is pretty paltry, I don't even like running OS X with that... Get 2 GB, min. is my reccomendation. It will run like a high-end PC at that point. We dedicate about a GB to the VM on our machines. On my Server I give it 2 GB of dedicated memory, with a shared pool of 1 GB and then 2 GB dedicated to my OS X Server side. The thing is screaming fast, on both the Windows AND OS X side... It renders web pages so fast, I can remote in wirelessly with ~1ms ping to the server and it will load the pages faster in the remote desktop Safari browser than in Safari or Firefox on my G4 17" 1.66 GHz 2GB Laptop... Windows is the same way, making exception for it being windows, but it runs faster than machines with MUCH higher specs than is dedicated and shared to it.
     
    Last edited: Mar 21, 2007
  14. LCPGUY

    LCPGUY

    Messages:
    49
    Running 10.4.9 and 3188. No problems and speed is fast!!!
     
  15. sparkomatic

    sparkomatic

    Messages:
    2
    I'm using 3188 and have noticed that I have more problems with USB devices now. I use a USB US Robotics modem that was working fine in beta versions. Now, it still works but will usually cause the VM to blue screen after I've been using it for 5 minutes or so. Sometimes it doesn't blue screen at all.

    Also, my Dymo labelwriter has stopped working on 3188 and it worked on the beta builds.
     
  16. blobmaster

    blobmaster

    Messages:
    1
    Same trouble here: :confused:

    After upgrade from 1970 to 3186/3188 with WinXP pro (German) and OS-X 10.4.9 (German):

    Entire system gets slow, even after closing Parallels, OS-X remains slow until reboot.

    Cannot say wich update was the killer, I made both updates quite the same day

    Might be in connection with the use of certain programs in OS-X (Firefox, Mail, Preview, SMC Fancontrol ...), but I'm not sure about this.



    System:
    Macbook pro Core Duo
    2GB Ram (1 GB assigned for Parallels)

    Parallels 3186 (3188 the same, went back to 3186)
    WinXP SP2 pro German with MS Office 2003, Autocad LT 2005, Rhino 4)

    OSX 10.4.9 German Edition
     
    Last edited: Apr 10, 2007
  17. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Here are some things to try, pick the order:
    Bump down your RAM allocation.
    Try wiping Parallels off your system then putting it back on.
    Run some utilities like Onyx.
    Run a directory re-builder like Disk Warrior.
    Repair permissions.
     
  18. cmassari

    cmassari

    Messages:
    3
    3188 & Boot Camp Problems - freezing, intalls, etc..

    I am sure there are multiple ways to trouble shot this is just a recap of my experience and some things that helped.

    Longtime Mac OS and Win OS user - no computer genius but believe I have a significant amount of knowledge and experience.

    New MBP 15 inch, 2.33 Ghz, Intel Core 2 Duo, 200GB hd, and 3gb ram.

    Set Up Boot Camp Win XP SP 2 Partition using v1.2 and a 32GB partition with FAT32. For the most part this works well without problems. Had some issues installing the Mac Drivers, but straightened this out.

    First let me give parallels some props - when it works it is amazing. It is fast and performs how I believe everyone imagines it should, etc… The problem is what about when it doesn’t work, and what kind of damage it can cause.

    I have had many problems with Parallels 3188 and installing and using it with the boot camp partition as the VM.

    Problem #1: Installation
    First - Mac partition is humming, working perfectly, and all maintenance and os software (and firmware if necessary) is up to date.

    Second - install Win XP SP 2 using boot camp v1.2 Before installing Mac drivers, but after the win xp is installed do at least one manual shutdown and restart.

    Third - install mac drivers. Important let the mac disc made with boot camp do all the work. Do not hit cancel or touch any tabs except the certificate tab that asks if you want to install the video driver, etc.. choose install it anyway as the instructions direct. When it is done do not let it restart - say no. Then do a manual power shut down and power up. (If you hit cancel or screw up the driver install risk getting a system 32/DRIVERS/pci.sys error. If you get this then just start over. Destroy the partition using the boot camp utility, restart the computer, use bc utility to make a new partition, install XP fresh, etc..)

    Test the Mac OS and Win XP functionality - once you are convinced your Win XP is working perfectly and you can boot and reboot into each without problems then you are ready to try and install Parallels.

    Parallels install - follow the directions for custom install using boot camp partition as VM.

    Starts off rather positive and innocently. The initial install of parallels tool and drivers goes through flawlessly. Then the trouble starts with when parallels tries to restart the virtual machine following the initial tools and driver install. It appears to boot up - you see the Win XP logo but you never make it to the welcome screen. It freezes on a BLACK SCREEN, and when I say freeze I mean it freezes everything - the virtual machine and the mac os. The whole thing locks up! The only thing to do is a hard restart.

    **Warning** Lesson #1 if you ever have to shut down parallels VM in any fashion other than using the Windows XP start menu - shut down - turn off method. Then boot back to Mac OS. Never boot to the Win XP after an improper shutdown in parallels VM. If you do then you will almost certainly destroy your Win XP install and have to start all over. The parallels instructions hint at this but do not emphasize it enough. NEVER GO BACK TO WIN XP NATIVE BOOT UNTIL VM HAS SHUT DOWN WIN XP PROPERLY!!!

    I found this out the hard way on more than one occasion. Along these lines also make sure you are aware what OS boots at startup and be read to push the alt/option key if necessary. Once Parallels froze and I restarted it after a hard reset, and I forgot that it was set to boot to Win XP and I wasn’t paying attention so of course it booted to XP caused a major error and destroyed the partition. Had to start all over - do not try fixing the error (usually a system 32/hal.dll is corrupt or missing error). I spent a whole day trying to fix it. Although there are many fixes to this on the internet none pertain to Parallels and it is the bad shut down in parallels that caused the problem. For some reason if you correct this problem (discuss later) before returning to native XP boot up then no harm done, but if you try a native XP boot up before fixing the parallels vm xp problem then you are screwed and just start over from the very beginning. i.e. erase the partition, reassess the partition, new/fresh xp install, etc..

    So what to do when Parallels VM freezes everything and have to do a hard restart?? Do not panic as I did multiple times. Recovery is possible.

    First - boot back to Mac os. Thank goodness my Mac os has never been compromised in all the problems I have encountered.

    Next try running parallels again. Sometimes you will get errors saying it couldn’t access boot camp or file can’t be found and your VM will not start up. Annoying but luckily not the end of the world - another trick I found from member fso (posted on 3/15/07) is that you should not use the desktop shortcut/alias to start the program. Bizarre but it is true! Just get rid of that thing and go to your applications folder, parallels folder, and find the icon to run parallels (drag it to your dock for convenience). Parallels seems to run much more consistent and stable if you start it using the icon in the parallels folder. If this doesn’t work then create a new Virtual Machine. At a minimum a new VM has always allowed me to start XP in a VM again and then shut down properly. Once shut down properly within the VM, XP can be booted natively, and it works fine.

    Summary and Few pointers:
    1. If you get the BLACK SCREEN of death in parallels XP VM then perform a hard reset and boot to MAC OS only and follow the suggestions above. You can always create/install another VM. As long as you do not access your Boot Camp XP partition via a native boot until there is a proper VM XP shutdown, then everything should be ok and Boot Camp XP should not be damaged, etc…
    2. NEVER boot to Win XP (boot camp partition) after a parallels XP VM session ends with an improper shut down!!
    3. Do not activate windows xp until you have parallels VM up and running. Then activate it first over the internet while in a parallels VM session. Should be no problem, then activate it again next time you perform a native boot into your XP partition. This should prevent having to call MS for a activation number.
    4. Do not install XP Software or do XP updates etc..through the parallels XP VM interface. Always boot natively in to the XP partition (boot camp method) to do installs, updates, etc..
    5. Access/Start Parallels by using the icon in the parallels folder located in the applications folder.
    6. I find that if I end a VM session and it shuts down properly, no freezes, etc.. If I want to start a new VM session then I first shut down/close parallels, then reopen it using the correct icon, and then start the VM session. I find that this method is more stable. Sometimes if I just hit play button without closing Parallels it has a higher tendency to freeze on start up.
    7. When closing a VM session always use the XP start tab, shut down, etc.. Never chose restart - my experience is for whatever reason parallels tends to crash more with restart. Even if I want to restart - I choose shut down (and as stated above) - after proper shutdown I close parallels and then restart it and then start a new VM session. All a pain in the … but this what I have found leads to the most stability. Using restart etc.. is not a problem when using boot camp to natively boot into the XP it is only when using the parallels VM XP
    8. All of the Parallel problems I have experienced are at Startup or Shutdown (except for the install issue which was kind of a Startup problem). Once the VM XP session starts properly and windows desktop appears I have not had any problems with one exception - I tried updating Win XP and it froze. That is why above I recommended that everyone performs installs and updates etc.. by booting natively to the XP os using boot camp method.

    I think that is it. I hope this helps people and it is not too confusing. Excuse grammar and typos - I just tried to put this together quickly.
     
  19. Resolver

    Resolver

    Messages:
    37
    Thanks for a useful tips!

    Thank you for a very detailed letter . Will be very helpful.
     

Share This Page