3D acceleration breaks rendering in ROS2 Ignition Gazebo on Ubuntu 20.04

Discussion in 'Linux Guest OS Discussion' started by LandonH, Jun 17, 2022.

  1. LandonH

    LandonH Bit Poster

    Messages:
    1
    When trying to run a simulation in Ignition Gazebo (a ROS2 simulation environment), 3D acceleration causes the renderer to output garbage. When 3D acceleration is turned off, it looks fine, but it is incredibly slow (obviously, because no 3d gpu acceleration).

    This is happening on a 2019 16" MBP with i9 and Radeon Pro 5500M (4gb). Screen Shot 2022-06-17 at 3.47.01 PM.jpg Screen Shot 2022-06-17 at 3.54.16 PM.jpg

    Any ideas?
     
  2. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    163
    Hello @LandonH, Please refer to the below steps and check.
    > Virtual Machine's Configuration > Hardware > Boot Order > Advanced Settings > Boot flags.
    Under Boot Flag attach below flags:
    video.metal=0
    video.untrimmed_dynamic_cbuffers=1
     

Share This Page