4560: Is It Safe?

Discussion in 'Installation and Configuration of Parallels Desktop' started by rbienstock, Jul 24, 2007.

  1. tonydenson

    tonydenson Member

    I noticed this - it took me 15 hours to compress, is this normal ?
  2. dkp

    dkp Forum Maven

    Just got back from vacation and saw a new build is available. Installed it and it immediately killed Fusion. I've blown enough of my life trying to make this sow's ear a silk purse. I'm giving up on Parallels - they just don't seem to learn from their mistakes and support is as good as ever. Time to move on.
  3. saywake

    saywake Bit poster

    works for me

    Considering there are only a few people on this thread with serious issues, it seems that your risk isn't so high, considering a simple backup will protect you from losing anything in the upgrade.

    It works fine for me; I haven't had a single issue with this build.

    Remember, the most vocal people are generally the (few?) people who have found problems; likely there are lots of people with no problems that don't bother to report back...

    Low risk, IMHO
  4. David5000

    David5000 Pro

    Coming from you, with your long history of knowledgeable and constructive criticism of all aspects of Parallels, I take this seriously.

    I have been happy using PD 2.5 with XP Pro and limited Windows activity, but am less and less certain of what the future will bring. Your post has convinced me to hedge my bet with a $39.99 Fusion pre-order.

  5. whytyger

    whytyger Member

    Parallels has a death wish?

    It is quite astounding to me that Parallels would release an update to a shipping product that seems so fundamentally flawed. To those who say that "only a few people are experiencing these problems" or that those who are using it in a production environment are foolhardy because virtualization is a new technology, I would observe:

    1) Virtualization is not a new technology at all. Macs have had it for many years with SoftPC, even before MS bought it. And it is standard on many Windows servers. It's actually a very mature technology.
    2) Only a minority of people got polio, even during the height of the global epidemic. This didn't prevent researchers around the world from working night and to find a cure.

    Parallels has only acknowledged these problems in an obscure post, in which they promise a fix. Otherwise, dead silence.

    Meanwhile, Fusion is solid as ever in its RC1 incarnation. Though it lacks bells and whistles, and a few important features, it represents a serious threat, since it is scheduled to ship at the end of August. Hence even if Parallels were working perfectly, it would be very vulnerable.

    Under these circumstances, it's difficult to understand how Parallels could fail to catch these problems in house before releasing the update; then fail prominently to acknowledge them or offer work-arounds (such as uninstalling and reverting to an earlier version). It seems that they simply do not take their business or their reputation seriously. I certainly hope they are having fun, because their users certainly are not.

    I reached the conclusion that dkp did some time ago, and switched to the competition, all the while hoping that Parallels still might get its act together. I am very sad to see these signs of a death wish. The market always benefits from competition, especially from a plucky upstart.
  6. deepyogurt

    deepyogurt Bit poster

    Parallels crashes when Mac sleeps

    I had the problem with Parallels Desktop crashing whenever the Mac went to sleep and the way I "fixed" it was to set the sleep time in Parallels to be less than the time the Mac OS X was set to sleep. Have had very few problems since doing this in 2.5, and upgraded to 3.0 a few weeks ago, then to the 4560 upgrade two days ago, and still no problems with sleeping and crashing. This way, Parallels has already put itself to sleep when Mac OS X goes to sleep. Then when the Mac wakes back up, the Parallels is still in its sleep mode, and then the only thing to do is to wake it up.

    The only issue I have so far with 3.0 in general is the idea of having to use the "Control-Option" key sequence to move from the Parallels window back to Mac OS X windows. Seems like there would be a way to have the Parallels stuff in it's own window that works more easily with the Mac windows. And am still wondering why I can't use the "Rate this computer" in Vista and see how well my Mac compares with a real Vista system. More of a curiosity than an issue but seems puzzling to me why this does not work.

  7. AngryAnt

    AngryAnt Member


    Sounds like I'm one of the lucky ones once again. I've seen 3.0 crash two or three times since it came out and I use it frequently (considering having it added to my login items). I run the latest build on a mbp core duo (not c2) with 1.5g ram and a 32gb fat32 bootcamp partition.

    I run some custom office programs, eve online, hitman 1-3 and quake 4.
  8. vkeven

    vkeven Bit poster

    I'm also using parallels 2.5 and all this saga of buggy 3.0 version have pushed me to fusion , if someone want a free and probably not more buggy than parallels use Q the qemu emulator port for OS X and let dying this stupid swsoft company , at least if you help debugging Q you will end up with FREE great emulator

    Last edited: Jul 31, 2007
  9. slantyyz

    slantyyz Junior Member

    Dude - SoftPC is emulation (i.e., emulating x86 on 680x0 and PPC), not virtualization. MS bought Virtual PC (Connectix) which was also an emulator, though Virtual PC and Virtual Server on Windows actually perform virtualization. Virtualization is relatively new on the Mac but mature on Windows and Linux. IMHO, the Virtual PC family on Windows is inferior to VMWare's offering.

    SoftPC was from Insignia, which was not purchased by MS.

    Normally, I'd ignore a comment like yours, but in these forums, too many people would probably take your statement as fact.
    Last edited: Jul 31, 2007
  10. time ed

    time ed Bit poster

    I installed a trial version of 4560 yesterday on a dual-boot core2duo running 10.4.9. Second partition is Vista. After the install Parallels found the Windows partition and created a guest called My Boot Camp. It looked like it was configured to boot from the physical drive (what I wanted). As soon as I clicked start for the guest, the OS crashed. I got a black screen that read "you must restart your computer..." in several languages.

    After the reboot I uninstalled then reinstalled. Same result. I uninstalled for good and I'm thinking about reloading the OS after reading this:

    Anyone else heard of this? I'm new to Macs so I'm not sure where to look for left over files and dump logs.

    All the talk about Fusion. Its not much better. I tried the latest RC and starting vmx puts the CPU at 50% on both cores. Its a common problem with a long thread about it and a lot of complaints on the Fusion forum.
    VMWare says they can't reproduce it. Very suprising. I've been using rock-solid Workstation 5 on Fedora years.
  11. sidssp

    sidssp Hunter

    Build 4560 did fix a number of bugs. Except for some problems installing Parallels Tools on Win XP Boot Camp partition at the beginning, it has been running fine so far. But I mostly run Fedora 6/7 VM and I don't run games so my experience is limited.

    If you have been experiencing random crashes, please make sure you do a memory check. I have seen so many memory problems that didn't manifest itself until VM is running.
  12. time ed

    time ed Bit poster

    @sidssp -- I don't understand 'memory check'. Its a brand new machine with 2Gb. Everything else runs fine.

    The crash wasn't random, it was immediate. I never got to use the product.
  13. sidssp

    sidssp Hunter

    Sometimes even a band new machine may have memory problem. Memory problem may not be complete failure. It could be just a stuck bit at a few memory addresses (e.g. a bit is always one even it is set to zero) or it couldn't maintain its set value (e.g. a bit is set to one but it will flipped to zero after a while). Problem like these may or may not cause program crash depending on how that memory location is being used.

    To check if you have memory problem, you can download a memtest utility from here:

  14. daigoro

    daigoro Bit poster

    The first time I tried the 4560 upgrade, Windows crashed a minute after restart, every time. So I downgraded, but it still crashed. I had to do a fresh install of Windows (which I've now archived). I then installed Halo (it didn't work, but that's for a separate thread). I then upgraded to 4560 again. Install Parallels Tools crashes every time.
  15. drscience

    drscience Member

    Step 1--Boot into safe mode; uninstall Parallels tools
    Step 2--Boot normally, select custom install of Parallels tools
    Step 3--Uncheck "shared applications"
    Step 4--Allow installation to complete

    If this fails, then install the 5060 beta, which is quite stable and gets around this nastiness; but again, select custom install of tools and deselect "shared applications."
  16. daigoro

    daigoro Bit poster

    drscience, thanks for your reply.

    I decided to go straight to 5060, but that had the same problem: crashes with the Parallels Tools install progress bar at 90%, during the configuration phase ("Parallels Tools is configuring your new software installation").

    I next tried the four steps you outlined. But in step 1 I couldn't uninstall Parallels Tools as I couldn't find them in Add or Remove Programs. However, the install (without "shared applications") completed. But Parallels crashed 10 seconds later. And it crashes as soon as Windows is started.

    I'll try 4128 again tomorrow.
    Last edited: Aug 4, 2007
  17. spectre

    spectre Parallels Team


    Have you tried manually deleting "Windows Shared Applications" folder contents on the Mac side before installing the Tools? Generally this folder is located in "Macintosh HD" - "Documents" - "Parallels" - <your VM name> folder.
  18. Bismarck

    Bismarck Junior Member

    I am shocked by what I am reading on the forum about 3.0. I have been running 3120 for some time now (no idea if that is a 1.x or 2.x since nothing anywhere says). I installed a boxed version, then updated to a download that crashed, reverted, and then got 3120 when it was ready. Hadn't been in the forum for many months, but I visited to research problems running an Office 97 installer in Win2000 SP4 under 3120. Only then did I know about 3.0.

    So I read a lot of horror stories, and I figure I will stick with 3120 because it is stable for my use. New bells and whistles aren't worth being on the bleeding edge. I do wonder though if there is a post-3120, pre 3.0 build that is generally regarded as stable that can still be downloaded ?

    But I am curious about one particular thing in any of the 3.0 builds. The last time I was here, I was asking about the inability of Parallels to inject the CD/DVD tray with the Mac keyboard button. A Parallels developer Ynot had said in October 2006 in this thread http://forums.parallels.com/thread5034.html that it would be fixed "soon". But in January, it was not yet fixed and he wouldn't answer what "soon" meant.

    So is that fixed in any build of 3.0 ?

    Not that the inject issue is a big deal compared to the issues that folks are reporting, but it speaks to me about the support. Someone will point out that I can just push the tray back in, but if Parallels says they will fix it, then they should do it. But more so, they shouldn't have released 3.0 with so many bugs in the first place. And it would be pathetic if such a fix were not available without a repurchase.
  19. Upton O'Good

    Upton O'Good Member

    For me it sometimes keeps the Mac from waking up. I'm not 100% positive that Parallels is the cause, but it has never happened when Parallels has not been running.
  20. daigoro

    daigoro Bit poster

    Hi spectre. Thanks for your reply. I start from a clean install of XP made using build 4128 so only only have a "Windows Applications" folder, but not "Windows Shared Applications".

    I tried a "start from zero" approach, as follows.

    • I noticed the the Parallels uninstaller does not remove a kernel extension: Pvsvnic. Since the uninstaller is not a complete uninstaller, I removed all vestiges of Parallels that I could find, including Pvsvnic, although if they have stuff that is not labelled Parallels, I won't know how to get rid of that.
    • Restarted, and installed 5060 Beta
    • Express install of XP Pro
    • Parallels crashed while Parallels Tools was being installed. (i.e. "Please wait while the OS installation assistant installs Parallels Tools").
    • Restarted, and got the following error from RUNDLL: "Error loading \PrlSAShellExt.dll. The specified module could not be found". When I googled that I read that other than the message, things might work OK now. I hope so.

    BTW, I have determined that even installing Parallels Tools in 4128 will crash, but I have an image that already has Parallels Tools installed.
    Last edited: Aug 4, 2007

Share This Page