Activation Key after Trial doesn't work with v4560

Discussion in 'Installation and Configuration of Parallels Desktop' started by drymaeus, Aug 19, 2007.

  1. drymaeus

    drymaeus Bit poster

    First a quick recap of what happened:
    - I took first a trial of Parallels Desktop at the end of last year to explore the possibilites. Then in April 07 I bought the full licence but - as I could find the registration key of my Windows XP (tucked away some years ago) and was looking around for somebody with a complete copy of both Windows and reg.key - I forgot to register the copy of Parallels.
    - When I requested a resend of my registration details I got quickly a new new download link and reg.key from element5 (the German distributor of Parallels). However, when I installed Parallels Desktop (v 4560) and tried to register my copy, the Activation Key didn't work.
    - I repeatedly emailed the support Dept. of element5, explaining the situation and asking for guidance, but no reply.
    - I uninstalled Parallels, cleaned the Trash and repaired my HD volume with Disk Utilities to make sure that no traces were left.

    When I re-installed Parallels Desktop and tried to register with my Activation failed again! :-(((((((

    Can anybody suggest a cure?

    Thanks, Bram

Share This Page