Add Colemak keyboard layout

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by AtomicLance, Apr 28, 2021.

  1. AtomicLance

    AtomicLance Bit Poster

    Messages:
    2
    Hi, as a user of the somewhat exotic Colemak keyboard layout, I found it was quite a challenging experience using Parallels with Windows on ARM. The keyboard would sync to QWERTY on both guest and host, without asking. Even with layout sync disabled, Windows does not support Colemak natively, and the layout cannot be installed using files from the official Colemak site.
    NB: it would be a good idea to see if the x64 windows works with the colemak layout found on their official website, so I can ask / assist them in making it work on ARM.

    Currently, the only fix I found was to
    1. Disable Kb layout sync: https://kb.parallels.com/en/115200
    2. Use any layout on Win10
    3. Remap keys to suit the needed layout:
    • Use powertoys and do it by hand with the key mapper
    • Remap they keys directly in the Windows registry

    As you can see none of this is simple and beginner friendly, that's why I would really appreciate it if the Parallels team could add a Windows Colemak layout natively, i.e: make another one of the "Apple" layout for Windows.
    I don't think this should be particularly challenging since you already did it for Dvorak, another unusual layout, and many, many other ones :)

    Thanks to the team for their great work !
     
  2. RobertS84

    RobertS84 Bit Poster

    Messages:
    2
    Hi, I am running into the same problem on my X86 Mac.

    2016 MacBook Pro 15 inch.

    I tried disabling the keyboard layout synchronization, but Parallels still seems to be forcing both my Mac as well as the virtual machine into QWERTY.

    I'm waiting on a reply from their support, but I'm not sure how to proceed from here.

    I can verify that this is not just an ARM processor situation though...
     
  3. AtomicLance

    AtomicLance Bit Poster

    Messages:
    2
    Hi RobertS84,

    I'd suggest you shut down the VM entirely (with the VM open, top bar > Actions > Shut-down). Then check that you correctly edited the file config file according to linked documentation (https://kb.parallels.com/en/115200). And make sure to properly save it . Maybe even quit Parallels Desktop just to be sure.

    Otherwise, I don't know what to say, I really hope Parallels team will answer, but sadly it seems they have long left the realm of human-to-human support.

    Personally I'll be moving to VMWare once my licence expires, they have zero tendency to force unwanted "features" onto their customers, and their price is way better, no subscription model yaay Only waiting for proper windows support, but that's right around the corner

    Hope you can solve your issue !
     
  4. RobertS84

    RobertS84 Bit Poster

    Messages:
    2
    I was able to resolve this after a fair amount of frustration.

    Here is what was happening:
    My macOS login screen, as usual, was set to Colemak, so I was able to log in ok to osx.
    Once I logged in my keyboard changed to QWERTY.
    When I went into System Preferences>Keyboard>Input Sources, any change I made there had no effect.

    What I did:
    Disabled keyboard layout synchronization in Parallels.
    Re-added the input source selector back to my upper menu bar ("Show Input menu in menu bar" option in System Preferences>Keyboard>Input Sources). Then I was able to change back to Colemak by toggling the input source in my menu bar. I have no idea why it worked in one place and not in the other...

    Parallels did respond via Messenger before too long, but I'd already resolved the issue.

    I'll look into VMWare as well, I wasn't aware of that option.
     

Share This Page