Aero problems with Parallels 5

Discussion in 'Windows Guest OS Discussion' started by JordiL, Nov 4, 2009.

  1. boardwatchr

    boardwatchr

    Messages:
    2
    Check to see if you are using the Use MacLook Feature under the services option in Virtual Machine Configuration. When this button is enabled, you have windows which look like the Mac's, but the Aero feature is disabled. I guess you can't have both.
     
  2. JordiL

    JordiL

    Messages:
    5
    The MacLook Feature is disabled. The blink problem is still happening.
     
  3. iMac

    iMac

    Messages:
    7
    Screensaver is set to None and MacLook Feature disabled, and I do have the problems.
     
  4. BarronD

    BarronD Bit Poster

    Messages:
    2
    osx 10.6.1
    windows 7 32 bit
    2.16 core 2 duo mac book pro
    3 gb ram
    using full screen on second monitor

    same problem with flicker, no screen saver
    only stopped areo from working once, usually just a black flicker for a couple seconds
    tried non aero theme-- still had problem
    have set to best performance (no areo untill fix is found)
     
  5. marcolago

    marcolago

    Messages:
    6
    Update.
    I'm not really sure if thi is relevant, but...

    In my case, a brand new MacBook Pro, if I set Snow Leopard to use the GeForce 9600M, GT instead of 9400M, the "blink" frequency is dramatically reduced.
    Now the screen blinks only when the system is under performance pressure.

    In any case I think is strange that a "Super" MacPro with 16 GB of RAM and cutting edge hardware all around suffer this problem.
     
  6. JayG

    JayG

    Messages:
    1
    This is happening to me also. In every mode except full screen and windows. OS X 10.6.2; 2.4GHz Intel Core 2 Duo; 6GB 667 MHz DDR2 SDRAM; GeForce 8600M GT GPU.

    Half the time when it does this it changes my active Windows Window ... which makes me start typing in the wrong window.

    A resolution to this would be nice. I am willing to send any diagnostic information requested.
     
  7. JarebB

    JarebB

    Messages:
    1
    Same problem

    I have the same problem. When I turn on Aero, my screen is blinking.

    Any solution?
     
  8. armh

    armh

    Messages:
    1
    Same here, on a trial and can't purchase full license until this is resolved.

    My case:
    - using Parallels Desktop 5.0.9220
    - guest OS: Windows 7 Ultimate
    - using full screen mode.
    - the screen blinks randomly, no fixed interval.
    - the screen blinks twice each time, the first is full black, then the image returns, then another black screen but with some windows shapes on, then correct image again. I don't loose Aero.

    My configuration:
    OSX 10.6.2
    Model Name:Mac Pro
    Model Identifier: MacPro3,1
    Processor Name:Quad-Core Intel Xeon
    Processor Speed:2.8 GHz
    Number Of Processors:2
    Total Number Of Cores:8
    L2 Cache (per processor):12 MB
    Memory:6 GB
    Bus Speed:1.6 GHz
     
    Last edited: Nov 13, 2009
  9. Michael Jackson

    Michael Jackson

    Messages:
    5
    I'll throw my hat into the ring on this:
    MacPro 4,1 (2x Xeon 5500 "Nehalem")
    RAM: 6 GB
    CPU: 2.66 GHz
    Video: ATI 4870 (Came with Machine from Apple)
    OS X Version 10.5.8

    Same flickering as above. Checked all the settings as suggested by others in thread. Sometimes I lose Aero the first time, other times I loose Aero after a few instances of the flicker.

    VM: Windows 7 Ultimate x64 (RTM)
    2 GB and 256 MB to Video
    4 Processors to the VM.
    System is NOT under load when flickering occurs.
    3D Acceleration is Enabled.
     
  10. BJG

    BJG

    Messages:
    4
    Not sure this point was made yet

    Once the flicker happens and Aero turns off, you can get it back again by running the Aero trouble shooter. This can be found by right-clicking on the desktop and choosing Personalize.

    When the trouble shooter runs, it fixes the problem and reports the the "Desktop Window Manager" had been found to be disabled.

    Of course, the fix is temporary until the flicker happens again.

    One final point: the flicker does not always result in Aero being disabled, but it often does.
     
  11. barneythedog

    barneythedog

    Messages:
    8
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  12. nickjkoerner

    nickjkoerner

    Messages:
    1
    aero problems

    My screensaver is off and it still blinks

    My configuration:
    MacBook Pro
    Intel Core 2 Duo, 2,66 Ghz
    Memory: 4 GB
    NVIDIA GeForce 9400M, 9600M GT
     
  13. Olivier

    Olivier Kilo Poster

    Messages:
    610
    Am I right that your VM configuration has 2 cpus?
    Can you turn it down to 1 and see if you still have this issue?
    I don't with 1 cpu, I do with 2 cpus.
     
  14. chienlim

    chienlim

    Messages:
    13
    Happen to me to. A quick fix when it happen is to go to "Personalization" and click on Aero Problem on the bottom of the Personalization window and run the fix process. Windows will then detect program with "Windows Desktop Manager".
    However, it seems like you have to do this every now and then.

    Here is my configuration:
    Model Name: iMac
    Model Identifier: iMac7,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 3 GB
    Bus Speed: 800 MHz
    Boot ROM Version: IM71.007A.B03
    SMC Version (system): 1.21f4
     
  15. Fai Lau

    Fai Lau

    Messages:
    10
    The problem you are experiencing is that the Windows Desktop Manager keeps crashing in the background. Every time it crashes you lose Aero and Windows would restart the WDM and you would then get Aero back. The fraction of the second between it cashes and it bounces back is why you get that blink. Sometimes you lose Aero altogether.

    I found that if I configure the the VM to use only 1 CPU the WDM would not crash. If I use 2 CPU it would. I can't even get Windows to calculate an Windows Experience Index either, as it complaints about video playback failing.

    You can confirm the problem by looking at the event logs using Windows Event Viewer. Look for Error events produced by the Desktop Window Manager.

    I use a MacBook Pro with 4GB running Snow Leopard and Windows 7.
     
  16. marcolago

    marcolago

    Messages:
    6
    Yes! My VM has 2 cpus and with only one I don't have the problem.
    This is a very good hint but I use my VM for developing applications and I need all the computing speed that I cound have.

    So this is not a true solution... but is a temporary patch.
    Thank you.

    marcolago
     
  17. marcolago

    marcolago

    Messages:
    6
    Another thing...

    I run the Windows 7 performance test just now with the VM with a single CPU and I had the same results that I had with 2 CPUs.
    In relation to this problem using 1 CPU seem to solve all the things.

    But... isn't strange that the performance remains the same with 1 and 2 CPUs?

    marcolago
     
  18. BarronD

    BarronD Bit Poster

    Messages:
    2
    Changed config on my macbook pro 2.2 to 1 cpu and the flicker stopped, areo seems to work so far.
     
  19. Michael Jackson

    Michael Jackson

    Messages:
    5
    I went back and changed the number of processors to 1 and I didn't have any Aero problems for the little bit that I tested it (about an hour of on and off usage). Changed the number of processors to "2" and within a few minutes had the "flicker" issue a few times and on the final flicker I lost Aero.

    Mike Jackson
     
  20. teo

    teo

    Messages:
    2
    Same problem here.
    Actually the screen blinks and then comes back. It happens completely randomly and only with aero activated in full screen mode, single or dual monitor setup.

    The strange thing here is that the vm performs much better with aero ON instead with aero off!!!
    I was expecting the opposite!

    My system is a Macbook pro 17' 5.2 (early 2009) running 10.6.2 on a Core2 duo 2.66GHz and 8GB Ram plus an SSD 256GB hdd. The graphics chip I use is the 9600GT chip. Although I think it happens with the 9400 chip as well

    This issue is more frequent when using the second monitor !

    Please do something!
     

Share This Page