After updating Parallels shared folders no longer available in Ubuntu 16.04

Discussion in 'Linux Virtual Machine' started by RyanG2, Aug 10, 2017.

  1. RyanG2

    RyanG2 Bit poster

    Hi everyone,

    I am running Ubuntu Server 16.04 in Parallels to support a local development server for the website I work for. It has always worked as expected, but today I updated Parallels and it no longer works.

    The files I work on are in my Mac OS filesystem in a folder in my home directory. These always were available at /media/psf/dirToFiles, but after this update those my home directory is no longer available. Other things have also disappeared such as the ability to restart the VM (I now have to shut down then start back up) and Actions -> Installing Parallels Tools... is now greyed out. I noticed that on boot there is a failed attempt to update Parallels Tools with a message to run a certain command for more info. Here's what I see when I run that command:

    root@eg:~# systemctl status prltools_updater.service
    * prltools_updater.service - "Parallels Tools Updater"
    Loaded: loaded (/etc/systemd/system/prltools_updater.service; enabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since Thu 2017-08-10 11:23:25 EDT; 55s ago
    Process: 712 ExecStart=/usr/sbin/ -i (code=exited, status=1/FAILURE)
    Main PID: 712 (code=exited, status=1/FAILURE)
    Aug 10 11:23:25 eg systemd[1]: Starting "Parallels Tools Updater"...
    Aug 10 11:23:25 eg[712]: Error: XFree86 server is not supported now
    Aug 10 11:23:25 eg[712]: Error: could not determine X server version
    Aug 10 11:23:25 eg[712]: Error: Can't detect Xorg server version, exitting
    Aug 10 11:23:25 eg systemd[1]: prltools_updater.service: Main process exited, code=exited, status=1/FAILURE
    Aug 10 11:23:25 eg systemd[1]: Failed to start "Parallels Tools Updater".
    Aug 10 11:23:25 eg systemd[1]: prltools_updater.service: Unit entered failed state.
    Aug 10 11:23:25 eg systemd[1]: prltools_updater.service: Failed with result 'exit-code'.

    The main thing that stuck out to me here is "XFree86 is not supported now". I have not had any issues with Parallels Tools in the past so I'm not sure what about my most recent update caused it to cease working.

    When I look in /media/psf I see 3 folders, all of which are empty, and I am unable to link them to real folders on my host filesystem: Flash Player, Parallels Desktop 12 , Seagate Backup Plus Drive. I do own an external Seagate HDD for backups, but this folder has never existed in /media/psf before to my knowledge.

    Has anyone come across this issue, and if so do you have any suggestions for how to get this working? My entire development process and my ability to do new work depends on being able to access the codebase for the website on my host filesystem from within the VM where the server environment lives.

    Thanks a lot for any help you can offer!
  2. RyanG2

    RyanG2 Bit poster

    As an additional note the upgrade here was from 12.2.0 to 12.2.1. Using time machine to restore the 12.2.0 version from yesterday resolves the issue and my home directory files are once again available in /media/psf as they always have been. I'd still like to figure out what the issue is so that I can eventually upgrade if possible.
  3. rkulikov

    rkulikov Parallels Developers

    Can you please provide /var/log/parallels-tools-install.log from the guest.
  4. RyanG2

    RyanG2 Bit poster

    It would not let me attach a file with a .log extension so I've created a gist entry with the contents of the file here:

    Also, here is the contents of /var/log/parallels.log:

    I have 2 machines I use for development that each have a copy of the VM. My laptop had not yet been upgraded so I tested things out on there to start from a working copy. As soon as I upgraded to 12.2.1 the same thing happens. It tries to upgrade Parallels tools and once it shuts down the existing version it fails.

    1. /media/psf does not include files shared through the configuration of the VM (/media/psf/Home does not exist)
    2. Restart option in the Actions menu is greyed out; I have to Shut Down then start back up
    3. On VM starting up the Parallels Tools option in the Actions menu is greyed out also and says Installing Parallels Tools... As seen in the logs it ends with "Shutting down Parallels tools daemon: done" vs the one before which appears to have worked even though it did not.

    Lines 167-169 in parallels-tools-install.log were not added until I shut down the VM (after waiting 30+ minutes to make sure I wasn't cutting it off mid process). While the VM is booted it just stays at "Shutting down Parallels tools daemon: done" indefinitely.

    Basically it starts the upgrade process, shuts down the existing version (thus unmounting my shared Home directory from /media/psf), then never finishes the process. It just dumps my mounted folders and leaves me stranded.

    *EDIT: I'm noticing in parallels.log that it's throwing a warning about I am running Ubuntu Server so I use no GUI, it's command line only. Could it be that the Parallels Tools update does not take that into account and just ASSUMES that I'm using an OS with GUI?
  5. RyanG2

    RyanG2 Bit poster

    I decided to shut down the vm and turn off hardware acceleration in my configuration then try again. Once I did the error message about libGL goes away, but now I'm greeted with a new error: "failed to find out Xorg modules directory"

    Here's the additional parallels.log block post restart:

    It really seems like this is related to the Parallels Tools installer assuming I'm not running an Ubuntu build not designed to utilize a GUI.
  6. RyanG2

    RyanG2 Bit poster

    Ok, so I was able to resolve this issue. I had to install Xorg in order for it to install. The installer was running and when it found no Xorg modules (because I have zero need for a GUI to run a development server) it just failed and never remounted my shared files in /media/psf.

    Apparently the new Parallels Tools install will not work if you do not have Xorg/X11 installed. I understand that a lot of what Parallels Tools does is related to UI, but I'm sure I'm not the only person who uses it to run a server VM with no GUI desired. The main functionality I need is to allow access to my projects on the host filesystem. It would probably be better if this chunk of installs was within a condition that skipped if Xorg is unavailable instead of failing and leaving the previous version unusable.
  7. rkulikov

    rkulikov Parallels Developers

    Confirm the issue. You may workaround it by reinstalling Parallels Tools. For this you need first to remove them:
    $ sudo /usr/lib/parallels-tools/install -r
    and then install normally.

    Thanks for reporting the bug!
  8. MichaelR26

    MichaelR26 Bit poster

    Has this issue been resolved (i.e. requirement for Xorg/X11 on headless (non-GUI) Ubuntu Server 16.04 installations) in either Parallels v12 or v13?

Share This Page