All utility screens of Parallels 14 Desktop starting blank

Discussion in 'Installation and Configuration' started by DvirG, Mar 8, 2019.

  1. DvirG

    DvirG Bit Poster

    Messages:
    2
    Hi There,
    I am running parallels 14.1.2 on macOS 14.1.2
    I currently need to create a new VM, and I have realised that once I click on File - > New (or the + button on the Control Center) I get a screen which has the heading but otherwise blank and can't go further.
    After browsing around the app I found out that these screens load blank:
    Installation Assistant
    Account & License (Header of the windows is actually Parallels Desktop)

    Attempt to reinstall Parallels did not solve the problem.

    I currently need to create a VM, can anyone assist?

    Thanks
     
  2. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    2,687
    Execute the command "QT_QUICK_BACKEND=software open /Applications/Parallels\ Desktop.app" in Terminal then check.
     
  3. DvirG

    DvirG Bit Poster

    Messages:
    2
    Thank you.
    That indeed sorted it.

    Enjoy your day further and thank you for the quick reply
     
  4. AJ@Parallels

    AJ@Parallels Kilo Poster

    Messages:
    752
    You are welcome, Please feel free to reach us any time for any queries regarding Parallels.
     
  5. AlexandreF2

    AlexandreF2 Bit Poster

    Messages:
    2
    Hi, I have kind of the same problem. At opening, I got a blank screen (white or black) and nothing to clic on. Typing don't do anything. 3days ago it worked fine and then, this trouble. I upgraded yesterday to ParallelDT14. Did not solve the issue. Tried the "execute the command "QT_QUICK_BACKEND=software open /Applications/Parallels\ Desktop.app" in Terminal then check." did not change anything.
     
  6. AlexandreF2

    AlexandreF2 Bit Poster

    Messages:
    2
    Sorry I upgraded yesterday from ParallelDT15 to ParallelDT16.
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,801
    Hi, could you collect the tech report once the issue reproduced and share the report's ID with us please?
     
  8. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,801
    Hello @AlexandreF2 we've received your reply:
    Hi, there is the report number 352053780
    I did succeed to open Parallels Technical Data report but no options to do anything were avail. I used Terminal to send it. I hope it will help all of us. Thanks for your time.
    Alex

    We will check it. Thank you once again.
     
  9. Crunch

    Crunch Bit Poster

    Messages:
    4
    this is the closest report I've seen that matches what I am experiencing.
    I upgraded to Parallels Desktop for Mac 16 a week ago.
    When I try to open any previously working OS image, it pops up the window
    for first time usage, to verify that I am paid up to date. But that window (heading "Parallels Desktop") is blank.
    It's the same window if I click "Account & License" from the title bar or from the "About Parallels" popup.
    the suggested Terminal input does not look like a shell command to me.
     

    Attached Files:

  10. Crunch

    Crunch Bit Poster

    Messages:
    4
    OMG.
    I use tcsh as my shell, so the commands are (2 lines, or with a semicolon between them on one line)
    setenv QT_QUICK_BACKEND software
    open /Applications/Parallels\ Desktop.app

    for bash it might be
    QT_QUICK_BACKEND=software
    open /Applications/Parallels\ Desktop.app

    and I haven't done it yet but I probably need to put
    that first line in my .tcshrc
    for it to work all the time, including by clicking on an icon.
     
  11. MarkH47

    MarkH47

    Messages:
    1
    OK, the .bashrc or .tcshrc solution doesn't work, because things run by clicking an icon in the GUI do not execute a shell first.
    Internet search shows that it would be possible to edit /Applications/Parallels(etc)/Contents/Info.plist to add the environment variable, but
    parallels seems to do a checksum to see if you've modified that file, and aborts if you have (thanks!).

    So the answer is a little more involved.
    I found the answer at https://support.shotgunsoftware.com...-Setting-global-environment-variables-on-OS-X
    but here it is

    edit (create) a file called environment.plist in
    /Users/YourName/Library/LaunchAgents

    with the following content. (I use the tcsh shell, so you would probably need to change "tcsh" below to "bash",
    and "setenv QT_QUICK_BACKEND software;" to "export QT_QUICK_BACKEND=software;")

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>Label</key>
    <string>my.startup</string>
    <key>ProgramArguments</key>
    <array>
    <string>tcsh</string>
    <string>-c</string>
    <string>launchctl setenv QT_QUICK_BACKEND software; </string>
    </array>
    <key>RunAtLoad</key>
    <true/>
    </dict>
    </plist>


    and then in your terminal run
    launchctl load ~/Library/LaunchAgents/environment.plist
    launchctl start ~/Library/LaunchAgents/environment.plist

    log out and back in.
    for me, the easy check is to launch Parallels Desktop,
    then in the Control Center, click on + as if to add another OS image.
    That popup window runs under QT and used to come up blank for me.
    Now it works, along with the "there is a new version of parallels" popup, which also used to come up blank.
     

Share This Page