An unfixable issue with Parallels, Steam and a controller, need help!

Discussion in 'Windows Virtual Machine' started by ArnarI, Sep 1, 2023.

  1. ArnarI

    ArnarI Bit poster

    I've been having troubles with Parallels running Windows 11 this past week and have done a lot of troubleshooting with no solution available.
    I believe that this is a problem with Parallels which needs to be fixed in a new software update.

    The problem:
    I'm have been running Windows 11 on my M1 MacBook Pro for more than a year now and it has worked smoothly with minimal problems.
    However I recently tried connecting a PS5 controller to the virtual machine which is detected by the OS itself with no problem.
    Running Steam I turned on Xbox and PS5 configuration support under controller settings so I could use my controller for playing games.
    Then after I suspended the virtual machine and turn it on again, the virtual machine doesn't register the input from the wireless mouse and keyboard. The only way to let it recognise a keyboard and mouse is to plug it in with a wired connection and then only allow it to connect to the virtual machine.

    What I tried to fix the issue:
    I could not navigate the virtual machine in any way after this unless I plugged in the keyboard with a wired connection.
    I tried entering coherence but it gave me an error message saying that "mouse synchronisation service has not started"
    I tried changing all options for the mouse in setting, both on my Mac and the virtual computer and in Parallels configuration but nothing seem to do anything.
    Then I read that I might need to reinstall Parallels Tools which I did more times than I could count and that did not alleviate the issue.
    I uninstalled Parallels, restarted my computer and everything but the issue still persisted, and everything is up to date.
    As I could not access the virtual machine or navigate it, I decided to create a new virtual computer and see if the problem was present there and to my surprise it did not. So the issue is tied to the virtual machine but not Parallels in a whole.
    After setting up the new virtual machine I started Steam again, plugged in the controller and got it working again... but again after suspending the session the new virtual machine got the same problem!

    The issue still persists:
    Knowing this I'm convinced that this is a problem with compatibility with Steam and Parallels and this is an issue that needs to be fixed as soon as possible as it prevents a user from using their virtual machine! I've spent countless hours trying to find out what the issue is and how to fix it, at least I know now what the problem is, but I'm sure that I have no way of fixing it myself and this is in the hands of Parallels to fix with a future software update.
    BenM18 likes this.
  2. KenH14

    KenH14 Bit poster

    I have the same issue here.
    Installed Parallels for MacBook Pro 16 M1 Max
    Good news is that it can play Origin games, like Generals Zero hours. It's great. Since I have issue to play this game using the intel MacBook Pro 16 at bootcamp.

    Bad news is that when I play Steam games such as the counter strike source, the mouse acting weird. I cannot control the mouse. I tried several methods online like change the hardware settings, "not optimize for games", etc.., but with no success.

    Anyway that Parallels can install steam and play counterstrike source themself and check this bug.

    thank you
  3. steved16

    steved16 Bit poster

    Have you come across any promising solutions? I'm keen to delve deeper into this. Also tell me if you have any information about difference between structural and construction engineering.
  4. BenM18

    BenM18 Bit poster

    I have this same issue; I cannot boot into windows as I cannot get past the Lock Screen

Share This Page