Android / Samsung Dex - RDP - Double Letters / Characters typing / keyboard

Discussion in 'Parallels Client for Android' started by TylerB10, Apr 21, 2021.

  1. TylerB10

    TylerB10 Bit Poster

    Messages:
    4
    I'm using the Parallels client for Samsung Dex because:
    - Microsoft RDP client hangs/times out after a few minutes of idle, and Parallels does not (the screen doesn't disconnect, it just 'freezes' when using Microsoft's client)
    - Parallels is the only RDP client I've found 'honors' the hotkeys (specifically it passes the WIN key to the remote session whereas all other clients I've tried do not)

    The problem I'm having is that whenever I either minimize and then come back to Parallels, or, if I try to reconnect to a saved connection, what happens is the keyboard sends duplicate letters. For example, it looks like this: tthhiiss iiss wwhhaatt hhaappeennss. The only way I can get around this is by creating a NEW connection. As you can imagine, considering this happens EVERY time I minimize the window/client, this gets annoying fast.

    Has anyone else seen this?
    Any suggestions?

    Thanks
     
  2. Eugene. K.

    Eugene. K. Parallels Team

    Messages:
    103
    Tthhaankkss ffoorr tthhee ffeeeeddbbaacckk,, TTyylleerr.
    Sorry, couldn't stand to try how much did it cost you to type "tthhiiss iiss wwhhaatt hhaappeennss" :) Quite a challenge, actually.
    As far as I see you don't connect to a RAS Gateway, but use a regular RDP connection, right?
    Please tell me the version of the Parallels Client you are using and the Windows version you connect to.
    Also, do you use the Android native keyboard or the "PC Keyboard" mode, available in the Parallels Client?
    Thanks in advance, we will try reproducing your issue locally.
     
  3. TylerB10

    TylerB10 Bit Poster

    Messages:
    4
    Ha! That's awesome. Thanks for the reply!
    - Yes, regular RDP connection (again, thank you for having the only RDP client available that is sending ALL keyboard strokes (especially the Windows key) to the remote client.
    - Parallels Client: 18.0.0.22344
    - Windows 10 - 20H2 (OS Build 19042.928)
    - Android keyboard: "PC Keyboard" mode

    I don't have the ability to test this in 'regular' android mode for the next hour or two, I'll attempt that as soon as I'm able. I've been using Samsung Dex. I'll respond with a new message once I'm able to test to see if it's happening in both modes or not. Just to clarify, the current workaround is anytime I come back to the Parallels Client, I must create a NEW session, typing in the remote hostname, custom port (not using 3389), username and password. Any/every time I create a New profile/connection, it works, and if it minimizes, or I close and re-launch, I get double letters. The double letters even survives a reboot on my phone.

    Thanks again for the assist!
     
  4. TylerB10

    TylerB10 Bit Poster

    Messages:
    4
    I went into work today where I've got my new setup. Happy to report that changing the setting "Use PC Keyboard" to unchecked appears to have resolved the double character problem. The WIN key is passing through no problem, so right now I'm a happy camper. As an FYI, I'm using a REAKA USB-C HUB 4-in-1 device for Samsung Des in case you wanted to try to exactly match the problem. If there's anything I can do to help in replication please let me know.
     
  5. TylerB10

    TylerB10 Bit Poster

    Messages:
    4
    Not to try to keep a dead thread alive, but to try to help future Google searches, I have a little more color for the picture. I have a Microsoft Ergonomic keyboard plugged into my adapter (don't have the model number, but it's newer, all black, no fancy center buttons), and where unchecking "Use PC Keyboard" has resolved the ddoouubbllee cchhaarraacctteerr problem, I've found that certain key combinations don't work well, especially things like Ctrl-1 and Ctrl-2 cycling through Outlook views. More annoying is most of the time the BACKSPACE key is now completely dead. I was getting good at utilizing arrow keys and the DELETE key, until I tried something new which is to simply go into the settings, uncheck and re-check the "Use PC Keyboard" button. Now with it enabled, the BACKSPACE key is back and operational. Ctrl-1, Ctrl-2 etc. in Outlook still isn't working, but obviously that's not a huge deal. No BACKSPACE? Yeah, that sucks. But a quick uncheck and re-check definitely get BACKSPACE back to an operational place.
     

Share This Page