Anyone get gOS running?

Discussion in 'Linux Virtual Machine' started by chosenken, Nov 8, 2007.

  1. chosenken

    chosenken Junior Member

    Hello. I have been trying to get gOS to run in Parallels. I have tried setting vga to 800x600 16 bit, but it still will not start. Has anyone gotten it to run yet, and how? Incase you are wondering, it is based off of Ubuntu 7.10.
  2. soonlar

    soonlar Bit poster

    gOS - got it running

    I read the forums regarding Ubuntu 7.10 and found a way to make gOS work. Credit goes to Sidney, Xenos, and Billy Goto for their posts:

    Here is how I used those posts to make gOS work for me. I am sure there are other variations to this that may work too.

    1. Boot the install CD or ISO file. When the menu screen comes up press F6 for boot options before it starts the install

    2. On the bottom of the screen use the arrow key and then delete key to remove the word 'splash' and press the Return key to start up the installation. This will prevent the terminal window from being hidden by a splash screen so you can do the next steps.

    3. The install system will begin to boot and it will go back and forth between the graphic display window and the terminal window. Type ctrl-c to kill the script and get you a shell prompt.

    NOTE: During the moments that it is in the terminal window you can type to the command shell. If it comes up with the window that says 'The display server has been shut down about 6 times in the last 90 seconds' go ahead and type Return to select the OK and you will again get the terminal window and in a few minutes get the dying display server again. Persevere and you can keep typing thing in the terminal window.

    4. Now using vi or pico as you prefer, edit xorg.conf as root:

    sudo pico /etc/X11/xorg.conf

    5. Scroll down to the end of the file and add this section exactly below

    Section "ServerFlags"
    Option "Xinerama" "True"

    then save the file and exit the editor. (use control-x, then type 'y, then hit enter')

    6. Start up the display server again by typing the command


    7. There may be a warning about running in low resolution mode, but continue.

    8. gOS live should now boot graphically, double click the Install button, configure and then reboot.

    9. At reboot of the virtual machine and when it says to press ESC to get the boot menu, quickly press ESC to get the boot menu, scroll down, and boot in recovery mode. That gives you a root shell prompt in a terminal window.

    10. Take gdm out of the startup procedure, run this

    update-rc.d -f gdm remove


    13. Now it should load gOS graphically.
    Note: you will need to use 'startx' with each reboot until Parallels gets this issue fixed or until you fix the gdm back to its original state.
  3. soonlar

    soonlar Bit poster

    One note, I am having problems getting Parallels tools to install.
    I have selected the 'Install Parallels Tools' menu option, then run

    sudo mount /media/cdrom

    It gives an error when mounting the cdrom.
    mount: can't find /media/cdrom in etc/fstab or etc/mtab
  4. claco

    claco Junior Member

    No need to rid yourself of gdm and manually startx.

    Just run sudo dpkg-reconfigure -phigh xserver-xorg, and select vesa and set your resolutions. Same trick used for Ubuntu 7.10
  5. adamswick

    adamswick Bit poster

    Doesn't work on the latest version

    F6 is no longer an option as it was before.

    You can hit "control-alt-F2" in the gOS setup and then "control-c" to eventually get a system prompt, but su or sudo access is not available and /etc does not have the X11 installed.
  6. KizzyS

    KizzyS Bit poster

    Thanks for this detailed steps. Very helpful.
    --And in the end, it's not the years in your life that count. It's the life in your years.~Abraham Lincoln
    Keen Footwear

Share This Page