Anyone having luck with Garmin GPS?

Discussion in 'Parallels Desktop for Mac' started by Traj, Jun 19, 2006.

  1. Traj

    Traj Member

    What you write makes sense. However it still leaves me with a sad face. :(
  2. bobodobo

    bobodobo Member

    Yes, the serial interfaces worked somewhat with the serial to USB adapters... but they always failed on long map data transfers, and it's VERY slow.

    The only 100% working way I've ever connected a Garmin eTrex unit to a Mac was connecting a Garmin Vista C to a PPC Mac running Virtual PC - BUT BOOTING UNDER OS9. The "Classic" launch under OS X was no joy, since Virtual PC doesn't work as a "Classic" application. Only older Macs can even boot OS 9, and only older versions of Virtual PC have an OS 9 application. But if you do meet these requirements (booting under OS 9 and use Virtual PC), it works perfectly and is VERY fast.
  3. Larry__Rymal

    Larry__Rymal Member

    True, slow it is. Very slow.

    But using the adapter I purchased from Radio Shack has resulted in 100% transfers for me. In my case, I only transferred three maps into my Garmin and I doubt if I'll do that again for another couple of years. For updating my waypoints, trackes, etc., and for real-time map tracking while I'm on the road or in the pasture, serial is more than fast enough. Again, with the combination I've been using with the Radio Shack unit I mentioned, everything has been 100%.
  4. CraigF

    CraigF Junior Member

    I bought a Garmin StreetPilot C320 last week, and it works very well with Parallels.

    I've updated the device software using WebUpdater and I've installed maps. I just picked up a 1GB SD card today, so I'm filling that with maps now. It's quite slow...taking about 2 hours to fill up the 1GB card with V6 of the maps. I've heard V7 of the maps is compressed better, but I'm hoping to get the entire US on the 1GB card (which I've been told is possible with V7), so that'll take another 2 hours.

    I guess either Parallels doesn't support USB2 speed, or maybe the C320 isn't a USB2 device (I haven't checked on that).
  5. jvaleski

    jvaleski Bit poster

    no dice

    I can only get Garmin USB stuff to work using Bootcamp. I have the same problem you mention when trying to use Parallels. Unfortunately, this will prevent me from buying a Parallels license. I need windows for two things, one, my Garmin device (Motion Based Agent), and two, a specific java applet that only works on windows.

    I'd like to not have to reboot to use these things, but until Parallels or Motion Based fixes the problem, I'm stuck w/ Bootcamp.:mad:
  6. SanDiegoJim

    SanDiegoJim Junior Member

    No joy on USB for my StreetPilot III

    I tried a couple of times today to update my routes and waypoint from Parrallels/WinXP to my Garmin StreetPilot III. After fighting WinXP so I could install drivers manually, I chose the Transfer to Device from my MapSource v6.5. WinXP seemed happy with my install indicating the device was running correctly on the device manager. MapSource found the USB device and I chose to send waypoints and routes, no maps. The program seems to work fine but when I installed the USB card ino the StreetPilot, nothing had updated. :confused:

    I downloaded new drivers from Garmin, installed, transferred and got the same no update result. :(

    I am quite disallusioned with Garmin too because I ordered a updated map disk 6 weeks ago and got nothing. I sent an email explaingin I got no CD and the problem I was having. No response. I called and left a message and got no return call. Garmin used to be good but not anymore.:mad:

    At last I still have my Dell tower I can use to interface with the Garmin.
  7. Phil Waters

    Phil Waters Bit poster

    Qualified Garmin USB success on a Mac

    On the Mac OSX side I just now had success in getting a Garmin eTrex Legend C to be recognized by National Geographic's TOPO after upgrading TOPO to 4.2.3. However, it was only after using GPSBabel+ for a separate test that things starting working.

    For me the Parallel/XP path was solely to be able to use my GPS on the Mac. There's $200 (for XP) that I'll never see again.

    My goal here is not to dismiss Parallels, which is awesome, but if you're: 1) trying to use a USB-based Garmin on a Mac and; 2) can or have used TOPO's state series and; want to work in OSX, then you may be in luck.

    What I'm now wondering is whether or not GPSBable+ had anything to do with the USB connection working properly. To that end there is a PC version of the program which someone out there may wish to download and test...
  8. Bit poster

    Garmin III+ Working

    Got my Garmin III+ (serial interface only) working with a Radio Shack USB-Serial adapter. Installed the driver under XP-Home and it worked.

    I had tried a cheaper USB-Serial with no luck. I don't think it had enough "stuff". The RS has a box on the cord big enough to have some electronics in it. The cheapo couldn't had much if any.

    RS doesn't have any sort of OSX drivers, but maybe it doesn't need any. Don't have any way to test because the Garmin is the only serial device I have anymore.

    Does what I wanted anyway, so I'm happy.
  9. petro

    petro Member

    If you have a USB serial adapter (I have a Keyspan), you can try this:

    I've seen other people post that they can talk to their serial port GPS units that way, I haven't personally though.

    Thanks to Eudyptes for a great tool to make Parallels talk to serial devices!

    Now if someone could tell me a trick to get it to work with my Apple USB modem so I could use it to dial from a Door Security app in Windows I'd be set!
  10. beej

    beej Junior Member

    what does your garmin show up as in system profiler?

    sometimes my StreetPilot 2610 is "Vender-Specific" and sometimes it is "Composite". either way, i get the "is being used by another process" error message :(

    what does yours show up as in PD's Devices menu? mine says "Vendor Specific 091e:0003".

    i tried to keep OSX from stealing it by doing a "sudo kextunload -b", but that just leads to a kernel crash :(

    sucks that i just paid $75 for City Navigator v8 and i can't load the data onto my garmin...

  11. beej

    beej Junior Member

    if you want to have some fun watching a mac kernel panic, try this:
    sudo kextunload -b
    sudo kextload -b

  12. YellowTJ

    YellowTJ Bit poster

    My StreetPilot 2610 works fine with XP Home in Parallels. I have noticed that since I installed the recent beta, transferring data to the 2610 is much, much slower. It took nearly 6 hours to transfer the entire City Navigator 8 map set to my 2610 (I have a 2GB card in my 2610). With the release version it only took about 90 minutes to transfer the entire City Navigator 7 map set and they aren't that much different in size. I havn't reverted back to the release version yet to try it with City Navigator 8.

  13. beej

    beej Junior Member

    larry: that is very encouraging! :) are you using USB autoconnect for your VM in PD? how is the StreePilot shown in the PD devices menu? how about under System Profiler? do you know what firmware is on your 2610?

  14. YellowTJ

    YellowTJ Bit poster

    2610 firmware is 4.7
    USB autoconnect is on.
    Will have to get back to you on what the device shows up as since I don't have it handy
  15. Bull_Durham

    Bull_Durham Bit poster

    Parallels sees my Garmin Forerunner 205, but Garmin's Training Center software does not. I checked the device manager in XP and the Garmin is there, reported working fine. When I launch Training Center it prompts me to connect a USB GPS. When I connect and click OK, sometimes it immediately rejects and re-presents the dialog, sometimes it goes away for a bit. But it never recognizes the device. I think it's Garmin's problem. There should soon be a Mac version of Training Center, so I'll wait.
  16. juggledad

    juggledad Junior Member

    Garmin Streetpilot C340 works

    I have just recieved a Streetpilot C340 and am able to load POI's using the Garmin utility. I've also been able to upload a new voice to the unit. (note to all C340 users: the unit has a SD card slot, but unless you are going to europe with it, it is useless. You can't put POI's on an SD card and since the unit has the entire US, Canada and Mexico in it, the need for an SD card is moot)
  17. beej

    beej Junior Member

    i was still running 4.4. i updated using webupdate and a real PC and then all was well :)


  18. jfjalest

    jfjalest Bit poster

    From Legend C to Legend Cx

    I have had no luck (like the rest of you) to use my Legend C with PD. Today I chanfed it for a new Legend CX (wanting more memory capacity and better sensitivity). The new CX works (perfectly it seems) with PD!!!!
  19. nuways

    nuways Bit poster

    60cs - a no go

    For some reason, I thought I had the 60CSx so I bought parallels, only to learn I have the 60CS, which it just doesn't work with - windows will recognize the USB device but Mapsource does not....

    have there been any changes or updates that make it work with it now?

    if not, I might as well return Parallels b/c it's the only reason I got it....

  20. Lynda Leung

    Lynda Leung Bit poster

    It works fine with my friend's Garmin 76CX, but it doesn't work with my Garmin Quest. Win2k pro detects the USB device, but not mapquest. Both units are running the latest firmware..
    Same machine.

Share This Page