Anyone having luck with Garmin GPS?

Discussion in 'Parallels Desktop for Mac' started by Traj, Jun 19, 2006.

  1. n4khq


    eTrex Vista Cx works fine

    eTrex Vista Cx works fine, Garmin must be hacking together a different driver for every single product line. After a firm ware update, (2.2.3 I think now running 2.2.5) the eTrex Vista Cx memory stick appears on the OS X desk top if you plug the GPS in before you boot Parallels. If I want to use mapsource, I wait until XP is running before I plug in the GPS.
  2. mladd


    No joy with a 496

    I have a new Garmin 496 and no luck connecting with MacOSX or Parallels on the same machine. This would be very nice to be able to see if Parallels can fix Garmin's problem, or if Garmin could fix their own.

    It will be even nicer when Garmin comes out with their Mac OSX Software sometime in the next decade.

  3. atheistvoices


    Garmin 10 Bluetooth working in parallels

    I was able to finally get my bluetooth garmin unit to work in parallels using serial client to connect to the mac then using Franson GpsGate to forward it to a virutal com port.
  4. bobodobo


    Parallels + Garmin GPS 10 bluetooth + nRoute = SUCCESS!!!

    This is not new considering what atheistvoices said in the previous post, but I thought it might be useful to have step by step instructions. These procedures work for me on an Intel iMac with Parallels running Windows 2000 SP4, but there is no guarantee it will work for anyone else. Anyway, the key seems to be that the GPS 10 appears as an RS-232 serial device, which Parallels supports reasonably well, instead of a USB device, for which Parallel's apathy and lack of support are legendary. While all this was written for the Garmin GPS 10, undoubtedly similar procedures will work for other bluetooth GPS receivers.

    (As always, it's a good idea to restart both the Mac and the virtual machine before doing installations like this...)

    1. Turn on the Garmin GPS 10 bluetooth receiver
    2. On the Mac, select Apple Menu / System Preferences / Bluetooth / Devices / Set up new device / Continue / Any device / Continue
    3. Select "Garmin GPS 10" and select Passkey Options / Use a specific passkey / OK / Continue
    4. When Bluetooth Setup Assistant is done collection information about the device, press Continue
    5. Enter "1234" (without the quotes) in the passkey box and select Continue (Passkey 1234 was just a wild, lucky guess on my part; I have no idea how one is supposed to know this!)
    6. Bluetooth Setup Assistant will claim that there are no supported services on this device. Ignore the message and press Continue then Quit.
    7. Back on the Bluetooth system preference panel, select "Garmin GPS 10" then "Edit serial ports". The device name will be "GarminGPS10-Gps10-1" or something like that, and the service "Gps 10". Select port type "RS-232" and don't check "Require pairing" or "Show in Network Preferences" (maybe you can, but I didn't). Press Apply.
    8. Quit System Preferences.
    9. Download and install the free program SerialClient from
    10. Open SerialClient. Configure with the following settings. These settings seem to be very critical; almost any other combination I tried at best didn't work and at worst froze the Mac.
    • Stream Path: /tmp/serial/ (this is apparently the default path)
    • Serial Port: GarminGPS10-Gps10-1
    • Baud Rate: 9600
    • Data Bits: 8
    • Parity: None
    • Stop Bits: 1
    • Flow Control: None
    11. Press "Connect". Close SerialClient.
    12. Start Parallels, but DO NOT start your Virtual Machine.
    13. Select File / Edit Configuration / Add... / Next
    14. From the hardware types, select Serial Port. Press Next.
    15. Select the "Use a socket" radio button. Press Next.
    16. In the box to specify the name of the socket, enter "/tmp/serial/" (without the quotes) and for role select "Server" from the drop-down menu.
    17. Optionally, select "Connect Serial Port at startup" if you want to connect automatically next time. Press Finish.
    18. Back in the "Configuration Editor" dialog box, press OK.
    19. Start your virtual machine.
    20. You should now be able to use the GPS 10 like any GPS device. Normally you'll use this with Garmin nRoute; select Utilities / Select GPS / AutoDetect and your GPS 10 unit should appear. Select it.
  5. waldo


    Garmin Mac OS X Release Delayed

    I've been trying for months to get my Vista Legend C to function on Parallels. It was one of the major reasons that I bought Parallels, after investing in the GPS and a copy of MapSource. I've gotten nowhere, of course. That's with the firmware updated to the latest version (2.6.0) and all related software fully up-to-date.

    I spoke with Garmin tech support last week. The wait was brief and the fellow was helpful. I asked whether Mac OS X support would really be coming by the end of the year (read as: this month). He admitted that, no, it would be early next year, because it simply wasn't ready. I asked whether that meant that I should not bother with trying to get this working on Windows. He said that, no, "early" probably didn't mean January, and that it was probably worth the trouble.

    FWIW, I didn't breathe a word about trying to get this to function under Parallels. I knew that if I mentioned the word "Macintosh" that they'd immediately refuse to help me, whether out of fear or ignorance. Having made some changes (like the firmware update) I intend to take another shot at calling tech support next week, but I'm not optimistic.

    Oh, and I tried the beta release that came out yesterday, since it's promoted as having much improved USB support. It hosed my system. (Mac mini Intel DP 1.66GHz, OS X 1.4.8.) I see on Macintouch that this is a universal experience. I downgraded and my system can once again respond to, say, clicks of the mouse. When they say beta they really mean it, so hold off.
  6. bobodobo


    I'm in the same boat as Waldo with a eTrex Vista C (same device with a built in magnetic compass and barometric altimeter, I think.) My experience is the same as waldo's, no joy at all after many tries with Parallels. (Guest PC for G4 Macs works though). Let's hope that the native Mac support by Garmin is really forthcoming and the long journey will finally end...
  7. hikerak


    Glad to see this thread

    Thanks for contributing to this thread. Please continue to post regarding your successes and failures. I have a GPSMAP 60 and have been using my bro-inlaws old windows machine just to load maps. I have the 20in IMAC and would love to use it to do everything.. I have checked the Garmin Website once a day since December hoping... If they(garmin) would just fix the USB problem I am sure many of the mac people would gladly use parallels to make the connection..

    Thanks, Matt
  8. copelands


    I have a Garmin 496 that I use in my aicraft as a backup to the main avionics. I installed the USB driver and map source in paralles and it works fine. It even does firmware updates to the 496.

    I can transfer maps to the unit from mapsource and upload new aviation databases.

    I still can't get my Jeppesen USB programmer to work, it installs the drivers and when I plug in the crad writer it just sings and does the windows device connect "ding" every few seconds. The device appears in the hardware manager for a second and the vanishes and the reappears and vanishes and so on....
  9. sidlinger


    Another GPSmap 496 Experience

    I am running Parallels Build 1970 on the latest MacBook Pro hardware (3GB) under 10.4.8.

    I manually installed the latest Garmin USB drivers.

    Ximage works great and WebUpdater seems to work but fails every time when I attempt a FW update from 4.60 to 4.80. Using the standalone updater also fails between "Erasing" and "Loading".

    I will now try the latest Parallels RC.

    I also have a Jeppesen USB programmer for my Garmin 530 but have not tried it yet.
  10. sidlinger


    GPSmap 496 WebUpdater works great after updating to Parallels Build 3120 RC

    The newest Release Candidate appears to have much better USB support! Everything is faster and more solid and the Garmin drivers install automagically now.

    Lots of other improvements, too. For example, on my 1680x1050 MBP 17-inch screen, the new Parallels display driver automatically set up a Windows display size of 1645x980, which is just exactly maximal w/o needing scroll bars.
  11. colday


    No luck with my Garmin GPS-18. WinXP detects when I plug in the USB GPS puck, Parallels even identifies it. But when I load either nRoute or MapSource they just complain that no GPS device can be found.

    Once I get this working I can nuke the Boot Camp partition on my MacBook.

    Using RC1 (build 3120)
  12. morgan


    Count me as another with no success trying to get a Garmin device (an Edge 305) to communicate with Windows software (TrainingCenter or CyclingPeaks WKO+) over USB when running on Windows (XP SP2) within Parallels on OS X 10.4. Machine is a MacBook Pro 2.33GHz.

    I have another device - an SRM Powercontrol V - which uses a serial-to-usb cable that plugs into the usb port on the PC, and which is called COM3 on the PC. I will try connecting my Edge to that and communicating with TrainingCenter & CyclingPeaks.

    I also tried running WebUpdater and it locked up my machine so tight I had to power cycle it.

    Bleh. I bought the MacBook Pro and Parallels and XP mainly so I could use CyclingPeaks with the Edge & SRM and still have a Mac.

    I've already sent one email to Garmin's support about it. I'll send email to Parallel's support, too.

    Hoping I can work around this,

  13. SoSa11


    I have a GPSMAP 76Cx which is practically internally the same as the GPSMAP 60Cx.
    For me Parallels (3120) plus XP works using Garmin MapSource with the latest Garmin USB drivers downloaded from the Garmin website.

    The flip-side is that my external hard disk which used to work with the previous versions of Parallels is not working with this one. (I see it in the devices but for some reason XP stops short mounting it.)
  14. morgan


    FWIW I updated to the latest beta - build 3120 - and the problem remains. :-(

    I am using the OS X MotionBased agent + Safari to upload from the device. That works fine. Then I launch parallels and msie and browse to motionbased to export as HST - I do this because if I download as HST from motionbased within Safari I get a .csx file, which CyclingPeaks can't open - to get an .hst file. Then I import the .hst file in CyclingPeaks within Parallels. Cumbersome!

    I am tempted to try the Vmware Fusion beta... I hear Garmins work over USB within it.

  15. bobbyb


    I was able to use my Quest in the VMWare Fusion beta, both tor uploading and downloading with MapSource.

    I updated Parallels to the 3120 build, and while I got further than before, it still doesn't completely work.
  16. pderby


    nuvi 660

    I just updated my Garmin Nuvi 660 using Parallels RC build 3120 using the stand alone downloads and had no problems at all. This USB update worked just like I would expect on a PC.
  17. bredding


    Place to watch for updates on Garmin Mac support

    It appears that Garmin has a blog and one of the bloggers has been dropping hints on their Mac support. Here is a link to a posting:

    It indicates that the webupdater and POI loader will be the next Mac OS X software sometime in the 1Q. No hint yet on when Mapsource will be released.
  18. bobbyb


    Garmin Quest in 2.5 Prod 3186

    My QUEST works fine in 3186 production version! WooHoo! :D :D :D
    Last edited: Mar 3, 2007
  19. Traj


    Finally have joy!

    I'm happy to say that I finally have what I wanted all along. My Garmin GPSr's are working fine with Parallels.
    This program evolved into a nice program. Appreciate all the work these folks put into it.

    Bravo Zulu!
  20. bobodobo


    Let's pile on! My eTrex Vista C (not Cx) FINALLY works with the new release of Parallels. Never did under any previous version. Woo Hoo!

Share This Page