Apple Magic Mouse

Discussion in 'Windows Guest OS Discussion' started by radarseven, Oct 27, 2009.

  1. ViktorC

    ViktorC

    Messages:
    1
    Am experiencing the same problem

    Any ideas highly appreciated. I run Windows 7 under the Parallels Desktop 5.0.9344 and Snow Leopard 10.6.3. This problem makes the magic mouse practically unusable when editing critical texts like program sources.
     
  2. Mike Mellin

    Mike Mellin

    Messages:
    1
    Right clique on magic mouse does not work -windows 7

    one right clique is suppose to do a pop up window, nothing happens using WIN 7 and Parallels 5 with latest updates and latest parallels mouse driver. using a logic tech mouse, I get the pop ups. just want to use magic. Any ideas?
     
  3. thomy

    thomy

    Messages:
    1
    Magic Mouse and P5

    HowardJ

    I have the same problem as you. Did you find a fix for it?

    Thomas
     
  4. Michael F.

    Michael F.

    Messages:
    3
    Try installing MagicPrefs for Mac OS X. It is like BetterTouch but (no pun intended) better.

    I enabled the right click using the Mac OS mouse options, and then I set up a middle click using MagicPrefs so that clicking with three fingers registers as a middle mouse button click.

    It should translate over to the virtual machine without any problems.

    The only issues I've had with Parallels and my Magic Mouse is hyper speed scrolling and way slower than neccessary tracking speeds in some applications.

    Hope that helps!
     
  5. AdgarH

    AdgarH

    Messages:
    7
    Hardware is hardware. Any of the “magic†functionality is built into the drivers and if there isn’t corresponding “magic†functionality on Windows PCs it’s because Apple chose to not include it.
    I have a Dell PC with a touch pad that supports many of the gestures that are missing from the magic pad on Windows (including “pinch to zoom†and touch to click†along with horizontal and vertical scrolling) so if the functionality isn’t there, its because Apple doesn’t want it to be there.
     
    Last edited: Jun 13, 2012
  6. Br.uno

    Br.uno Bit Poster

    Messages:
    9
    today i installed parallels 7 on my new imac.

    my problem is, that for some reason the right mouse click is not working.
    for the time beeing i can use ctrl+shift click to get there....

    however, can you please help me to get the right click on my magic mouse working?

    thanks.

    EDIT: it works now, I had to switch on the secondary mouse click in the settings of the mac os.
     
    Last edited: Dec 8, 2011

Share This Page