arm64 ISO and VHDX images?

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by KolbeK, Dec 17, 2020.

  1. IanT9

    IanT9 Bit poster

    I am trying to install Windows 10 Client ARM64 Insider Preview - Build 21354

    It installs on Paralletls 16.5, but (like previous versions) crashes just at 100% install with "failed to execute the operation" (with no details or clue of the cause!).
    That part was perfactly fine in the video above.
  2. WernerR1

    WernerR1 Bit poster

    Sorry, bin ich der einzige der alte VMs hat mit denen er weiterarbeiten will? Das ist doch alles noch gebastel, wenn ich erst alles neu aufbauen muss, mit einem Testprogramm ect....
  3. SteveW19

    SteveW19 Bit poster

    Which build? Did you do anything special to get it to work? I'm trying to install Win10 from an .iso instead of the .vhdx. I'm building the .iso fine using the linux script in the download package but I get an unhandled thread error at the start of installation.
  4. FerdinandR

    FerdinandR Bit poster

    I have followed the instructions for setting up Windows 10 ARM64 under Parallels 16.5. When it asks for the Windows VHDX file, I select the file I downloaded (build 21354) and parallels gives me an "Unable to detect operating system" error. If I press Continue, select Windows 10, Productivity, and Create, I get "operation failed. Failed to execute the operation."

    Any ideas how to get past this problem?
    NikitaM1 likes this.
  5. taxidrivercurrantdog

    taxidrivercurrantdog Bit poster

    Thanks for the tips, I was searching the whole internet looking for comments like this.
    However, would you explain more details about the page size. Is this due to hardware limitation like you have mentioned the "translation granule isn't available on Apple M1", or it just something that PD have deal with and perhaps would be patched in the future?
  6. >>> Message has been deleted by the user <<<
  7. >>> Message has been deleted by the user <<<
    serv likes this.
  8. VladimirE1

    VladimirE1 Bit poster

  9. Cyburn

    Cyburn Bit poster

    Not sure if anyone care but I have been able to install Windows 11 arm64 in Parallels on my M1 Macbook Pro 11. This thing is FAST! If you care to know how to do it then here you go. It was rather easy actually.

    This solution is derived from (588) Windows 11 ARM is FINALLY HERE! M1 Mac Install Tutorial - Parallels VM + Game Benchmark Comparison - YouTube

    - Using create the two iso (win10 and win11)
    - Mount win11 iso
    - Mount win10 iso
    - Copy the win10 iso files to a new folder
    - Replace the win10 iso files /sources/install.wim with /sources/install.wim from the win11 iso
    - Create new iso from combined files in new folder:

    .\bin\cdimage.exe -bootdata:1#pEF,e,b"D:\iso\win11arm64\efi\microsoft\boot\efisys.bin" -o -m -u2 -udfver102 D:\iso\win11arm64 win11arm64.iso

    - Use to install win11 on parallels for m10
    LaurenG2 and CYT like this.
  10. CharlieT2

    CharlieT2 Bit poster

    Has anyone successfully installed MacOS Big Sur? I get the same error, and when I follow this process, and it doesn't work.
  11. NikitaM1

    NikitaM1 Bit poster

    Exactly the same behavior on my macbook air m1 ( BigSur), but while using Parallels 17.0
  12. SahinM1

    SahinM1 Bit poster

    Hi, my problem was same. i was installed program on apple store.
    but it not worked.
    after, i download Paralels from their web site ( and install it. when it install, ask for file permissions, i approve it.
    And voila! it's work like a champion.
    i think it's a file permission problem...
  13. MarkM52

    MarkM52 Bit poster

    I don't have a .iso file. Just the .VHDX that isn't working. What am I missing?
  14. Anand48

    Anand48 Member

    Hi, please uninstall and reinstall your Parallels Desktop application. Also, refer to the Parallels knowledgebase ( ). Thanks.
  15. MarkM52

    MarkM52 Bit poster

    Thanks. I deleted and reinstalled with no success. I then downloaded version16.5, installed windows, then upgraded to v.17. It's working now.
    Anand48 likes this.

Share This Page