At symbol (@) on Swiss German keyboard

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by MartinL34, Mar 5, 2023.

  1. MartinL34

    MartinL34 Bit poster

    Hi there,

    For about an hour now I'm desperately looking for a solution to type a @ on my Swiss German MacBookPro in Parallels... I've tried all possible combinations of option + key, option+control+key even with shift, but no @ appears anywhere! What can I do?

    Thanks, Martin
  2. Ashley Chumun

    Ashley Chumun Staff Member

    Dear Martin,
    Thank you for your feedback.
    For us to better understand the issue, please, perform the following steps:
    1. Launch your Virtual Machine > Click on the Windows start icon > type Language settings and press enter > Next to your Language, select the 3 dots on the right.

    2. Select "Language Options" > Down below you will see all the keyboards that are currently installed.
    3. Please check if you have a keyboard layout that ends with "-Parallels".
    e.g on my mac I have the keyboard "French-Numerical" installed. To use the same layout in my Windows 11 virtual machine I need to set the keyboard layout as "French (Numerical, Apple) - Parallels".
    4. If the keyboard installed inside your Windows virtual machine doesn't have the "- Parallels" extension > Click on Add a keyboard > Select the One that is currently installed on your mac along with the Parallels extension.
    5. Press the Option+Shift button to switch to the Parallels Keyboard layout inside the virtual machine > check if this resolves your issue.

    If the issue persists, for further investigation, kindly provide us with the following information:
    a. Start the Mac On-Screen keyboard (open Spotlight > type On-Screen keyboard) and take a screenshot with pressed Shift.
    b. Start the On-Screen keyboard inside your virtual machine and take a screenshot with pressed Shift.
    c. From your mac > Click on Apple Icon on Top left corner > Click on "System Preferences" > Choose "Input Sources" (Take a screenshot)
    d. From your Windows Virtual Machine > Click on start button > Type "Language settings" > Click on the 3 dots next to the preferred language > Language options (Take screenshot)

    Thank you!
  3. ChristophR7

    ChristophR7 Bit poster

    I have the exact same problem. I also have a "Swiss German" Keyboard in MacOS and also on my desk. The Windows Configuration is described as written in the above post. However, I cannot type an @ sign in the Windows 11 VM. Here the requested screenshots.
    Any help would greatly be appreciated.

    Attached Files:

  4. ChristophR7

    ChristophR7 Bit poster

    I forgot to add the "shift" screenshot. Here you go

    Attached Files:

  5. Maxim Rasulov

    Maxim Rasulov Staff Member


    The reason for this, is a difference between Alt functions in macOS and Windows, in short, you should be able to achieve the @ sign in your layout in Windows 11 virtual machine by either: Using the "Right Option" + G; Or "Ctrl+Left Option+G". As opposed to the host system "Left option + G"

    A bit more expansion on the subject was covered in this thread: including the option to remap Option keys function, tho it does bear some limitations if this is done.
  6. ChristophR7

    ChristophR7 Bit poster

    Hi. Sadly your post didn't help me much. After trying out a couple of settings I found the solution to the problem here. In the "Parallels Desktop Preferences" under "macOS System Shortcuts" I had to set the "Send macOS system shortcuts" to "Always" (see attached screenshot). With this setting, the described way of pressing "Ctrl+Left Option+G" started working. Before that this was not the case.

    Attached Files:

Share This Page