Discussion in 'Parallels Desktop for Mac' started by kwojniak, Apr 12, 2006.

  1. johnoyler


    Hey Sheppy...

    Are you trying to tell us that you don't have a Bebox or two stashed away in the attic? With AT&T Hobbit CPUs, no less?
  2. exadeath


    Doesn't boot

    I tried both resizing with imagetool and using transporter. It just gives me a screen with a cursor.

    Using build 3094.
  3. mayuge


    I have build3120 and got the same result.
  4. titetanium


    I actually have a machine that has BeOS sitting in my living room. Unfortunately, the motherboard on it is conking out. :-(

    I actually played with it for a couple of years till they went out of business. Loved it, it was so revolutionary and ahead of its time. I can still remember the initial shock and awe when I booted it up for the first time. I'd be willing to give it a shot again and maybe use it as my full time os if and when most or all of the bugs are ironed out.
  5. Frank Friedlos

    Frank Friedlos

    Would like to try Haiku, but...

    Hi all,

    I downloaded haiku.image.bz2 and followed the instructions, but Parallels image tool did not want to play with it. Am I getting the right image? The instructions don't seem to mention the .bz2 extension. All the same, I think the versatility shown here, that I haven't got working yet is a hoot. As an aside, I have had OS2/warp running. What next?
  6. buzzdat


    .bz2 is a bZipped file - you need to uncompress it. Open a terminal, and at the command line enter:

    bunzip2 file.bz2

    where file is the filename. The resulting file will be your disk image.
  7. Frank Friedlos

    Frank Friedlos

    Oh I see. Should have guessed. Thanks for that.
  8. Frank Friedlos

    Frank Friedlos

    As with some previous posts, I also get the black screen with single text cursor. But then if I click in, and press return (as one does) I get a HAIKU splash screen, with a white bit at the top bearing the message "kernel panic/could not mount boot device" and the slightly sinister "welcome to kernel debug land". Yes, and you're welcome to it too. I tried a few ruses such as starting a linux VM but pointing to the haiku.hdd, and it spontaneously rebooted my Mac! It was me that was panicking at this point. The only other time I had problems with Parallels/kernel panics/crashes turned out to be specific to Core 2 duo machines, so maybe this is the same. Does this tally with anyone's experience?
  9. Rachel Faith

    Rachel Faith


    Same here.... any help ??

    All I get is a Black Screen.
  10. Rachel Faith

    Rachel Faith

    I'd like to ask one of the experts here to post a little more detial on HOW one is supposed to install these non windows aps.

    Like step by step. Cause it seems many of us aren't doing something or are doing something we shouldnt be doing.

    Like it always asks for the windows key... what do we do there? Or how do we not get that screen?

  11. Gryzor


    I have tried today, and experimented with various settings. One thing that I didn't see mentioned in the "guide" is which Windows are we supposed to specify. You can get Parallels Panics depending upon your choice.

    By using "Other Window" and "Windows ME" I got to see the error.

    I had a few "out of memory" and a PANIC: page fault, but interrupts were disabled.

    In the out of memory I jumped to the Kernel Debugger.

    It looks like it won't work for now. (I am using latest Paralells -> 3120)

    Did anybody mange to get past this?

  12. Frank Friedlos

    Frank Friedlos

    Nil Desperandum

    Thought I'd try one more time, and it worked! As far as I can see, the thing that prevents Haiku booting is having networking switched on. Without this, get to the blackscreen/single cursor stage, click in and press return, and the OS loads. Now why was it I wanted to do this again?

    Attached Files:

  13. Big Al

    Big Al

    Are you using one of the betas or the last release? I've had no success at all using any of the latest betas. I always get a vm error. Removing networking did nothing for me. Any ideas anyone?
  14. blackjack75


    As stated earlier the size must be 120 mb! Not anything else. Took me a while to realize the problem was I resized the disk to 500mb.
  15. the_webers_inc


    Haiku works fine here....

    I have been using Parallels to check on the Progress of Haiku for about 6 months now & haven't encountered any problems yet. I have updated Parallels to the latest beta & now RC when they come out, without any problems. I just tried the latest version of haiku (Revision 20239) in Parallels RC3 Build 3170(See attached image below).

    - I have my os type in this VM set to other.
    - I only increase the size of the haiku.image.hdd by 1mb -- if it's 114mb I make it 115mb
    - I only have the HDD and CD-Rom enabled in this VM configuration. Network, USB, etc is turned off.

    On a side note: my experience above was on a 20" Intel iMac Core Duo. I have tried, on a more limited basis, to run Haiku in the various betas and RC of Parallels on my Black Macbook. The last time I did so I ended up in Kernel debug land. But that was 3 weeks ago when I was on the road. No problems on the iMac.

    T. J.

    Attached Files:

    Last edited: Feb 27, 2007
  16. tlj


    Haiku successfully running for me too

    I followed the instructions posted. The only strange thing is the time to book haiku. Sometimes it boots quickly, other times it takes a few minutes to boot. At first I thought I was experiencing problems that others have reported in this thread but after waiting for a bit all was okay.
  17. Resuna


    tlj: do you get it booting with network active or not?

    If it's timing out on something to do with the network that would explain it, and of course networking was one of the achilles heels of the original BeOS. Perhaps the instructions on the Haiku site need to be updated.
  18. ctrl+alt+del


    So, does Parallels 3.0 supports BeOS R5?
  19. dolbie


    I'm waiting on my activation key so I can find this out.
    Any 3.0 beta testers out there try this?
  20. adparadox


    Well, Haiku still works

    I just installed version 3 of Parallels (build 4124) and Haiku (revision 20610) works just as well as it did before. Unfortunately, I don't have a BeOS R5 CD laying around, otherwise I would try that out as well.

Share This Page