Beta 5 deletes VM!

Discussion in 'Parallels Desktop for Mac' started by sunnfun, Apr 30, 2006.

  1. sunnfun

    sunnfun Junior Member

    I wanted to reboot the VM to try the "Change Mac OS X Resolution" setting with a different window size from the full screen resolution. However halfway trough the reboot (with the blue background screen shown through XPs start up), Parallels stopped and skipped back to the VM Configurartion screen and showed the VM as "stopped". I tried starting up the VM one more time, same result. On the thrid try to start the VM it showed a dialog saying that the VM could not be found!!!

    Looking in Finder I found the pvs file to be set to 0 bytes and the hdd file is there but it can't be accessed, i.e. copied (Error -36). Any Idea whats wrong?
  2. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Sounds like something went very wrong... Is it somehow related to VM Compressor activity?
  3. sunnfun

    sunnfun Junior Member

    No, I don't have compressor installed.

    Upon further investigation I found the following:

    - The folder that the vm was in (the .hdd file and the .pvs) were showing empty in the finder. If I made a search through spotlight for ".hdd" or ".pvs" it found both files and when I was clicking on "reveal in finder" both files showed up, but both were not accessible.
    - Copying or moving the files bot resulted in an Error code -36.
    - Trying to reset permissions on the folder resulted in an error -36 as well.

    Access to any other files or folders seemed to be normal. So I did a full back up and ran disk utility from the startup DVD. It found and repaired several severe problems with the disk.

    After the repair everything seems to be as before, except that I have gained about 4GB Diskspace (The size of the VM), and the folder that used to contain the hdd is now accessible but empty.

    Log from the disk utility on the verify:

    Verifying volume Macintosh HD
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Invalid node structure
    The volume Macintosh HD needs to be repaired.

    Error: The underlying task reported failure on exit

    Disk Utility stopped verifying Macintosh HD because the following error was encountered:

    The underlying task reported failure on exit
    1 HFS volume checked
    Volume needs repair

    Let me know if I can be of more help.


Share This Page