Big Sur and Parallels: "Network initialization failed"

Discussion in 'General Questions' started by LukeI, Nov 14, 2020.

  1. anjuna

    anjuna Bit Poster

    Messages:
    15
    Tryied also to reinstall this app, and notthing!
     
    RodrigoV3 likes this.
  2. serintakma

    serintakma Bit Poster

    Messages:
    2
    The some problem at me... Parallels team pls do something, don't abandone Business users...
     
  3. UgisG

    UgisG Bit Poster

    Messages:
    6
    I can say that I have the same problem with Parallels (16.1.1) and VMWare Fusion (12.1.0) - network in guest Windows 10 does not work in bridged/UAT mode. In parallels i see "Network initialization failed" while in fusion there is simple no internet connection.
    It was working for some time in fusion (i think bridged mode only) but once (maybe something else, but I think that after this) I created new VPN connection (but i'm not using it while running VM) this problem started.
     
  4. StenZ

    StenZ Bit Poster

    Messages:
    1
    Works fine - thx, Simon....
     
  5. CharlesF5

    CharlesF5 Bit Poster

    Messages:
    1
    Indeed, it works, thanks a lot for sharing, Simon :)
    Quick note: my <UseKextless> string was not showing '1' but '-1', I don't know if it's something specific to Windows VMs but, in case you have '-1' instead of '1', you can go ahead anyway, the workaround works ;)
     
  6. UgisG

    UgisG Bit Poster

    Messages:
    6
    SimonR4 recommendation fixed my problem.
    1. I had -1 as value there
    2. Changed to 0 and on next app startup got message about "system extension blocked" > enabled
    3. Restart was required
    4. On next startup - internet connection was available in my guest win10. Hurrray!
    In VM hardware settings i can see that network source is bridged > en5 (which i suppose is network adapter on mac)
    Not gona change anything here as it works now.
    Thanks.

    Not an expert, but based on change it looks like kernel extension(?) was enabled with this change. Is this something that is still supported in BigSur then?
     
  7. serintakma

    serintakma Bit Poster

    Messages:
    2
    Thanks a lot Simon. Solution you posted worked!
     
  8. JonathanL10

    JonathanL10 Bit Poster

    Messages:
    1
    Thanks Simon for Sharing. It also works for me. But since the network is working again, the VM is super slow so that I cannot use it. I changed from 0 back to -1 and now the Performance is much better again. Does anyone else has the same effect?
     
  9. JindrichS1

    JindrichS1 Bit Poster

    Messages:
    1
    Thank you so much Simon!!!
     
  10. NikolajG

    NikolajG Bit Poster

    Messages:
    1
    Simon's instructions worked for me. Network is now up and running, but I lost USB. Can't connect a USB drive directly to VM.
     
  11. NeilD3

    NeilD3 Bit Poster

    Messages:
    1
    I had the same issue after upgrading to macOS big sur this morning. I tried Simon's suggestion, however, I didn't have the entry <UseKextless>1</UseKextless>
    I fixed this by changing my network adapter (in Parallels configuration, Network, Type) from Virtio to Intel (R) Pro/1000 MT.
     
  12. LucasT1

    LucasT1 Bit Poster

    Messages:
    2
    Same problem here. I can't connect USB on VM.
     
  13. NilcemarP

    NilcemarP Bit Poster

    Messages:
    3
    Simon's suggestions work... Thanks Thanks!! I will make more tests...
    It's impossible a company like Parallels kidding with customers like this... I have production VM need for work stopped because this issue. This consuming more than a day of work coping VM and migrating to VMWare trial for wait a solution and NO return from support that really work.
     
    anjuna likes this.
  14. anjuna

    anjuna Bit Poster

    Messages:
    15
    Im the only one that with this solution Windows it's like to use a touch screen method? I have to select the square for every stuff inside windows.
    It's not the solution! Cmon!
     
  15. SimonR4

    SimonR4 Bit Poster

    Messages:
    3
    Hi All,

    Apple is moving away from kernel extensions, in preference to more advanced implementation. The use of kernel extensions will be forbidden in later releases of MacOS, so I would use this workaround sparingly, as it will break later.
     
    Last edited by a moderator: Dec 16, 2020
  16. SimonR4

    SimonR4 Bit Poster

    Messages:
    3
    I work in telecommunication, we don't upgrade production systems unless there has been some serious testing. Have you tried calling support?
     
  17. OhadB

    OhadB Bit Poster

    Messages:
    6
    Can someone please explain SimonR4 solution?
    I can't understand what I need to do :|

    Thank you !
     
    AgungS2 likes this.
  18. AhmedA15

    AhmedA15 Bit Poster

    Messages:
    3
    how do you change the value?
     
    Last edited by a moderator: Dec 16, 2020
  19. anjuna

    anjuna Bit Poster

    Messages:
    15
    Svolto questo passaggio, solo che mi trovo windows in modalità touch screen con i quadratini in selezione, sono l'unico ad averlo cosi?
     
    Last edited by a moderator: Dec 16, 2020
  20. SeddikiA

    SeddikiA Bit Poster

    Messages:
    1

Share This Page