Big Sur Beta 1

Discussion in 'macOS Virtual Machine' started by prenez, Jun 26, 2020.

Tags:
  1. prenez

    prenez Member

    Messages:
    37
    I'm running the VM on an external SSD from my 2017 Macbook, 16gb and i7 chip. Latest version of Parallels. 15.1.4 build 47270

    I go through the install process, but as soon as it gets to Big Sur login, all I get is a black screen. This is a common experience, according to Apple Forums. The beta runs fine on VMWare Fusion.

    I follow this procedure.

    1. Create a new Parallels VM by installing a fresh copy of macOS Catalina from Recovery Partition (or use existing VM).

    2. DO NOT INSTALL Parallels Tools or uninstall it if it's already installed.

    3. Login to iCloud account which have Apple Developer Program membership active (thanks @paulrbarnard).

    4. Resize disk drive to be at least 80 GB (see article 112119 in the parallels knowledge base website on how to do that).

    5. Download and install your Beta profile (https://developer.apple.com/download/).

    6. (blank)

    7. On a host, supported Mac, run these commands in a terminal
    Code Block
    sysctl hw.model

    this will get you mac_hw_model (something similar to MacBookPro14,3).

    ioreg -l | grep board-id

    this will get you board_id (something similar to Mac-551B86E5744E2388).

    7. In the Parallels VM configuration, under Hardware -> Boot Order -> Advanced Settings -> Boot flags, enter the following (inserting the information noted above where shown):

    devices.mac_hw_model="mac_hw_model"
    devices.smbios.board_id="board_id"

    where mac_hw_model and board_id inside the quotes should be substituted to your values.

    7. Proceed with downloading and installation of macOS Big Sur via System Preferences.
     
  2. Abishek

    Abishek Member

    Messages:
    91
    Hello @prenez Please try Actions menu (From Mac menu bar) -> Reset and see if it helps.
     
  3. prenez

    prenez Member

    Messages:
    37
    No it didn't help.
     
  4. KerryC2

    KerryC2 Bit poster

    Messages:
    2
    Did all of that. Got it all right on the 3rd attempt (and I had to reinstall Catalina on Parallels twice). Was very excited as Big Sur booted up. Cant' get past the login screen. I login, and after about 30 seconds, it just refreshes the login screen. Any advice?
     
  5. Hello,
    please collect the tech report right after the issue reproduced and post the report's ID here.
    Thanks in advance.
     
  6. Christopher_Micali

    Christopher_Micali Bit poster

    Messages:
    2
    I see same behavior as KerryC2. I've submitted technical report 344135367.
     
  7. Hello, could you please collect crash logs from inside guest. If you cannot boot, try recovery mode or mount disks to another macOS guest and try there.
     
  8. DominikHoffmann

    DominikHoffmann Junior Member

    Messages:
    15
    I have had the same exact two types of experience. Last thing I have tried has been the Beta 3. I am waiting for the public beta to try again.
     
  9. Thank you for sharing your experience. You can also subscribe on this article and receive all updates
     
  10. Parallels Engineering Team works hard to make Parallels Desktop compatible with the macOS 11 Big Sur.
    Thank you for understanding.
     
  11. BrianK12

    BrianK12 Junior Member

    Messages:
    17
    I found after many tries to set up Big Sur on my Parallels Pro 15.1.4, all I needed to do was not install the Parallels tools and it worked. Every time I installed the tools, everything ground to a halt (before or after Big Sur installed). I didn't need to add the boot flags (it worked with or without them). I'm running on a Macbook Pro with 10.15.6 Catalina. Hope that helps anyone trying.
     
  12. BrianK12

    BrianK12 Junior Member

    Messages:
    17
    To update my last post, I installed Parallels 16 that was just released and now I can install the Parallels tools without issue. So far, so good.
     

Share This Page