[Boot Camp] More than one Windows partitions are found.

Discussion in 'Windows Guest OS Discussion' started by Konrad, Jul 1, 2007.

  1. Konrad

    Konrad

    Messages:
    1
    Hi,

    the following behaviour seems like a bug to me. First, my setup: I have a Boot Camp installation of Windows XP on my local hard drive (as a FAT32 formatted partition) that I want to use in Parallels. I also have an external mass storage device that's connected to the notebook via FireWire. The media has two partitions, one formatted as NTFS and the other as FAT32 (incidentally, neither of them is bootable).

    Now, whenever I try to boot my Boot Camp partition in OS X, I get the following error message:

    Apparently, Parallels is confused by the existence of additional partitions. To solve the problem, I have to exit Parallels (!), disconnect the external drive and then restart Parallels. After I have booted Windows, I can reconnect the external drive. This is somewhat bothersome and I actually don't see why the existence of additional non-bootable devices should trouble Parallels unduly.
     
  2. r4given

    r4given

    Messages:
    3
    I have the same problem

    I scoured the user manual and didn't find anything that addressed this issue. I had not tried to re-connect my external drive after starting Parallels. I have a MacBook and I do a lot of work with photshop. My version of Photoshop happens to be Windows, so I need that extra storage for files.
    I don't run Photoshop from Parallels, but wanted to be able to access the files for viewing.
    I hope there is a resolution for this issue.:confused:

    MacBook 2.16GHz, 1g ram, 120g hard drive partitioned 80 mac 40 windows (approx), External drive 250g partitioned 150 mac, 100 windows.
     
    Last edited: Jul 6, 2007
  3. brkirch

    brkirch Kilo Poster

    Messages:
    424
    Try setting this program (it automates setting up a custom boot camp partition, read about it in this thread) as a login item. Then open it and select your Boot Camp VM, select Boot Camp from the virtual drives list, select the Boot Camp partition (the partition itself, not a folder in the partition), and click "No" when asked if Parallels should be launched.

    Hopefully that will resolve your problem, but let me know if it doesn't or if there are any other issues that continue to prevent the Boot Camp partition from working in Parallels.
     
    Last edited: Jul 6, 2007
  4. r4given

    r4given

    Messages:
    3
    worked for me

    Hey, thanks! It did work. Only thing is, I have to eject the external drive from the Mac (not disconnect it) before opening parallels. If not, I get an error from OS X telling me the drive was not properly ejected and data could be damaged.

    Right now there is no data on the external drive - it's new and I haven't gotten around to transferring it yet.:D
     

Share This Page