Bootcamp partition corrupted - works in parallels

Discussion in 'Windows Guest OS Discussion' started by AndrewBT, May 9, 2021.

  1. AndrewBT

    AndrewBT Bit Poster

    Messages:
    30
    Hi there

    I have a bootcamp partition which I have been using in Parallels Desktop for Mac for a year or two. Today I tried to boot into bootcamp directly, but it got stuck in a boot-loop, then went into 'Preparing Automatic Repair'. I am unable to boot into bootcamp but the OS still works perfectly in Parallels from the Mac side. I have the latest Parallels desktop update and Windows updates.

    This is what I've tried:

    - Tried booting into restore mode (CMD+R) but 'first aid' option is not available for MacOS
    - Tried several of the automatic repair options on the Windows side, none work
    - Tried booting into safe mode on the Windows side, this also gets caught in a boot-loop and ends up in preparing automatic repair
    - Tried booting from USB drive containing a Windows 10 image. This fails to boot giving an error about startup disk not recognised.

    Can anyone assist? I don't want to have to wipe the entire bootcamp partition just to fix this ... :(
    Best regards,
     
  2. SteveE7

    SteveE7 Bit Poster

    Messages:
    1
    Similar thing happened to me recently. I was booted into Windows 11 in my Boot Camp partition, my battery died while I was using an app, and now I can't boot into it again. I don't even get an Automatic Repair prompt - it starts with the usual Microsoft logo and spinning dots, then goes to a permanent black screen. Requires a hard shutdown then option-boot into the macOS partition. The Parallels VM based on this Boot Camp partition works fine and there was nothing to repair with chkdsk or similar tools. It seems like an issue on the Mac side, but I have no idea what. If the partition itself was corrupted how would the Parallels VM launch successfully? What other components in macOS control this process? Boot Camp Assistance provides no (wait for it) assistance, only the option to remove the partition. And you can't repair a NTFS partition with Disk Utility. Any help here would be greatly appreciated.
     

Share This Page