Broken Games - Speak up here if you want to see a particular game working.

Discussion in 'Windows Guest OS Discussion' started by krayola, Jun 10, 2007.

  1. mlasky

    mlasky

    Messages:
    1
    I can play Dragon Age pretty well under Parallels 5 (1920x1080, settings maxed).... for about 5 minutes. Then I get random crashes during dialog. It seems the fix for this (from reading Dragon Age Forums) is to downgrade Catalyst drivers... anyone know if that's possible with parallels?

    I've tried lowering the settings, but that didn't help.


    Mac Pro
    2x2.8Ghz Quad Xeon
    16GB
    ATI Radeon HD 2600
     
  2. Michael Newbery

    Michael Newbery

    Messages:
    11
    What guest OS? XP /Vista/7?

    I've got Win XP SP3; Mac Pro early 2008 5GB/NVIDIA GeForce 7300GT and all I can get is the "Loading..." screen when I try to start a new character---then it dies ("A problem has occurred, send to Microsoft?")
     
  3. etrigan63

    etrigan63

    Messages:
    8
    Champions Online would be nice (gets D3DERR_INVALIDCALL when trying to generate texture)
    and
    Star Trek Online (I haven't tested this one yet - I'm just being proactive as both are by Cryptic)

    Carlos
     
  4. Snrub

    Snrub

    Messages:
    1
    Star Trek Online has same error message:

    Fatal Error: Direct3D driver returned error code (D3DERR_INVALIDCALL) while creating a texture. Unique Error ID: 6418o32


    Get the same result whether using XP or Windows 7.
     
  5. cayennecode

    cayennecode

    Messages:
    7
    I also get that D3DERR_INVALIDCALL while creating a 3d texture. I have an ATI Radeon HD 4870. I kind of hoped that would be powerful enough...
     
  6. solus

    solus Bit Poster

    Messages:
    27
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  7. solus

    solus Bit Poster

    Messages:
    27
    DDO Unlimited

    I just installed DDO Unlimited, and it appears to run mostly fine up until the character select screen, but all the characters have black faces. Entirely black. No visible features, such as eyes, lips, etc. The rest of the characters look fine, armor, hair, etc.

    Is there an updated video driver I can try? I have a nVidia GeForce 8800 GT installed in my Mac Pro. I'm assuming I can't simply update the nVidia driver, since it believes it really has a "Parallels Video Adapter".

    Any suggestions on how to correct this?
     
  8. Daniel Cantu II

    Daniel Cantu II

    Messages:
    1
    Broken Game?

    command & conquer: the first decade does not seem to work with other parallel users, as with mine. Is there a patch update that has been made for Parallels 5?

    Thanks, Daniel II

    p.s. if possible could the answer be email to dsc209@yahoo.com?
     
  9. BobTheDog

    BobTheDog Bit Poster

    Messages:
    44
    Civilization V in DirectX 10/11 mode doesn't start.
     
  10. PatrickJ

    PatrickJ Bit Poster

    Messages:
    89
    Props to Parallels

    Loving Parallels 6.. great game performance. I've been posting over at Steampowered (Halflife2, Left4Dead and such) about the joys of P6.

    Working games (mine):
    Bioshock 1, Bioshock 2, Crysis, Dead Space, Far Cry 2, Stalker: SOC, Stalker: CS, Stalker: Pripyat, L4D 1 and 2, Halflife 2 + episodes, Fallout 3, Grand Theft Auto 4, Penumbra

    Ars Technica tested a bunch.. all working:
    Mass Effect 2, Unreal Tourn 3, World in Conflict, Batman Arkham Asylum, Dirt 2
     
  11. Jakub Vosahlo

    Jakub Vosahlo

    Messages:
    1
    Civilization V

    I second that, Civilization V looks terrible with Direct X 9 and does not start with DirectX 10/11...
     
  12. Alessandro Bombaci

    Alessandro Bombaci

    Messages:
    3
    Cities XL 2011

    The game starts and seems to work, but there are no textures, so the land appears black, no other details exept for the waves on the shoreline...
    That on Parallels 6, on the 5 it worked fine.

    Any Idea?


    (on MacBook Pro late 2008 | Intel Core 2 Duo - 2,5 GHz | GeForce 8600M GT - 512 MB)
    (Parallels config. 1 core | 1.5 Gb RAM | 256 Mb Video)
     
  13. Alessandro Bombaci

    Alessandro Bombaci

    Messages:
    3
    Even stranger... on another Mac (iMac) with Parallels 5 Cities XL 2011 runs fine, even with 256Mb Video Ram.
     
  14. LloydR

    LloydR

    Messages:
    2
    I third it and in fact even when I play in Direct X 9 I get this horrible flicker in the panel on the right and when you close a panel it doesn't refresh and stays there (not clickable, just an image of what it was)

    Anyone got Civ V working? If you could let me have your graphics settings that would be appreciated.

    Cheers
     
  15. sjrose

    sjrose

    Messages:
    1
    Medieval II hangups

    Older game I know, but has anyone experienced trouble with Medieval 2 in battles? Whenever a wall is taken out or a gate broken open, the game starts to freeze and gets really choppy. At that point I have to switch between windowed and full screen mode to reset the graphics until it happens again. Any thoughts? I'm running windows 7 on a 2010 imac.
     
    Last edited: Nov 20, 2010
  16. zelidethm

    zelidethm

    Messages:
    1
    :(

    I wanna run my online games!! I only got parallels to run my online games and now I find out I can't :(
    I wanna Run:
    Dream of Mirror Online (DOMO)
    Luna plus (Luna Online)
    Iris Online

    Any of those work? I already tried DOMO but it won't start the actual game... And I really love that game! And my Dad doesn't want me to instal windows on boot camp... So is Parallels or I'm going to die not being able to play my fav game ever again! :'( any help?
     
    Last edited: Feb 8, 2011
  17. jesalerno

    jesalerno

    Messages:
    1
    I am running Parallel's 6.0 on an Intel Mac Book Pro. I am trying to run Dungeon's & Dragon's Online (DDO) and when I start the application, I get the following error message when the updater tries to run: "RunDLL: There was a problem starting SelfPatch.dll Invalid access to memory location." Any suggestions on how to get around this problem?
     
  18. Sonellion

    Sonellion

    Messages:
    2
    Running Windows 7, 32 Bit through Parallels 6 on a 2.2GHz Macbook Pro with 8GB RAM. I just thought I'd post what games currently work and don't work for me. (I haven't found enough of these lists so I thought I'd make my own)

    Works (with minimal or no problems):
    - Fallout: New Vegas (requires some fixes such as the d3d9.dll and messing around with ffdshow if you have it)
    - Dragon Age: Origins Collector's Edition (I understand there is a native version available, however, it does run fairly well in Parallels.)
    - World of Warcraft (Yes, I am aware this one has a native version too. I tested it anyway.)
    - Prius Online (Some of the actor shadows look like they have no AA, but it's playable!)
    - Dungeon Siege III
    - Drakensaang: The River of Time
    - The Elder Scrolls IV - Oblivion + The Shivering Isles
    - Hellgate: London
    - The Sims: Medieval (This one has a native version too, but it works.)
    - Assassin's Creed
    - Divinity II
    - Saints Row II
    - Mythic Blades
    - Faery - Legends of Avalon
    - Priston Tale II
    - Dungeons and Dragons Online
    - APB Reloaded (I wasn't willing to allocate enough RAM to my VM to run APB without crashing after an hour, but it runs so it's on this list.)

    Works (with some serious bugs)
    - Fable III (I've been experiencing super-low framerates, and a problem where my textures/meshes flicker in and out of sight continuously. Sometimes if I stand still enough, they settle down for a few seconds, but then it comes back afterwards. Unplayable, but it launches.)
    - Fallout 3 (Some people have gotten Fallout 3 to run, but my machine's processor speed does not meet the minimum, so it crashes outside of Vault 101.)
    - Mass Effect 2 (I've actually been playing this for a while. In all honesty, it's playable and runs well, but there's a shader issue which causes actors and some objects to have random dark (or light, as it changes with the lighting) stripes across them. Distracting, but hey, the game runs. Hopefully this will be resolved in the future. I found that tweaking Coalesced.ini (with 3rd party programs, not Notepad, or else the game will refuse to launch!) has helped to make the stripes somewhat less noticeable. Note the 'somewhat'.)
    - Risen (I have this weird issue where I can sometimes see the shapes of things, but everything is in black and white. Shapes are merged together because of it, and it's unplayable. Ever used the Threshold effect on Photoshop, but moved the slider way too far to the right? It looks like that.)
    - Gothic 3 (It runs, and fast, but within the first 10 minutes it crashed on me. Also, some of the buildings/landscape flicker like a dying lightbulb when you look up.)

    Won't Run (No matter what I've tried!)
    - Lost Planet 2 (Doesn't even start, even though I tried the solutions used in the Windows 7 versions).
    - (I can't remember anymore than that, I've removed most of them!)

    Potentially Could Run (I possess the copies, but have not tested them)
    - Vampire: The Masquerade, Bloodlines (Requirements are really low; it ran well on my old Acer, so it ought to run well in Parallels.)
    - Neverwinter Nights 2 (I own a copy, but I have yet to test it. I think there's a native version available anyway.)
    - The Elder Scrolls III - Morrowind GOTY (Have yet to test it, but it's quite old and I see no reason it shouldn't run.)
    - Fable: The Lost Chapters (Own a copy, haven't tested it yet.)
    - Sacred 2: Gold Edition (Own a copy, haven't tested it yet. The disk space requirement is ridiculous.)
    - The Witcher (Own a copy, haven't tested it yet.)
    - Trine (Own a copy, haven't tested it yet. I think there's a native version as well.)
    - Starwars Battlefront II (Own a copy, haven't tested it yet.)
    - Lineage II (Own a copy, haven't tested it yet.)
    - Aion (Own a copy, haven't tested it yet.)
    - Dark Messiah of Might and Magic (Own a copy, haven't tested it yet.)
    - Borderlands (Own a copy, haven't tested it yet. I also think there is a native version now, or something.)
    - Hunted: The Demon's Forge (Own a copy, haven't tested it enough to draw any conclusions.)
    - Two Worlds II (Own a copy, haven't tested it yet.)
    - Mass Effect (Okay, so I don't own Mass Effect yet; but I'm picking up a copy soon and will be testing it.)
    - The Witcher II (I don't own this either, but I'm borrowing a friend's copy tomorrow.)

    I just thought I should share my findings, since they might help someone.
    At the moment, I'm mostly looking for help on fixing the Mass Effect 2 issue. If anyone else has been experiencing the same issue, they should surely know what I mean. And if anyone has any solutions or workarounds, please let me know! (I read somewhere that they were preparing a Mac release for Mass Effect 2, but I'm not sure if it's true. One can only hope!)
     
  19. PatrickJ

    PatrickJ Bit Poster

    Messages:
    89
    Of the Potentially... list, I can vouch for:

    Vampire / Bloodlines
    Morrowind
    Witcher 1
    Borderlands (there is a native version as well)
    Mass Effect 1


    re: Mass 2, what GPU do you have in your MBP? I've got an ATI 4890 and haven't seen any corruption iirc.

    re: Vault 101, I had that same problem as well. Before you leave, reload with your graphics settings to Low preset, should get you through. Once you've saved outside you can set your graphics back. Not sure what the issue is (maybe Parallels 256mb vram limit?), but it worked for me. Good luck!


    I really want to get Crysis 2 working, but it bombs out because of the 256MB limit. Fingers crossed we can get that limit upped a bit!
     
  20. Sonellion

    Sonellion

    Messages:
    2
    Ah, yeah I figured those would be pretty likely to run as well :p In that case, I feel a bit more confident about going out to buy a copy of Mass Effect 1!

    Well, the main GPU is an AMD Radeon HD 6750M, 1GB VRAM. It handles native games (such as Dragon Age II, Left 4 Dead 2, Sims 3) flawlessly on full settings, though I understand they are based on a different engine than ME2 anyway. There IS a video up on YouTube displaying ME2 on Parallels 6 that has the same bug as me, but it is much less visible in the video than it is in-game.

    For Fallout 3, I tried that too actually...it worked for a few few seconds before crashing again. From that point on, crashes would persist regardless of my graphical settings ): I also tried simply using the console to teleport to Megaton, where I experienced the flickering graphics. I thought this was really odd because my old computer could run Fallout 3 quite well. However, I thought it might be due to the fact that my processor speed doesn't meet the minimum requirement...but I could be wrong.

    I just hope that when Skyrim is released, it can run within the 256MB limit, but I have a feeling I'm hoping for too much!
     

Share This Page