Broken Games - Speak up here if you want to see a particular game working.

Discussion in 'Windows Guest OS Discussion' started by krayola, Jun 10, 2007.

  1. Diran

    Diran

    Messages:
    1
    I'm also wanting City of Heroes suppot. I can also get it to load up and it seems to run ok except for the missing mouse pointer which makes it unplayable. I'm not sure how much work would be involved, but I'd really love to see this running properly!
     
  2. Arr MiHardies

    Arr MiHardies

    Messages:
    5
    C&C3 would be great. right now, it will launch, get the the main menu, even let me start a mission, however when i get there all i see is my hud, and the main map is completely blank. I also have no sound.
    Additionally, Command and Conquer - the First decade, does not work. Not even the original C&C (1) will work on this. It tries to start, then errors out and I have to open the task manager to kill the c&c 95 process. interesting, since this game worked under win95 :p
     
  3. TimKenyon

    TimKenyon

    Messages:
    2
    Post up another for GuildWars - I was hoping this game would run having it run the Log On Screen on my Macbook (Black - 512Mb RAM; 32Mb Shared Graphics) with a poor render figured this would work on the Mac Pro, but it didn't.

    Also wanting Dawn of War (Game, Winter Assault, and Dark Crusade expansions), Warhammer: Mark of Chaos, Mechwarriors 2 through 4 (plus Black Knight) and Mechcommanders 1 and 2.

    Everything else should work.
     
  4. AngryAnt

    AngryAnt

    Messages:
    32
    Hitman 2, atomic bomberman

    Hitman 2:
    I see a lot of dislocated polygons - models twisted strangely like a bomb went off in the level and part of the mesh was heavily damaged.

    Atomic bomberman:
    Colours are way off and shifting. Tried to set XP to run the app in 256 colour mode, but no dice.
     
  5. pcjr

    pcjr

    Messages:
    1
    Magic the Gathering Online V3

    I have been trying to use the beta version of MtGO v3. I think there's a DirectX-related issue. The application window is black. However, if I move a window on top of it and then off again, I see the correct window contents for a moment before they are over-written with black again.

    I am running Windows XP on Parallels build 4560 on a Mac Pro.
     
    Last edited: Aug 2, 2007
  6. DevonDisast0r

    DevonDisast0r

    Messages:
    1
    as someone posted earlier i too have purchased parallels mainly so i can play ragnarok online...i keep getting an error and i cant even load the game...im not sure if i have my settings configured right...my video device says its like parallels video or sumthing like that...im not sure if directx is even enabled..sorry im a n00b! lol im also new to mac so im having trouble getting used to it all...could someone maybe offer me assistance as to how i should adjust my parallels settings to make the game run??
     
  7. nrchy

    nrchy

    Messages:
    3
    hi would like battlefield 2142 to work and even half life 2 as i get that to work either
     
  8. jdandrea

    jdandrea

    Messages:
    17
    Infamous 18, please

    My 7-year old son humbly requests support for the golf game Infamous 18. :)

    I already had DirectX 9.0c installed, but some files are marked outdated, even after installing Parallels Tools. Then I read elsewhere on this forum that DirectX 9.0c is not supported, only 8.1 (the latter of which is already on XP). Hopefully having 9.0c installed in tandem is not an issue. (Shouldn't normally be - different drivers/DLLs, I'd expect.)

    Anyway, as it is, Infamous 18 does not appear to work at all. (The game requirements mention it's DirectX 9.0c _compatible_ but at the same time it doesn't mention that it's not 8.1 compatible.)

    - Joe
     
    Last edited: Aug 4, 2007
  9. joeyconnick

    joeyconnick Bit Poster

    Messages:
    4
    I'm having problems too but I can see the application... what seems to be happening with me is a font issue? Or some kind of display issue.

    What it results in is attached. It's pretty awful. Makes the cards unreadable. Doesn't happen, however, when I boot up in Boot Camp.
     

    Attached Files:

  10. neongrau

    neongrau

    Messages:
    7
    another vote for eve-online PLEASE!

    it somehow works but, UI is garbled, rendering is broken, and when rotating the camera the mouse jumps around. so not playable.

    and, is there a way to make media player work? some iptv stuff will only work with media player because of it's DRM crap.
     
  11. jmstacey

    jmstacey

    Messages:
    14
    Comanche 4 is not working properly. It's a DirectX 8 game.

    The game and missions load however there are serious issues: Nothing but the sky loads and it's moving at like 1 frame every 3 seconds, which is also how long the delay is for any keyboard actions.
     
  12. elf

    elf

    Messages:
    4
    Last edited: Aug 7, 2007
  13. WJWwood

    WJWwood

    Messages:
    1
    I would like some help with Conquer Online. You can log onto the game fine, and everything looks normal but when new people come onto the screen it bombs, one time it even completely killed parallels. This seems to me like it would be something easy to fix if you knew what you were doing, because it runs perfect until new people load with no lag or artifacts.
     
  14. nrchy

    nrchy

    Messages:
    3
    hi all would like battlefield 2 or battlefield 2142 to run
     
  15. nrchy

    nrchy

    Messages:
    3
    Battlefield

    hi all would like battlefield 2 or battlefield 2142 to run
     
  16. DigitalHytop

    DigitalHytop

    Messages:
    9
    Guild Wars
    Eve Online
     
  17. odend42

    odend42 Bit Poster

    Messages:
    16
    Kreme314, how were you able to install Harry Potter and which one? Was it Order of the Phoenix? I installed it but when it starts up it shows just a green screen, the music plays in the background but the screen appears upside down. Any help would be appreciated.
     
    Last edited: Aug 15, 2007
  18. reubensitos

    reubensitos

    Messages:
    3
    Guild Wars would be awesome.
     
  19. skoldfactor

    skoldfactor

    Messages:
    1
    Warcraft III

    When I open the program, the colors for the background of the menu (the menu buttons are fine) go photonegative and in Warcraft III the background and mouse are utterly unusable, glitchy, and weird. I have followed all the troubleshooting instructions on blizzard's support site with no success, including adding -opengl and -swtnl to the end of the target name. I have plenty of video memory and a brand new computer (macbook pro bought in early june). Please help.
     
  20. mt_morgan

    mt_morgan

    Messages:
    1
    Tabula Rasa

    I know that TR is only in beta -- but it would be nice to see games such at this addressed earlier vs. later. :) (Looks like this one will require more video memory support AND currently has some issues with (possibly shaders) one of the 3D implements).

    Cheers,

    Morgan
     

Share This Page