BUG in Parallels microphone driver and Windows 7

Discussion in 'Windows Guest OS Discussion' started by plevintampabay, May 10, 2011.

  1. plevintampabay


    I am rather sure I have found a really bad BUG in parallels having to do with the microphone and Windows 7.

    I have Parallels 6.0 running under Max OS 10.6.7.

    I have 1 Windows 7 VM and 2 Windows XP VMs.

    There is a really nice audio editing program for Windows called Audacity which I installed on both the Windows 7 and one of the XP VMs. This program has the ability to monitor and continually display the microphone signal level.

    I ran this monitoring on the Windows 7 VM and it showed the microphone to be working. BUT after about 1 hour, the microphone STOPPED WORKING!

    I also ran this monitoring on the Windows XP VM (not at the same time as the other VM) and the microphone was still working after 6 hours.

    Just to verify, I also ran the Audacity microphone monitoring on a Windows 7 PC (not a mac w/Parallels) and the microphone worked for over 3 hours (after which I had to give that computer back to its owner).

    I got started on this issue when a VOIP application stopped working when I was in a call this morning, after about an hour, using the Windows 7 VM.

    As far as I can find, there are no setting in Parallels or Windows 7 that would have any effect as to disable the microphone after an hour, thus this clearly looks like a BUG in Parallels.

    I do not have a service contract, nor will I get one. Parallel's support mechanisms seem to all require one, in order to contact anyone at the company. Without a service contract, how can I report this BUG to Parallels?
  2. TamaraK


    Hello Plevintampabay,

    Please reboot your Mac.
    Open Device manager - Sound, video and game controllers tab - make sure the device is working properly, you have an up-to-date driver installed.

    Also check the Event viewer for errors (Start -run: eventvwr.msc)

    Did you try going to control panel, sounds and audio, audio, volume in the sound recording box and make sure that mute is not checked?

    If the issue is still there, open configuration of the virtual machine, remove sound device. Reboot Windows, add sound device back.

    And also try this:
  3. plevintampabay


    TamaraK, thank you for the reply. I hope you understood that the microphone works, but only for about an hour, and then it stops. So several of your suggests really do not apply. However...

    I rebooted the Windows 7 VM and then started Audacity to monitor the microphone.
    The microphone was working well.
    I left my office and returned after an hour. The microphone was no longer working.

    1) I looked in Device manager | Sound, video & games controllers -- it shows that the Parallels Audio Controller x64 is working properly. It is Parallels version 2/17/2011, version 6.0.11994.0

    By the way, I see that this is the x64 controller, where as my XP VM would be using an x32 controller. This explains why the XP does not have the same problem as the Windows 7 VM.

    2) I looked in the event viewer. Looking only at events the occurred after I started Audacity, there were the following entries:
    Under Application, there were the following information messages:
    The Software Protection service has stopped
    Successfully created restore point
    The VSS service is shutting down due to idle timeout.
    The disk defragmenter successfully completed defragmentation on C:
    Under System there were several information messages about services entering and leaving run state, and there was one error message:
    The shadow copies of volume C: were aborted because the shadow copy storage could not grow due to a user imposed limit.

    3) the microphone is NOT muted. As I clearly stated, the mic works for about an hour and then stops working.
    Anyway, I did look in Control Panel | Sound | Recording | Microphone | Levels. It is not muted.

    While doing the above checks, Audacity was still running, showing that the microphone was not working. I then clicked the X to exit Audacity, and something new happened (that has never happened to this VM before). I got a BlueScreen. After the reboot here is the info Windows made available:

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.1.7601.
    Locale ID: 1033

    Additional information about the problem:
    BCCode: 19
    BCP1: 0000000000000020
    BCP2: FFFFFA8000F37000
    BCP3: FFFFFA8000F37880
    BCP4: 0000000015886000
    OS Version: 6_1_7601
    Service Pack: 1_0
    Product: 256_1

    Files that help describe the problem:

    After the reboot, I started Audacity again and it showed the microphone working again (as expected since Window rebooted). I then exited Audacity from the X and it closed successfully. Do not suggest that there is a problem with Audacity. Remember that I started this investigation because the mic for a VOIP program stopped working. When the mic is not working in Audacity, I also have used Windows Sound Recorder and confirmed that the mic is not working there too.

    By the way, I looked for the xml file mentioned above and it was not there. The dmp file is there, but its binary so I couldn't get any information from it.

    Continuing now, after the reboot following the above crash...

    4) I'm not sure what you mean by "remove the sound device" from the VM configuration. From the Virtual Machine menu, I clicked Configuration and on the Hardware tab selected Sound. Then I unchecked the Connected check box and saved that setting. Then I rebooted Windows again. When Windows came up, I re-checked that check box again. By the way, the Input and Output are both set to Default, and Channels is set to Auto.
    I restarted Audacity and it showed that the microphone was working.
    I then left it alone for about an hour. When I returned, the mic was no longer working.
    I clicked the X to exit Audacity and it exited successfully (it did not cause a blue screen crash).

    5) I downloaded and ran the Microsoft FixIt program from the Microsoft URL you gave. It did not find any problems.

    6) After all of the above, I have discovered a new behavior. The microphone stops working after a shorter period of time (less than 15 minutes), but simply restarting Audacity gets the microphone working again. The same thing happens using Windows Sound Recorder.
    I rebooted the VM again and the mic worked for about an hour again, and then stopped again.

    At this point I am convinced that there is a BUG in the Parallels Audio Controller x64 driver.

    I would be happy to help with additional tests, but I want to be sure that your developers have attempted to reproduce the problem, and will look at this problem.
  4. Simmo



    I've got a similar issue:

    - Corporate Windows 7 Enterprise build guest OS
    - Parallels 6 12094
    - OSX Lion
    - New macbook Air 13" (mid 2011), i7
    - Earphones with built in mic connected (iPhone earphones)

    I use Cisco IP communicator as a softphone a lot in the guest OS; I find that the microphone stops working after random amounts of time (so say I'm in a call, people will stop being able to hear me).

    The only way I found to get the mic working again once it had stopped was to quite Parallels and restart.

    The mic works 100% natively under OSX and it also works 100% natively under the same Windows 7 image via bootcamp which leads me to believe its the pass-through that parallels is doing which has the problem

    Did anyone manage to find a solution to this?

    Cheers, Simmo
  5. plevintampabay


    No reply from Parallels

    Hi Simmo,

    Its been a long time since I've retested the problem, and there have been a few updates to Parallels, so I don't know if the problem still occurs. I setup another virtual machine, running Windows XP and I run my audio from there.

    Of course one major problem is that I can not run more than one virtual machine at the same time. I researched that issue a bit, a while ago, and found that it isn't just Parallels that has that problem. From what I read, all VM programs have that problem on the mac - something to do with mac's virtual memory handler.

    Simmo, if you get a work around, or get someone at Parallels to listen and look at this problem, please repost here, and let me know.

  6. BrunoB


    I'm using an iMac and in the sound option the microphone is unavable (Parallels Audio Controller (x32)). Can anyone help me?
  7. mrutter

    mrutter Bit Poster

    just to let Parallels knows that I have the same problem here (BSOD) with Skype but also with Adobe Connect Pro 7 and 8. I already posted my cases on other threads in this forum (months ago ... without answers ... at the moment I'm still using Skype and Adobe Connect Pro from Mac OS X).


Share This Page