[BUG] Mouse Stops Working Properly

Discussion in 'Windows Guest OS Discussion' started by Erod, Oct 4, 2011.

  1. Erod

    Erod

    Messages:
    4
    I'm using Parallels 7.0.14922 (9/13/2011) on my 2011 MacBook Air 11" (10.7.2 11C71), running Windows 7 x64 Ultimate.

    The Parallels app will stop responding to mouse-click events on the Mac OS (and guest OS, Windows in this case) side. I am unsure what causes this, as the timing has been random and I have not been able to reproduce a set of actions that can cause it to occur.

    I typically am coding in Visual Studio 2011 SP1 under Parallels and I'll go to use the mouse and notice that I cannot click things anymore under Windows. The Parallels menus also do not work (like exiting Coherence mode through the dock icon menu). I cannot even force-quit the application since there is no application window in coherence mode. Mac OS itself seems to be unaffected otherwise.

    The strange part is that keyboard events work fine still. I can press Command, which shows the Windows start menu. From there I can launch applications and whatnot using the keyboard. At this point, I typically run the "shutdown -s -t 0" command so I can shut down Windows immediately without using a mouse. Once the VM is shut down, I can close and relaunch the Parallels application, restart the VM, and everything is fine -- until it decides to occur again.

    Kind of annoying, but I haven't had this bug until recently (last week). I've been running the 10.7.2 betas as they release, so I don't think it's just that. My 2011 27" iMac running the same 10.7.2 build does not have this issue. Using a USB mouse vs the built-in trackpad does not make a difference.
     
  2. AdamsW

    AdamsW

    Messages:
    2
    Same problem here

    Hi,

    I have the same problem.

    Environment:

    Macbook Pro mid-2009
    OS X 10.7.2
    Parallels Build - ParallelsDesktop-7.0.15050.707095 (the same issue is on all build from the Parallels Desktop 7 day 1)
    Guest OS: Windows XP

    Issue:

    Every time after mac reboot, parallels desktop doesn't respond the mouse click event, but I can move the cursor. I have to relaunch the parallels, the issue is gone.

    I have already reinstalled the XP and tried the same guest OS image on parallels 6 (no issue at all). Still have the same problem on Parallels desktop 7.

    It is not the severity 1 issue, but quote annoying. Hopefully somebody can provide some guidance.
     
  3. YanaYana

    YanaYana

    Messages:
    1,666
    Hello,

    Can you please reproduce the issue and send us Problem Report ID - go to Help menu --> Report a problem, post the ID here
     
  4. AdamsW

    AdamsW

    Messages:
    2
    Hi, i think i found the root cause.

    The problem happens when it met below 2 criteria.

    1. Define the parallels desktop as "Open at Login".
    2. Also in the system preference, user & groups, define the parallels desktop as "hide when log in".

    Then after mac reboot, the guest OS (XP) stops responding to the mouse click.

    What i do was just disable "hide when log in", I see the window, but at least it's not that annoying.
     
  5. HarmonP

    HarmonP

    Messages:
    4
    I'm having the exact same problem. Periodically the cursor freezes, and it can happen if the cursor is in the guest OS or on the Mac side. If I press Option-Cmd-Esc and open the "Force Quit" window, then close the window without clicking on any app, the cursor will start working again....until the next time it freezes. This is very annoying. I hope someone has a fix for this bug in Parallels Desktop 7 for Mac.
     
  6. HarmonP

    HarmonP

    Messages:
    4
    This problem continues with no solution that works for me suggested so far. I hope someone can come up with an answer, because this behavior is very annoying.
     
  7. Aaron_O

    Aaron_O

    Messages:
    1
    I'm having the same issue. Parallels just stops responding to mouse clicks and the only way to fix it is to reboot the guest OS. This usually happens while playing full screen games and the culprit seems to be the mouse driver installed by Parallels Tools.

    I filed a support ticket on this and related issues with the cursor disappearing, but it was closed with no resolution. It's very disappointing that basic input doesn't work in such an expensive product.
     
  8. HarmonP

    HarmonP

    Messages:
    4
    Apparently No Fix Available

    I finally couldn't take the aggrevation and switched to a different product.
     

Share This Page