Cannot access Mac folders from Ubuntu 22.04.2 ARM64 VM (Parallels Desktop 19) on M3 Max

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by DanC23, Jan 2, 2024.

  1. DanC23

    DanC23 Bit poster

    On a newly purchased MacBook Pro 14" (Sonoma, M3 Max), I installed Parallels Desktop 19 and created a Ubuntu 22.04.2 ARM64 VM.
    I can't access any of my Mac folders from within the Ubuntu VM.
    I've tried Configuration/Options/Sharing with "Mirror Mac and Linux user folders" and/or "Share custom Mac folders with Linux" checked but nothing seems to work. Curiously though, in the "+ Other Locations" tab in the Files app, I can see other computers and file servers on my local area network. But I can't see the files on my own Mac!

    As a side note, if you go to the Parallels menu bar and select "Actions / Shut Down" - nothing happens. I have to click the icons in the top right of the Ubuntu windows and select Power Off / Log Out and then Power Off.. to shut the VM down.

    I also have a Windows 11 VM and there are no issues - I can see my Mac folders.

    Any help would be appreciated.

    Screenshot 2024-01-02 at 11.59.34 AM.png
  2. PhillipB2

    PhillipB2 Bit poster

    I'm seeing the same issue with Parallels Desktop 19.3.0 with Ubuntu 22.04 x64.
  3. DanC23

    DanC23 Bit poster

    I did the following and it worked for me. In the screenshot shown above, click on the Manager Folders... button and then:
    • Make sure your computer name is checked
    • Click on the "+" button and then add the folders you want to share (e.g. Documents, Downloads, etc.)
    That did it for me.

Share This Page