Cannot change language and keyboard layout in Ubuntu 22.04 VM

Discussion in 'Linux Virtual Machine' started by TOMO-ONE, Jul 17, 2023.

  1. TOMO-ONE

    TOMO-ONE Bit poster

    Messages:
    5
    I installed Ubuntu 22.04 and try to change the language and keyboard layout to German. It's not possible. The list is empty. Language is not so important, but keyboard layout.

    upload_2023-7-17_20-46-4.png

    Any ideas how to fix this?
     

    Attached Files:

  2. Maxim Rasulov

    Maxim Rasulov Staff Member

    Messages:
    80
    Hello.

    To add a keyboard layout, in case of Ubuntu, it's required to click on the three dots in the "Add an Input Source" menu (on the screenshot) -> then click "Other" -> a list will open up, you can then scroll to your required language or use a search bar that will appear on the bottom of the window.

    For system language, it should also be possible if it's installed in the system first:
    1. Go to "Settings" -> "Region & Language" -> "Manage Installed Languages".
    2. Use the "Install\Remove Languages" to install German.
    3. Use the list of installed languages to determine which one will be used for menus and windows.
     
  3. TOMO-ONE

    TOMO-ONE Bit poster

    Messages:
    5
    Strange behavior with Ubuntu. I am already in the list view and have to click the three dots and again on "other". In all other distros you can see the list without additional click. This confirms why Ubuntu is not my preferred distort.

    Thanks for the hint.
     

Share This Page