Cannot install a macOS 10.13.3 APFS image

Discussion in 'Parallels Mac Management for Microsoft SCCM' started by MikaelS1, Feb 25, 2018.

  1. MikaelS1

    MikaelS1 Bit Poster

    Messages:
    15
    Hello,
    I'm trying to create a workflow where I use a macOS 10.13.3 APFS disk image. I used AutoDMG to create the image. The NetBoot image is 10.13.3-based, and that works really well, and the boot is fast and correct. But, when I try to apply the disk image on a Mac, it will almost immediately fail. When looking into logs (/Library/Logs/pmm_tswizard.log), I can see that TsExecutor cannot select a target disk. Se attached screen shot.

    macOS 10.13.3 HFS images works as supposed.

    Any workaround on this?

    Environment:
    • Windows Server 2016 with SCCM 1710 and SQL Server 2016 (fully updated)
    • PMM 6.1 (latest available)
    • MacBook Air 11", MacBook Pro 15" Retina, Mac vms

    //Mikael
     

    Attached Files:

    • TS.png
      TS.png
      File size:
      116.6 KB
      Views:
      9
    Last edited: Feb 27, 2018
  2. LorinW

    LorinW Bit Poster

    Messages:
    6
    Hi,

    I can deploy APFS disk images. I use a "Format and Partition Disk" step first, and format the Disk to one partition, 100% Mac OS Extended (Journaled). This step fails if the disk is already in AFPS format, so I use continue on error. But after that, I can deploy my AFPS image. The AFPS-image will wipe the entire disk contents anyway (I think)
     
  3. DannyK1

    DannyK1 Bit Poster

    Messages:
    8
    Hi all - You'll need to use the PMMOSDImageBuilder.dmg as noted in the Admin Guide starting on page 126 - only the Parallels 6.1 OSD Image Builder is supported for creating 10.13 APFS High Sierra images for deployment out of SCCM - https://goo.gl/XMYPMR.
     
  4. MikaelS1

    MikaelS1 Bit Poster

    Messages:
    15
    I've tried to create NetBoot images from both 10.13.3 APFS and 10.13.3 HFS (and tool used is PMMOSDImageBuilder). I can boot from both NetBoot images, but cannot install a perfectly valid NetInstall 10.13.3 APFS from neither of them. Of course, I can install a NetInstall image 10.13.3. HFS from any of the NetBoot images.

    NetInstall images are built with AutoDMG.
     
  5. MikaelS1

    MikaelS1 Bit Poster

    Messages:
    15
    Hmmm, didn't work for me.
    It seems to work, but in the very end of the TS installation fails.
    My solution for now is to use NetSUS to distribute a very thin image (standard OS + FirstBoot-script with naming, AD-join, SCCM-join, fetching certificates and setup WiFi). From there, all installations are done from Self Service app.
     
  6. JohnnyI

    JohnnyI Bit Poster

    Messages:
    1
    Didn't work for me... I am having an issue that it fails at the end and states "not permitted" ..... any suggestions. Followed instructions with PMMOSDImageBuilder..... Thoughts???
     
  7. DannyK1

    DannyK1 Bit Poster

    Messages:
    8
    Hi all -

    It's built to work as documented in the Admin Guide - while I applaud your work-arounds you shouldn't have to - I'd collect logs and get a ticket submitted. I've received same error and had to change the output from a desktop folder to one in Shared. This failed with the same issue that you report -
    sudo ./pmm_osd_image_builder netrestore -s disk2 -o /Users/dannyk/Desktop/NetrestoreImg/

    Best,
    Danny
     
  8. PatrickB8

    PatrickB8 Bit Poster

    Messages:
    1
    I've been encountering this as well, seems to make it almost all the way then fails on final validation. Does 10.13.4 break image capture or am I missing something?
     
  9. PatrickH9

    PatrickH9 Bit Poster

    Messages:
    1
    I too am seeing this with 10.13.4. It seems to capture just fine but fails near the end of the Checksum. Just for grins, I copied the .dmg while the checksum was running and it mounted just fine. I am thinking I try and deploy it anyway and see if it goes. I have a call later with at least one engineer I suspect is on this thread, I will update if I can deploy or succesfully capture the 10.13.4 image.
     
  10. MartinH18

    MartinH18 Bit Poster

    Messages:
    4
    I have the same problem with it failing to apply APFS 13.6 image shortly after it successfully verifies. This is using netboot image created using the latest 7.0 image builder. I can deploy High Sierra 13.6 image fine if captured off a HFS partition.
    Anyone managed to resolve at all?
     
  11. FlorinA

    FlorinA Bit Poster

    Messages:
    3
    I'm adding to what MartinH18 said. We can deploy the images if are HFS+ with High Sierra. I encounter a problem when I try to capture an image using the task sequence with APFS. Seems to be some issues with image deployment and capture for APFS that varies from build to build. Also i'm using the v7.0
     

Share This Page