Cannot install Parallels Tools on Ubuntu 8.04 (Hardy)

Discussion in 'Linux Virtual Machine' started by The Belgain, Jan 16, 2008.

Thread Status:
Not open for further replies.
  1. beta_kimball

    beta_kimball Bit poster

    Messages:
    3
    WOW.

    Prior to reading this thread, I had not heard of VirtualBox (http://www.virtualbox.org/), but I have now tried it on my MacBook Pro (OS X 10.5.2, intel) and can say that it works perfectly with Ubuntu 8. Networking in flawless, host integration is perfect (video any size I want, accelerated, mouse integration, copy/paste, etc...), and it is wicked-fast.

    I have officially dumped Parallels in favor of VirtualBox.

    It is easier to install, works with the distros I need, and, oh... it's FREE.

    Listen up Parallels: you will lose lots of customers if you don't get your linux support together in a huge hurry.
     
  2. Jisi

    Jisi Member

    Messages:
    57
    Hi beta_kimball

    is it possible to install VirtualBox besides Parallels or do kernel extensions conflict?

    Since I have paid for Parallels and not to mention the hours spent in setting up my VMs I do not really want to switch, but since Parallels has repeatedly shown that they're seriously lacking resources to fix (often EASY) problems in an acceptable timeframe it might have to switch anyway.

    At least VirtualBox doesn't cost money, so I'd have no right to be annoyed if things don't work there either:)
     
  3. Bernhard.parallels

    Bernhard.parallels Member

    Messages:
    98
    Jisi,

    I installed VirtualBox while having also Parallels installed. There is no problem I see with having both installed. HOWEVER, they cannot run at the same time. This results into Kernel Panic - at least on the two occasions I tried and I do not want to try it again.
     
    Last edited: May 20, 2008
  4. mprussell

    mprussell Bit poster

    Messages:
    8
    I'm adding my name to the request for Tools to work on Ubuntu 8.04.

    I upgraded the other day. Everything went well with only one (video RAM allocation) hitch apart from ... Parallels Tools.

    I'm not going to rudely shout or threaten to defect, but a short acknowledgement of any kind from the staff, committal or not, on here would be nice... C'mon Parallels!
     
  5. Bernhard.parallels

    Bernhard.parallels Member

    Messages:
    98
    mprussell,

    I am totally with you on that - also in your attitude that Parallels could do a lot to cheer us up and to show committment to the product and their customers. Basically I just want to continue to use the product I am using and I want it to be the best. But at the same time the occacasions to provide disillusionment on that have become more than one.

    And the said cause of Ubuntu 8.04 is already 4 months old with many users waiting, and waiting...
     
  6. chris_ottow

    chris_ottow Bit poster

    Messages:
    1
    I tried to hack the install scripts to recognize the Xorg version, which succeeded (copied the install scripts from the cdrom image, changed the functions that detected the xorg version to return 7.3 always) but the module that was installed wasn't compatible with Xorg's ABI version. The hacking stops there, I guess

    I also switched to VirtualBox now, and it works like a charm.
     
  7. Jimathy

    Jimathy Bit poster

    Messages:
    1
    Searching around I found this thread.

    http://forum.parallels.com/showthread.php?t=21021

    I downloaded the Paralllels-2.2.2232-lin.tgz file to my desktop (MAC). Extracted the archive and then mounted the file vmtools-linux.iso as my cdrom drive in my new ubuntu 8.04 installation. Ran the parallels-tools.run file within the new vm and parallels tools installed fine.

    Direct link to file with Beta Parallels tools.

    http://download.parallels.com/stuff/Parallels-2.2.2232-lin.tgz

    Mouse now moves in and out of the VM without the ctrl-alt combo, screen res needs some tweaking and shared folders doesn't look to be working. Good luck!
     
  8. Jisi

    Jisi Member

    Messages:
    57
    Hi Jimathy

    Nice that this works for you. When I tried it with Kubuntu 8.04 (KDE4 Version) the the KDM login screen looks fine, but when it logs into KDE the screen is all messed up and a few seconds later X crashes and restarts. :(
     
  9. destiney

    destiney Bit poster

    Messages:
    2
    Build 5600 Released, Still No Hardy Heron Support?

    Build 5600 was released _after_ Ubuntu 8.04, and still I get this:

    root@ubuntu:/media/cdrom# ./parallels-tools.run
    Verifying archive integrity... All good.
    Uncompressing Parallels Tools for Linux.................................................................................................
    You are about to start installing Parallels Tools. Save your data and close all
    applications to prevent data loss during possible X-Server restart.
    Continue ? [Yes/No]:Yes
    Found xorg version .
    Installation for xorg.. not found.

    I guess that translates to "Go install VirtualBox and leave us alone" ?
     
  10. trolley

    trolley Member

    Messages:
    28
    It's been posted on numerous threads that this will be fixed in the June release of Parallels. If you want to try the beta version you can find it here: http://forums.parallels.com/showthread.php?t=21021

    Download the tarball, extract it, and search for vmtools-linux.iso (I think that's the name anyway). Mount it with:

    mount -o loop <path to vmtools-linux.iso> /media/cdrom

    Then go to /media/cdrom and run the install. It worked for me. The only problem I've had so far is that I only had one resolution, 800x600, available until I edited my xorg.conf to make it fullscreen (1440x900 on my MacBook Pro).
     
  11. destiney

    destiney Bit poster

    Messages:
    2
    Oh, sorry.. What _was_ I thinking?!?!

    Clearly I didn't have time to read "numerous threads". I just found the one where in January some Parallels guy said 8.04 was "not supported yet" and then I remembered how it's been 5 months since that post and then how the 5600 build was released recently and all.

    Sorry for thinking something might have actually got done in 5 months, my bad.

    Meanwhile I've got at least 3 emails in that same time frame begging me to buy a Parallels upgrade, again. I guess marketing is more important than a working product. I mean, we use this product because we're power users usually on the cutting edge, not because we like to run old software.
     
  12. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Ubuntu 8.04 will be supported in the nearest build which is planning in the begining of June
     
  13. Bernhard.parallels

    Bernhard.parallels Member

    Messages:
    98
    Thank you for the reply.

    Two more questions: a) will Mint 4.0 also be supported and b) will there be an updated list of which Linux distributions are supported?

    In my case I wanted to use Linux with Parallels. I chose Ubuntu 8.04 first and second Mint 4.0 and had to realize that both did not work with Parallels
     
  14. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    Yes for second question exactly.
    As for Mint.
    Kernel 2.6.25 will probably be supported as I can see Mint 4 is 2.6.24, also Xorg version is 7.3 (as for Ubuntu 8.04) so I think yes.
     
  15. stf

    stf Bit poster

    Messages:
    8
    Next build (scheduled for begining of June)

    The primary reason I bought Parallels Desktop for Mac 3.0 is to run the latest Ubuntu releases on my iMac. Unfortunately this does not functioning properly with the current version.

    If I'm right, the next update build (scheduled for June) should fix the issues regarding the current ubuntu related flaws.

    So I got two questions:

    1. When will be the the localized builds available?
    2. I'm still waiting for the non-english 5600 build. Why does it takes so long?
     
  16. Bernhard.parallels

    Bernhard.parallels Member

    Messages:
    98
    stf,

    I would rather be a simple happy Parallels user than suggesting this: you might consider VirtualBox, which is free and works with Ubuntu 8.04.

    One has also to keep in mind that - if the next version works with 8.04 - it is nearly half a year for Parallels to finally make things work. Pretty long period.
     
  17. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
  18. dullerm

    dullerm Bit poster

    Messages:
    7
    Behaves the same as using Parallels Tools from Parallels 2.2.2232: The mouse is acting weird. E.g., when clicking on a Menu of the Gnome Toolbar, it opens the menu and immediately closes it again. Holding the mouse button is the only way to access a menu item. Sometimes, I can't even use ALT + F1 to open the menu (mouse driver sending mouse events all over?). Also, when using the rectangle to select items on the desktop (klick on an empty spot of the desktop and hold the mouse button, then move the mouse), there are small artefacts left at the top left corner of the rectangle after releasing the mouse button which causes the rectangle to disappear (except those artefacts, of course).

    System:
    Ubuntu 8.04 LTS, all updates applied
    Parallels 5602 on Mac OS 10.5.3
    15" MacBookPro1,1 2GHz, 2GB RAM
     
  19. John@Parallels

    John@Parallels Forum Maven

    Messages:
    6,343
    I want just to make sure that Parallels Tools also is reinstalled.
    Please confirm
     
  20. dullerm

    dullerm Bit poster

    Messages:
    7
    Start situation: Parallels for Mac 5600, Ubuntu 8.04 VM with Parallels Tools for Linux 2.2.2232 installed (showing the same behavior as described above).

    Detailled procedure applied:
    - downloaded, verified (MD5), and installed Parallels for Mac 5602
    - reboot
    - start Ubuntu VM, Install Parallels tools, open Terminal, sudo sh parallels-tools.run from CD mount point
    - shortly after responding Yes, the VM terminates and Parallel's crash windows opens. Unfortunately, sending the crash reported failed due to not being able to use Apple Mail on my machine
    - start Ubuntu VM again, drop into text mode, stop gdm, again Install Parallels Tools, this time no crash, installation succeeds without error.
    - start gdm again, test mouse behavior, still the same
    - reboot VM, test mouse behavior, still the same

    If there is any way I can verify that the recent tools are running in the VM, please let me know, then I'll double check.
     
Thread Status:
Not open for further replies.

Share This Page