Cannot log into OS X!

Discussion in 'Installation and Configuration' started by sklzacharia, Jul 4, 2007.

  1. sklzacharia

    sklzacharia

    Messages:
    3
    I am new to mac; hopefully by describing what happened, someone may be able to help me troubleshoot.

    I ran xp via parallels on os x. My keyboard was not working in xp, and I did not know the shortcut or method of getting back into os x. So I restarted the computer.

    Now at the log in page for os x sometimes the keyboard will hang. If I am able to type in my username and password, after hitting enter the color wheel spins endlessly.

    By not stopping or pausing the virtualization before restart kill my mac?
    How do I fix this?

    Thanks, Shaun
     
  2. Al_Q

    Al_Q

    Messages:
    46
    Restarting should not kill your mac, especially if you restarted cleanly (by selecting restart in the Mac menus, rather than just powering down). The worst should be a broken Parallels virtual machine from killing it without normal shutdown.

    We don't know enough to help you much -- what kind of Mac? how much RAM? what version of Mac OS? Were you running Parallels with a virtual disc (in a Mac file) or had you created a Boot Camp partition that you were using for Parallels? How did you restart your system? Have you tried restarting again cleanly using the Apple menu or the pop-up option that you get when you press briefly on the power button?
     
  3. sklzacharia

    sklzacharia

    Messages:
    3
    Because the keyboard was not functional, the only way I could restart the computer was by holding down the power button. It is a macbook pro (fairly new) so I am guessing it had 1-2gb of ram. Guessing it was the latest OS X, and the parallels was running on a virtual disc. Once again because the keyboard was not functional, and I could not get the mouse out of xp and into the mac, and I did not know the shortcuts to switch, I had to restart by holding down the power button. Looking forward to your response!
     
  4. swivet

    swivet

    Messages:
    20
    Hi Shaun,

    Unless Parallels Tools is installed and functioning in your Windows virtual machine, you have to press <ctrl> and <option> to pop your mouse and keyboard out of the VM and back into the Mac OS. One good reason to install Parallels Tools.

    The Mac itself isn't broken -- you haven't done anything that would break it. Your keyboard is working, or you could not type your login password. It does sound like at least one file involved with your login got hosed by the cruel shutdown, though. The spinning beachball announces that some process is taking a very long time... like, forever, possibly.

    If you insert the System disk that came with the machine into the optical drive and start up holding the "C" key, you will boot from the optical. Now you have some options. Don't reinstall the OS! From the top menubar, open Disk Utility and run a verify/repair of your hard drive, and then a repair of your access permissions (I would do in that order). Restart normally -- any better?

    If not, and if you haven't got another account on the same machine you can log into, then restarting from the System DVD and reinstalling the Mac OS may be your easiest fix. Use the "Archive and Reinstall" option to save the contents of your Home folder. DO NOT REFORMAT the hard drive!! That would be jumping from the pan into the fire.

    When things are back in order, you can pull items you may need out of the archived Home folder (browser bookmarks, keychain files, whatever).

    There are other measures you can take, but I hesitate to suggest as you are brand-new to all this. It's unusual to get so screwed up just because of an abnormal shutdown, but it can happen. Your whole problem could be a single temp file or a cache that should have gotten cleaned up, and very badly didn't.

    Good luck/swv
     
  5. sklzacharia

    sklzacharia

    Messages:
    3
    thanks for the advice! i will give it a try tomorrow.
     

Share This Page