Cannot upgrade to Windows 8.1 (PD9)

Discussion in 'Installation and Configuration' started by HahnB, Oct 17, 2013.

  1. HahnB

    HahnB Bit Poster

    I've got a march 2010 MBP, Windows 8 installed on a bootcamp partition, PD9 uses this partition.

    I try to upgrade to 8.1 via the Windows app store.

    Upon restart it gives me a boot error screen of some sort, saying:
    Your PC needs to be repaired
    A required device isn't connected or can't be accessed

    Error code: 0xc000000e

    , giving me options to press enter try again, press f8 for Startup Settings, or press f9 to use a different operating system. The only option that works is f9, which loads up my existing Windows 8 installation, but then an error screen comes up saying "Couldn't update to Windows 8.1".

    It's as if the installer is targeting the OSX partition. I also happen to get the same course of errors when trying to install via win 8 running natively.

    It looks as though some people in the same scenario (using win 8 on bootcamp) have passed this obstacle and are on to others.

    Any tips?
  2. Curlypaws

    Curlypaws Bit Poster

    I'm seeing the same issue and have so far been unable to upgrade to Windows 8.1 through Parallels 9.

    If it helps, I see the error codes 0xC1900101 - 0x20017 at the point that I'm told the install has failed. Searching reveals this to be a common (but apparently not definitely solved) problem afflicting a lot of Windows PCs.
    Last edited: Oct 18, 2013
  3. opdoraya


    i have win 8 on parallels desktop 9.i tried to upgrade win 8.1via win app store.after downloading win 8.1 at the time of installing it says some thing happened win 8.1 could`t be installed error code 0xc0000005. some body please help
  4. Tony Carreon

    Tony Carreon Kilo Poster

    same problem here. curious - are any of you trying to update the version of windows 8 you got from an MSDN subscription (i am) or are you using retail copies of windows 8?

    back when 8.1 was ctp, i had no problems running it (as a new setup, not an upgrade). now that it's GA, i am unable to update to 8.1 from 8.
  5. kendonb


    I'm seeing the same problem and have been unable to upgrade to Windows 8.1 through Parallels 9.
  6. opdoraya


    I finally installed windows 8.1, i refresh windows 8, then update via windows update, then installed windows 8.1. This might help, refresh would keep all of your files but will erase all of the aplications (antivirus, office,etc.), to refresh the computer you should search for advance startup option then go to the general tab then go to the windows refresh and follow the instructions. Hope this helps all of you.on parallels 9 while refresh pc may ask insert media than go to device-CD/DVD-connect image -select win 8 iso.
  7. graydog7

    graydog7 Bit Poster

    I had this problem but fixed it by setting the Hard Disk location to IDE 0:0 In the Virtual Machine settings.
  8. Mike Weis

    Mike Weis Bit Poster

    Having the same problem with the Win 8.1 from the Window store. My Virtual Machine setting for Hard Disk location was already set to IDE 0:0. Found a link to run a Microsoft diagnostic tool, which looked like it fixed a few things but still no success with the update.

    Found this comment on another site: "It seems to be that in Windows 8.1 upgrades, it freaks out if you have your primary hard disk partitioned in such a way that your primary boot partition isn't necessarily your first partition on the disk - this is the case with large vendor desktop PC's from the likes of HP and Dell who tend to have 'recovery' partitions on the disk."

    If this is the case, how to get around it in Parallels?
  9. graydog7

    graydog7 Bit Poster

    Hi Mike. Are you using Boot Camp or a Virtual disk?

    I use a virtual HD. I think that the IDE 0:0 in the VM setting is purely a logical address when using virtual disks so I don't think that the physical layout of the disk would affect that....Could be wrong, I don't know.

    If you have a Virtual Disk and already use IDE 0:0 maybe you could try one of the other locations in the list?

    Don't know what to suggest if you are using a Boot Camp partition.

    Good luck with it anyway..

  10. Mike Weis

    Mike Weis Bit Poster

    I finally got this Windows store 8.1 update to run. it was resolved by one or more of these things:
    1) Time: perhaps MS modified their store/download package. I hadn't tried for awhile.
    2) VM memory: I had only given it the default .5G. I never noticed a problem until a Quicken update complained it needed 1G. so I gave it 1.5G.
    3) Parallels offered an update yesterday, and I installed it.

    In hindsight, #2 may have been the most significant.

Share This Page