Can't boot - "autochk program not found - skipping autocheck" after XP SP3

Discussion in 'Windows Guest OS Discussion' started by Al_Q, May 26, 2008.

  1. gk1

    gk1

    Messages:
    2
    "Official" solution for virtual machine failure?

    I have the situation where I installed the SP3 update in boot camp, and parallels desktop is not working (autochk error), but boot camp still is. I cannot find any "official" KB article addressing this situation. Not that I don't trust those here, but is there an official solution to this issue?

    I can do the "Clear" solution or course, but I am concerned this will then affect my Boot Camp Windows boot-up (I thought i saw a post that says it does).

    Can someone confirm that it will not?
    thanks
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,450
    Please check following
    Build should be at least 5608 (version 3)
    If yes, no problem, just click Clear button, it will not affect your Boot Camp
     
  3. gk1

    gk1

    Messages:
    2
    latest build

    Thanks a lot for the reply. I have build 5608. I noticed there is one build beyond that. Are there any differences between the two that are notable?
    thanks
     
  4. John@Parallels

    John@Parallels

    Messages:
    6,450
    Build 5626 added Parallels Tools for Linux, and it is US version only, if yours is US, please upgrade to that build
     
  5. EatingPie

    EatingPie

    Messages:
    15
    Basically, it all came down to...

    I had the authchk not found error in Boot Camp, not in the Virtual Machine. These great instructions above worked for me, but it really came down to one simple thing...

    Uninstall SP3 in Parallels

    Once I did that, rebooting in Parallels to make sure it was all taken care of, I could then hard boot my Boot Camp Partition without the autochk error. I reinstalled SP3 from there, and any other updates, and was all fine and dandy.

    I also upgraded from PD3 to PD4 at this point.

    KB article 5447 deals with failure in the VM, not Boot Camp. I'm disappointed there isn't a KB article that specifies the Boot Camp situation. Or maybe one does and I don't know about it. If so, it should include mention of SP3 being the cause of the problem, and just.do.it's instructions for fixing.

    I waited a long time to for his fix because I thought it was ludicrous to have to reinstall Windows... and I still do.

    -Pie
     
  6. DaTa

    DaTa

    Messages:
    194
    Hello, EatingPie

    Actually the situation is mentioned in the Knowledgebase article
    http://kb.parallels.com/en/4875

    The article applies to Parallels Desktop version 3, but is valid for version 4 as well.
    I will request adding version 4 to "APPLIES TO:" list.
     
  7. EatingPie

    EatingPie

    Messages:
    15
    Well, I don't actually see how your referenced KB article is the solution at all.

    All correct up to this point, but we run into problems here...

    In the autochk issue, you cannot boot via Boot Camp. Therefore you cannot repair via Bootcamp.

    The solution is to uninstall SP3 (via Microsoft's guidelines) from Parallels. That is the key to the whole thing.

    You really need to add that. Especially since the first reply from the Parallels team is almost always to reference a KB article. None of those have the specific fix of uninstalling SP3 (this avoids the absolute horror of re-installing Windows).

    Please, please update your KB articles to include uninstall of SP3. Oh, and to make sure I'm clear, my fix is for Boot Camp failing on autochk, but Parallels booting fine. There's various permutations of the issue, and this was mine.

    Thanks!

    -Pie
     
  8. lech@kowalczyk.cz

    lech@kowalczyk.cz

    Messages:
    4
    Dear Sirs, I'm using your great piece of sw since almost 1 year. I was OK till the moment when I've installed SP3 unfortunately via VM run via Parallels. I did not care too much, as I wasn't forced to boot in XP natively. Unfortunately recently I had to do so and I got an 'autochk' error. So, I've started to look for solution on web and found this thread. Believe me I went through the all of posts very carefully. And I applied 5447 way. Everything was fine till I've uninstalled BootCamp 2.0, reinstall it (incl. all of drivers) and tried to download BootCamp 2.1 upgrade via apple software upgrade. When download finished I got an error message telling something about corrupted ... Therefore I've downloaded this upgrade from apple site and tried to run BCUpdateXP.exe manually. After clicking on this exe file, nothing happened even after 30 minutes! So, is there any advice or idea how to install this required update???

    Thanks in advance for your effort and/or advices.

    Lech
     
  9. Specimen

    Specimen Product Expert

    Messages:
    3,256
    I haven't seen this problem in a long time, let me see if I recall the procedure correctly. The problem is that the 2.1 patch has a bug when you're using The english version of Windows with the language settings and keyboard for another language (weird, eh?). So, before applying the patch change temporarily the language settings and keyboard to American english and it should run fine.

    There was/is a thread in Apple forums about this, there were other possible issues or solutions there if I recall.
     
    Last edited: Feb 5, 2009
  10. lech@kowalczyk.cz

    lech@kowalczyk.cz

    Messages:
    4
    Thanks Specimen. I'm using CZ version of XP Pro. I will try to follow your suggestion later on today and will let you know the result.

    Have a nice day.
     
  11. lech@kowalczyk.cz

    lech@kowalczyk.cz

    Messages:
    4
    Thanks a lot Specimen for advice. That's true I'm using CZ version of XP Pro. Let me try to follow your suggestion later on today. I will let you know the result.

    Have a nice day.
     
  12. Krel

    Krel

    Messages:
    9
    Peter,

    Thanks for posting your solution! I am adding my very lengthy post as well in the hopes it helps other.

    I have not posted back on this issue for several months because I was too busy and ended up using VMWare as a working solution to my client's "Can't boot - "autochk program not found - skipping autocheck" after XP SP3 upgrade" problem. Now that I have the time, I went back and tracked down a Parallels work-around that works for my specific situation. (In the meantime, parallels engineering did attempt to collaborate with me on reproducing and finding a work-around but I had to decline granting them remote access to the systems and couldn't waist any more billable time on this problem.)

    Review of my problem (to make the situation absolutely clear and hopefully avoid unnecessary forum chatter):

    * Client has 20 macbooks with Parallels 3.0 (build 5608) running BootCamp (v2.1) XP-Pro SP2 in dual-boot usage. They needed to upgrade them to SP3.

    * All machines were backed up (via winClone) and then upgraded to SP3 via native BootCamp XP (using Microsoft SP3 CD).

    * The SP3 machines were rebooted under native Bootcamp and tested.

    * Then rebooted under Parallels VM applying "Configuration Editor -> Hard disk 1 -> Advanced and click 'Clear'" to remove Parallels Desktop information from BootCamp (per KB #5447 item 10) and tested.

    * Then rebooted under native Bootcamp again as a crosscheck.

    Three of the machines ended up with "autochk program not found -- skipping autoch" BSOD error on their final native BootCamp reboot after their prior Parrellels VM boot. The three machines were restored to their backup images and chkdisk was run to check their NTFS filesystems were correct. Two attempts to use Parallels build 5626 were also tested. The two machine all got the same BSOD error again on their first native BootCamp re-booot after a prior Parrellels VM boot. It was clear there was a subtle Parallels bug that affected a subset of the users when upgrading XP to SP3 even when the upgrade was done using the correct procedures (I think Parallels has still not documented recommended procedures for BootCamp XP SP3 Upgrade in their Release Notes - see my prior posts).

    My Solution: (Compete de-install/re-install Parallels Desktop and re-configure BootCamp VM paramaters. May require Microsoft XP Registration of newly constructed XP VM)

    * Back up the functioning dual-boot Parallels/BootCamp XP-SP2 partition (e.g. via winClone). The XP system should obviously not be running while the partition is backed up. (A backup is always good to have if things fail.)

    * Boot under Parllels and and Jot down a copy of your current BootCamp VM configuration settings.

    * Un-install Parallels Tools from XP VM (via Control_Pannel->Add_or_Remove_Programs). Reboot under Parallels and confirm that Parallel Tools is no longer being used.

    * Shutdown XP-SP2 VM and then "Configuration Editor -> Hard disk 1 -> Advanced and click 'Clear'" to remove Parallels Desktop information from BootCamp. You should now have a clean BootCamp partition with absolutely no Parallels fingerprints on it.

    * Quit Parallels Desktop and apply KB #4790 to completely un-install Parallels Desktop from Mac OS. In addition, Remove any Parralel VM configuration files (*.pvm) files you may have.

    * Reboot under native BootCamp XP-SP2 and test

    * Upgraded to SP3 via native BootCamp XP. Reboot XP-SP3 and test.

    * Reboot Mac OS and re-install Parallels Desktop. You may need to re-enter your Parrallels Activation Key.

    * Reconfigure the automatically detected BootCamp VM configuration back to your old saved settings before your first VM boot.

    * Boot (via Parrallels) your BootCamp XP-SP3 VM, install Parallel Tools and test. (May require Microsoft XP Registration.)

    * Reboot under native Bootcamp again as a crosscheck.

    I hope this helps some folks. As I said in an earlier post, I suggest Parallels document in their v3 Release Notes recommended procedures for updating BootCamp XP-SP2 to SP3 and that Parallels Desktop should first be completely un-installed (ala KB4790) prior to attempting the XP-SP2 upgrade to SP3. The Release Notes should warn of the possible consequences of BootCamp partition corruption if Parallels Desktop is not un-installed.

    PS> I have not tried using PD V4. They may have already fixed this and v4 may now reliably support XP-SP2 to SP3 Upgrade when done under native BootCamp XP boot.

    Krel :)
     
  13. Roberta Dikeman

    Roberta Dikeman

    Messages:
    1
    Thanks!

    I was in boot camp and updated to SP3, then I paniced when I couldn't run in parallels.
    Your clear Parallels data suggestion from the boot camp hard drive worked like a charm. Thank you
     
  14. Flagg

    Flagg

    Messages:
    220
    Krel,

    A very informative post there. Thank you for your input and time!
     
  15. scotto

    scotto

    Messages:
    33
    I think this may be a twist on the problem. I boot into native Boot Camp so rarely that I didn't realize that I had the autochk problem until very recently, and can't boot natively. I believe it was likely caused by doing the SP3 upgrade through the Parallels VM (who knew?). There have been a number of Windows updates since then, and I don't know if it's safe any longer to just uninstall SP3. Furthermore, Winclone is unable to complete a backup of Boot Camp - maybe a bad sector - and it appears that I would have to boot into native Boot Camp to fix such things (is that correct?). So:
    1) I can't back up
    2) The recommended procedure seems like it might be quite hazardous without a backup - or is it just low-risk misery?

    Thanks.
     
  16. staffing power

    staffing power

    Messages:
    1
    HI

    I was in boot camp and updated to SP3, then I paniced when I couldn't run in parallels.
    Your clear Parallels data suggestion from the boot camp hard drive worked like a charm. Thank you its rocking....


    Staffing service

    Seo master[​IMG]
     
  17. Rodeoguy

    Rodeoguy

    Messages:
    1
    I had the autochk issue when trying to open bootcamp. I could access my windows partition through Parallels desktop.
    I uninstalled SP3 through Parallels, using the #2 Method from Microsoft. Rebooted twice.
    Then I was able to enter through bootcamp.
    I re-installed SP3 in bootcamp, then tried to access through Parallels. It started with the Autochk.
    I then did the "clear parallels" part, logged in and just had to hit a button to "activate windows".
    I think I'm all fixed...with all of the solutions provided.
     
  18. Juli

    Juli

    Messages:
    1
    There is a similar tool for checking the history of the auto vincheck.expert. Just I noticed that there are cheaper.
     

Share This Page