Can't boot - "autochk program not found - skipping autocheck" after XP SP3

Discussion in 'Windows Guest OS Discussion' started by Al_Q, May 26, 2008.

  1. John@Parallels

    John@Parallels

    Messages:
    6,440
    Well , I understand your frustration , but let us see
    1. You say Corruption is back after steps 10.11.
    10. Navigate to Configuration Editor -> Hard disk 1 -> Advanced and click 'Clear' to remove Parallels Desktop information from Boot Camp.

    11. Start Virtual Machine and reinstall Parallels Tools.

    If you check my earlier comments, I mentioned , that in case to avoid any relation to Parallels Desktop, try to uninstall Parallels Desktop, and install it back,
    I tested this scenario about 12 times, performing even virus infection to Boot Camp Windows, and this (virus infection) was the only case when Windows got corrupted again, as virus messes registry entries back.

    The situation is unfortunately very complicated in term, that we cannot get remote access to such Mac just to point to fact that problem is on Windows side, or on Mac OS side not in Parallels.
    I always ready to check any situation, but simple saying it doesn't work, without even taking a look in Window System and Application logs, without knowing software installed on Mac OS side, is simply for no use.
    As I can see you didn't even list software installed in Windows side, which may cause such situation
     
    Last edited: Oct 19, 2008
  2. R. Peter DeLong

    R. Peter DeLong

    Messages:
    6
    Simplified Twist on This Problem

    All -

    I have read all the messages in this contentious thread. Thank you all for the effort put into the discussion. I am a new Parallels user, having three machines to maintain. Two are business-related, and have Boot Camp installed, because they must to be able to run their essential (Windows) software no matter what goes wrong with Mac OS or Parallels.

    The two business machines have clean fully updated installations of Mac OS X.5.5, Boot Camp 2.1, Parallels Build 5608, and Windows XP with SP2. After reaching that point, I found that Windows XP needed some 23 updates. I chose to do the updating from the Parallels side, all the way through SP3, and I now have the problem of being unable to boot into Boot Camp that has been referred to many times in earlier posts.

    My question is, what are the minimal instructions for me to get my business machines back in full working order?

    Thanks.

    - Pete
     
  3. John@Parallels

    John@Parallels

    Messages:
    6,440
  4. Specimen

    Specimen Product Expert

    Messages:
    3,256
    If you have BC 2.1 and Parallels 5608, then this error shouldn't have happened, my suspicion is that you upgraded to Parallels 5608 from an earlier version but the update was incomplete or you didn't update Parallels Tools inside the VM.
     
  5. R. Peter DeLong

    R. Peter DeLong

    Messages:
    6
    Nope. I've never owned any version of Parallels other than 5608. Just bought three copies from Amazon.com. I think the problem is still there, and is due to my installing SP3 for Windows XP in Parallels. These are all brand-new installs in brand new iMacs.

    I asked for a minimal solution because 5447 has extraneous BC 2.0 -> 2.1 stuff.
     
  6. R. Peter DeLong

    R. Peter DeLong

    Messages:
    6
    If I follow the 5447 approach, and create a slipstreamed installation CD for Windows XP with SP3 as explained in 5446, do I have to create a separate CD for each machine, using the original installation CD for that copy of Windows XP?

    Is there any risk creating the slipstreamed CD in Parallels? (I suppose I should burn a CD for practice first.)

    Also, I guess it's obvious that I have to trash all the Windows software and transferred data files that are now on the C: drive and reinstal, right?

    - Pete
     
  7. Specimen

    Specimen Product Expert

    Messages:
    3,256
    You installed SP3 under Parallels. That's what caused the problem, system updates that somehow mess with the hardware such as a Service Pack should be installed under Boot Camp and never under Parallels.

    First, the BC 2.0 to 2.1 is needed because Apple only released 2.1 as a patch to 2.0, they didn't release it as stand-alone, so you have to have 2.0 installed in order to get 2.1, it's extraneous, I know, complain to Apple. The only way to get directly to 2.1 is probably with the OSX DVD for more recent systems which probably already come with BC 2.1, if this is your case then your job is easier.

    A slipstreamed XP CD with SP3 is good far all machines, it will be like a retail XP with SP3 cd if MS would sell those (it sells, or sold, XP with SP2). You can slipstream it under Parallels, and burn the resulting .iso in OSX, I suggest you use nlite for slipstreaming, it's much easier, although John refuses to mention this program in the article because it can be used to make a slimmed down version of XP which is apparently not allowed by XP EULA or whatever. Nlite is a powerful and versatile tool, slipstreaming a Service Pack is only part of what it can do but even just for that it simplifies the procedure very much since it creates a bootable .iso automaticly.

    The repair install procedure you're going to make won't delete your installed apps or data, it only fiddles with the Windows installation itself, reseting it to a default XP SP3 state, which means, that most if not all Windows settings are reseted to their default state (for instance, if you disabled any services, like System Restore od the Indexing service which tend to be performance hogs, these service will be enabled again), also, any Windows update made after SP3 was installed is lost, which isn't a problem since SP3 is fairly recent, it would be a problem if you were repair installing with a XP CD with SP2 which would revert all Windows files and settings to that version and discard any updates to SP2.

    You should do a backup using Winclone prior to doing this procedure.
     
    Last edited: Nov 1, 2008
  8. R. Peter DeLong

    R. Peter DeLong

    Messages:
    6
    5447 Procedure Does Not Work

    The procedure outlined in kb.parallels/en/5447 does not solve the "autochk not found" problem.

    I created a bootable Windows XP CD with SP3 slipstreamed into it (This took me days to get right. Only Nero seems to be able to get the boot image file in the right location on the CD).

    I performed the repair installation in Boot Camp.

    I uninstalled and reinstalled the Boot Camp drivers in Boot Camp, and once again updated to Boot Camp 2.1.

    I reinstalled SP3. I reinstalled all the Windows XP updates, and reactivated Windows XP, all in Boot Camp.

    I restarted OS X.5.5, started Parallels holding the Apple key, and cleared the Parallels Desktop data from Boot Camp (whatever that really means).

    I restarted Parallels, and verified that I had the same server and printer connectivity that I had before, and which I had checked while still in Boot Camp.

    I shut down Windows, the Parallels VM, and exited Mac OS X.

    I rebooted into Boot Camp, and got "autochk not found".

    I rebooted into Mac OS X, tried to run Parallels. Now, the Windows cursor responds to mouse movement only by increasing both x and y pixel position by 1 for each pixel moved by the mouse. So, each motion of the mouse moves the cursor steadily SE on the screen until the cursor runs into the bottom of the screen. On its trajectory, it misses the icon for logging in, so the only way I have to exit Parallels is by Force Quit in Mac OS.

    I consider this particular fault to be random corruption, and I suspect that other users will encounter other problems.

    What is clear to me is that neither we nor Parallels staff really understand this problem. I was suspicious at the start because 5447 did not seem to me to reflect the wisdom of the preceding discussion. However, I supposed that it was based on some testing and analysis.

    Krel and others' remarks about 5447 seem to be correct.

    I would like to hear from _anyone_ who has a dual Parallels/Boot Camp configuration working with Windows XP SP3. I think the evidence is strong that Parallels does not support Boot Camp installation of SP3 at all.

    - Pete
     
  9. Specimen

    Specimen Product Expert

    Messages:
    3,256
    You're wrong. You should've assumed from all I said that, indeed, I have XP SP3 running on Boot Camp Parallels. Like probably most XP+Parallels+Boot Camp users which by now are already with SP3.

    I've been helping out people with this problem from the start of this thread because I actually solved the problem for me first, back when there even wasn't a Parallels build that would support SP3, back then it was more understandable why people got into this mess. Nowadays, with the latest Parallels build, if you do everything right you won't get into any trouble.

    If you had read this thread more carefully you had found that the cause is not random corruption, it's just a registry entry that's changed but causes all this havoc, and versons of Parallels prior to 5608 are not "prepared" to handle this registry change in SP3 (Parallels mirrors Windows Boot Camp registry and changes the hardware entries, or something like that).

    If you had burn the .iso produced with nlite in OSX like I said it wouldn't have took you days.

    You weren't supposed to install all the Windows updates besides SP3, and I have my doubts if SP3 was correctly slipstreamed.

    I understand you're frustrated, but don't go jumping into conclusions because of that. Besides if you had follow my advice you wouldn't have wasted so much time.

    Most cases I can remember of people reporting that KB5447 doesn't work were in fact because people didn't correctly followed the procedure (mostly becuse they thought some steps of the procedure could be done in some other way, or were unimportant) or mine and/or John's advice.
    Besides, The people that get their problems solved normally don't report back on their success, hence this thread might seems skewed in favor of failure, since people only report when they have problems.

    Finally, the impression I get from what I read from you is that everything I wrote in my last post flew right over your head. I personally lose all the interest and goodwill in helping people out when they refuse to follow advice and start playing the blame game.

    Sorry, but, I don't feel like helping someone that refuses to follow advice.
     
    Last edited: Nov 7, 2008
  10. R. Peter DeLong

    R. Peter DeLong

    Messages:
    6
    I'm sorry I sounded ungrateful

    Specimen -

    I didn't mean to sound like I was criticizing you or your advice. Sorry.

    I tried nLite first, following your suggestion. It did the slipstreaming, but I failed to get a true bootable .iso out of it. I also tried WinISO, but the free version refused to handle some large image file in the mix. I used bbie to get the boot image file extracted, but didn't understand why IsoBuster extracted the same file with a different name, so I used the IsoBuster version. Nero took a very long time to download, but it had a bootable disk as an explicit burn choice, and handled the boot image separately, so I ended up using it - probably because I felt I could understand what it was doing. They're the combination prescribed by 5446, so I felt secure using them, even if they were not the very best choice.

    I suppose there could be something wrong with the slipstream I created, but it did boot and act normal. The resulting Windows installation seemed to work fine in Boot Camp. All my network connections, printers, and applications worked.

    It was only after I lit off Parallels that things went awry. When I came back to Parallels the second time, the cursor problem was present. This is the behavior I meant was random corruption, not the autochk problem.

    Based on earlier discussion, I thought it was not only okay, but desirable, to do updates to Windows XP, as long as they were done from the Boot Camp side. You pointed out that my (original) mistake was to have installed SP3 on the Parallels side.

    I tried very hard to follow the instructions in 5447. I would appreciate it if you would point out where I might have done the wrong thing (other than not using the best tool to create my slipstreamed instal disk).

    Thanks for your continuing service to the discussion list!

    - Pete
     
  11. Krel

    Krel

    Messages:
    9
    To: R. Peter DeLong (KB Forum ID


    I have struggled with updating a dual boot BC/PD XP-SP2 to XP-SP3 for over 22 man-hours and have had no success. In my particular case, I had attempted to update to SP3 via the correct procedure of using a native BC environment. You are not alone, several others have also had the same net result when applying KB 5447 (Forum userids users zoozie, jakoban , Cocoa Beast, TimeLordBob , pkasin, ... etc...).

    I have already submitted User Problem Ticket #585060 on 9/5/08 which was eventually "Closed" by Parallels Support with the following Parallels comment: "The issue you are talking about is known issue and we have plenty of information how to fix it in our knowledge base articles, described procedures are working fine." (No need to repeat the details of several exchanges I had with them in that ticket since it is mostly a rehash of what I had already stated in this forum).

    I resubmitted a new Problem Ticket #601792 on 10/19/08 which I have just now escalated since it has been a week since I gave Parallels support my phone number and no one has yet called me or sent me any further email. I had also sent email directly to (Parallels Vice President, Virtualization and Tools) and other Parallels engineers I happen to know in Technical Sales Support to draw their attention to this support issue. As a result I received sincere email from various engineers trying to reproduce the problem, but with no such luck. The SP3 update (when performed correctly under native BC) completed in their environments and only steps #10 and #11 og KB 5447 needed to be applied after the upgrade. The end result was they had no corruption of either the PD or Native boot.

    I have already asked Parallels several times to include a technote in the PD v3.0 Release Notes defining the proper steps for upgrading BC XP-SP2 to SP3. Lets see if they are willing to do it in the future.

    It is clear the latest production PD release (build 5608) has a subtle bug when upgrading from SP2 to SP3 that only a subset of the users are encountering (most probably a Windows Registry related bug, though I have no proof,). I know of users who have not had any problems in installing and running build 5608 on the an already upgraded XP-SP3 BC environment. Thus I think the additional recommended step to KB 5447 of first completely un-installing PD on both Mac OS and XP (as described in http://kb.parallels.com/en/4790) and re-installing PD on MAC OS before attempting to boot XP back up under PD may be a reasonable fix to your problem. Unfortunately, I can longer afford to waist time on this (see my prior posts) to check if this actually works. I am content to restore my system back to my original XP-SP2 backup image and stay at SP2 until some other brave soul pioneers the solution to this problem.

    If you do attempt to include KB 4790 as additional steps before KB5447 step #10, please let this forum know of your results!!!!!

    If it does work, I suggest Parallels recommend in their procedures for updating BC XP-SP2 to SP3 that PD should first be completely un-installed (ala KB4790) prior to attempting the XP-SP2 upgrade to SP3. The Release Notes should warn of the possible consequences of BC corruption if PD is not un-installed.

    Good luck,
    Krel
     
    Last edited by a moderator: Nov 8, 2008
  12. John@Parallels

    John@Parallels

    Messages:
    6,440
    Jenny tried to contact you, and there were no answer in ticket during one week.
    US, and NSK support team tried to contact you several times, while I am writting

    PS> Please remove Parallels employers personal info from your post,
    You can leave mine, as it is nickname
     
  13. John@Parallels

    John@Parallels

    Messages:
    6,440
    As my colleague have told me you want we to investigate problem in 40 days
     
  14. Specimen

    Specimen Product Expert

    Messages:
    3,256
    Note to Krel.

    Just to make things clear since you included me in the CC field: I'm not a Parallels employee, nor in any way paid by Parallels. I'm a Parallels Desktop paying customer.
     
  15. Specimen

    Specimen Product Expert

    Messages:
    3,256
    To R. Peter DeLong:

    It's true the Windows updates should be made in Boot Camp. What I meant was, before fixing the autochk problem it's safer to refrain from installing additional updates besides SP3, I would install those only after everything is working correctly.

    As I said before, after slipstreaming SP3, the resulting .ISO could've been transfered to Mac OSX and burned thru the Disk Utility.app, it would have been quicker.

    The only possibility that occurs to me right now is that you're not running Parallels build 5608 but a previous version or a corrupted installation of Parallels, or, there's a subtle bug in 5608 like Krel said. Thus completely uninstalling Parallels for the Mac and Parallels Tools from Windows, using KB4790, then do KB5447, and then download and install PDM 5608 should solve your problem.
     
    Last edited: Nov 8, 2008
  16. John@Parallels

    John@Parallels

    Messages:
    6,440
    Removed personal info from post
     
  17. The Duelist

    The Duelist

    Messages:
    28
    This Solution Worked For Me

    Thanx Blinky

    Your Concise (But Detailed) Solution Worked For Me :)
    (The Only Things I Did Differently Were The BootCamp 2.1/XP SP3 Updates Were Done Via Download)

    I Had Previously Updated To XP SP3 Inside Parallels (5608) Running Bootcamp 2.0.
    Parallels Was Running Fine But I Couldn't Boot Into Bootcamp.

    Several Days I Tried Different Ways (Unsuccessfully) To Run The Windows/PTEDIT Solution :(
     
    Last edited: Nov 8, 2008
  18. R. Peter DeLong

    R. Peter DeLong

    Messages:
    6
    Here's What Worked for Me

    All -

    I now have Windows XP with SP3 working with Boot Camp on two iMacs. I have only a few minutes to write before a trip, so here is a sketch of what I did on each machine:
    - Uninstalled Parallels.
    - Erased all virtual machines.
    - Repaired permissions.
    - Erased Boot Camp partition with Disk Utility, back to FAT32 format.
    - Ran Boot Camp Assistant, reinstalled Windows XP with SP2, formatted BC partition as NTFS.
    - Installed Boot Camp drivers from iMac installation DVD #1.
    - Updated Boot Camp to 2.1.
    - Installed all the essential Windows XP updates I should, including SP3, using the Windows Update tool.
    - Installed most of the target business software (still lacking McAfee antivirus, however).
    - Made sure all printers, shared folders, other Windows configuration things were working.
    - Booted into Mac OS X.
    - Installed Parallels.
    - Repaired permissions.
    - Created new virtual machine for Boot Camp, using "Custom" choice in installer.
    - Deleted ghosts of previous virtual machines that reappeared (so erasing of virtual machines was not complete, somehow).
    - Success!

    I hope people find this encouraging.

    - Pete
     
  19. just.do.it

    just.do.it

    Messages:
    4
    Another solution

    Ok, here's another one, maybe helpfull to others. That's what i did to upgrade from parallels desktop 3 to 4 and to work around the autochk bsod:

    - Reinstalled version 3 of parallels desktop
    - start windows in parallels
    - uninstall SP3
    - reboot windows in parallels
    - shutdown windows
    - remove paralells support from boot camp partition
    - uninstall parallels desktop 3
    - boot into windows
    - install SP3
    - install all additional windows updates of your choice
    - boot into mac os
    - install parallels desktop 4
    - create NEW! VM with boot camp partition
    - install parallels tools

    It took some time but i got it up and running again without reinstalling windows.

    Best Regards
    Dirk
     
  20. houser

    houser

    Messages:
    2
    thanx just.do.it

    exactly the same fix helped me out. Appreciated!
    It was ok to upgrade the virtual machine though.
    Just wanted to express my gratitude for taking the time to write this.
     

Share This Page