Cant connect my USB device (telescope) after PD 17.1.0 Update

Discussion in 'Windows Guest OS Discussion' started by yasara, Oct 19, 2021.

  1. IainS4

    IainS4 Bit Poster

    Messages:
    3
    I am addig my name to the USB not working - in my case a USB to RS232 adapter - worked fine for years but now 17.1.0 it didn't work - in Windows 10 Device Manager all was well, but couldn't actually communicate. I may well try reversing to 17.0.1 and see if it helps. Seems to be a widespread issue
     
  2. ThomasH76

    ThomasH76 Bit Poster

    Messages:
    5
    JoachimV and SebastianS17 like this.
  3. IainS4

    IainS4 Bit Poster

    Messages:
    3
    Can confirm that it seemed to work OK with V17.0.1 from a brief test - thanks to anyone who posted that....
     
  4. TomF11

    TomF11 Bit Poster

    Messages:
    2
    Parallels - why release a half baked update? We've all wasted a half day working out why our USB accessories no longer work after an 'update'. Sort this out before releasing updates! Thanks for your support.
     
  5. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello guys, the newest Parallels Desktop 17.1.1 update has been released recently.
    And it resolves a USB devices connectivity issue.
    Please check the issue and let us know the results.
     
  6. DanielT30

    DanielT30 Bit Poster

    Messages:
    3
    still not working completely with 17.1.1 (I'm running MacOS 11.6.1 and Windows 10).
    USB flash drives seems to work. Android devices for debugging oder file transfer still not working.
     
  7. HansR2

    HansR2 Bit Poster

    Messages:
    5
  8. AlbertN2

    AlbertN2 Bit Poster

    Messages:
    9
    Originally had issues with SpeechMike (USB speaker and microphone) on Macbook Air M1 with Windows 11 for ARM with PD17.1.0
    Downgraded to PD 17.0.1-51482 as suggested few weeks ago and the SpeechMike was recognized successfully.
    Updated to PD17.1.1 and the SpeechMike recognition failed again.
    Windows freezes when trying to playback audio via the SpeechMike, unplugging the SpeechMike (or disconnecting from virtual machine) unfreezes the virtual machine.
     
    JoachimV and GarethL2 like this.
  9. GlennS5

    GlennS5 Bit Poster

    Messages:
    14
    I just installed 17.1.1 that fixed USB issues for me. The 17.1.0 is the release that gave me USB issues that seems to be solved with the 17.1.1 release in my case.
     
  10. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hi, could you collect the technical report and share the report's ID here please?
     
  11. ZachD2

    ZachD2 Bit Poster

    Messages:
    1
    Yea I have exactly this issue. Huge disappointment after already wasting half a day realizing the issue was parallels originally.
     
  12. AlbertN2

    AlbertN2 Bit Poster

    Messages:
    9
    Hi Maria,

    Compared to PD 17.1.0, PD 17.1.1 does allow the ability to recognize and connect the USB SpeechMike to the Win11 virtual machine.
    Audio playback through this USB is laggy and stutters. Recording seems unaffected.

    I have produced and sent technical report ID: 384967418
     
  13. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    398
    @AlbertN2 Double check the input and output settings in System->Sound. While there were USB problems it may have inadvertently set the bit depth and/or speed to something ridiculously high.
     
  14. GarethL2

    GarethL2 Bit Poster

    Messages:
    1
    I have the same set up for dictation using both a Philips Speechmike on the go, and a Philips SpeechOne at home. I run windows 10 on parallels on a MacBook Pro.

    I saw your message, as I had the exact same problems you encountered on upgrading to 17.1.0. I downgraded as you suggested, and it resolved the issue. I daren't not upgrade to 17.1.1, given the fact it has failed to resolve issues for you and created new ones. I think I'll have to wait and see what the next upgrade brings.
     
  15. AlbertN2

    AlbertN2 Bit Poster

    Messages:
    9
    Thanks for the suggestion, unfortunately not many options available for my USB recording/playback device.
    After extended testing with PD 17.1.1 and Win11, very unreliable playback and recording when USB device is connected to Win11 virtual machine.
     
  16. AlbertN2

    AlbertN2 Bit Poster

    Messages:
    9
    On 17.1.1, as a workaround, I managed to use my SpeechMike with DMO by setting it in keyboard mode and not connecting it to the virtual machine. I do lose a bit of SpeechMike advanced functionalities when using it as keyboard mode vs event mode, but at least I can dictate.
     
  17. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    908
    Hi, please upgrade to Parallels Desktop for Mac 17.1.1 version and let us know if still the issue persist.
     
  18. RobG8

    RobG8 Bit Poster

    Messages:
    1
    I just found this thread after upgrading to 17.1.1 and it broke my ability to use my Android phone with my Linux Parallels VM. Downgrading fixed it.
     
    ZachD2 likes this.
  19. KavehV

    KavehV Bit Poster

    Messages:
    32
    I also continue to find USB highly unreliable in 17.1.1. Devices may look like they're connected, but they aren't at all reliable like they used to be. An example is using TI's XDS110 debugger in a Windows VM, it has all sorts of reliability and flakiness that wasn't there in version 17.0.1. I had to downgrade again.
     
  20. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    908
    Hi, kindly upgrade to 17.1.1 . After recreating the issue send us a technical report by following https://kb.parallels.com/9058 so that we can investigate further and help you with a resolution.
     

Share This Page