Can't connect to internet in XP

Discussion in 'Windows Guest OS Discussion' started by ubernos, Aug 18, 2007.

  1. ramonekalsaw

    ramonekalsaw

    Messages:
    25
    I still don't have Internet connectivity, and because I don't have the time to keep troubleshooting the problem, I've just been using Parallels to run my WinXP programs: telling myself, that the upside is, since I can't get to the internet from Parallels' the Windows viruses, et. al. can't get to me. But I still would like to get full functionality from Parallels.

    I have been working intermittently with Parallels support, but have lost contact since my last interaction which suggested another reinstall of the software ... et. al. But like I said, I have to earn a living and can't keep troubleshooting on a hit and miss basis.

    But it's been a couple of months so I guess it's about time to try again : / But before I do I noticed this:

    I just installed a stat widget for 'network' which lists the data listed below. I see that there are two items for "Parallels": Could this be causing my internet connectivity problem?

    Airport - en1
    Local IP: 192.168.0.3

    Parallels Host-Guest - en2
    Local IP (none)

    Parallels NAT - en3
    Local IP: 10.211.55.4
     
  2. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello all,

    Edwardd20, you can restart DHCP instead of restarting your Mac:
    In Mac - System Preferences - Network Show Built-in Ethernet choose Off for Configure IPv4, click Apply. Then choose Using DHCP and click Apply again.
    This is just a workaround. In future builds the bug is going to be fixed.

    Using Bridged Ethernet instead of Shared Networking and turning Firewall off are also the workarounds that were proved to be helpful by many users.

    Ramonekalsaw, the data you've given does not let us see where the problem is.
    Please try disabling Firewall on both Windows and Mac sides.
    Could you also run the command tracert www.parallels.com in CMD window (Start -> Run -> CMD) and attach the output to your next post?
    This is supposed to clarify on which step the connection gets lost.

    Thank you!

    Best regards,
    Xenos
     
  3. edwardd20

    edwardd20 Bit Poster

    Messages:
    30
    I've tried turning DHCP off and back on but that doesn't work consistently. Bridged networking works fine at home but it doesn't work "on the road" when I'm limited to 1 IP address (at hotels).

    Looking forward to the day when this is truly fixed.
     
  4. kallisti

    kallisti

    Messages:
    2
    Possible easy fix

    I was also experiencing difficulty connecting with Internet Explorer. Kaspersky Internet Security software was receiving updates (so I had an internet connection), but IE wouldn't load pages. I had turned off the firewall settings in XP, but it still kept showing that firewall was "on" in Windows Security Center.

    The problem turned out to be with the Kaspersky Internet Security software bundled with Parallels. Turning off its firewall fixed my IE connection problems.

    To do this:

    (1) Click on the stylized "K" to the right on the windows taskbar (this should bring up the Kaspersky interface)

    (2) Click on "settings" in the top right portion of the window

    (3) Highlight "anti-hacker" in the left column under "Protection"

    (4) Uncheck "enable firewall" in the pane on the right

    (5) Click apply

    I doubt that everyone's problem will be fixed by this, but hopefully it will prove helpful to someone.

    By the way, I am using a Macbook Pro connecting via Airport.
     
    Last edited: Dec 22, 2007
  5. I have the same problem. I am running os 10.5.1. I tried the net work set up and got the same error as others here. I would check to see if the parallels settings are set to share but don't know how to do that. since i was sharing before the last parallels update, however, i would think it was set to sharing. thanks. lou
     
  6. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello Loutzellner@earthlink.net,

    To check your Virtual Machine network settings you should open Configuration Editor (when the VM is started but the Guest OS is not running) and choose Network Adapter in the list on the left side of the window. Set Shared networking Emulation type.

    Please check Parallels NAT port status as well. For this you should go to Mac -> System Preferences -> Network, Show: Network Status. If Parallels NAT port is red, Show: Parallels Host-Guest and choose Off for Configure IPv4, click Apply. Then choose Using DHCP and click Apply again. After that Show: Parallels NAT and repeat the steps with Off and DHCP.

    Best regards,
    Xenos
     
  7. ramonekalsaw

    ramonekalsaw

    Messages:
    25
    In my ongoing efforts to get my WinXP internet connection to work again, I went through the steps outlined above to check/reset my configuration for Network Status.

    I have DHCP set for both Parallels NAT and Parallels Host-Guest, but while "NAT" is "green" in Preferences, "Host-Guest" is "red."

    Is this something that can be causing my (lack of) Internet connectivity problem?

    Thanks.
     
  8. ramonekalsaw

    ramonekalsaw

    Messages:
    25
    Turned off firewalls in WindowsXP and OSX. Still no connection through browsers.

    Here is the output from tracert:

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Administrator>tracert www.parallels.com

    Tracing route to www.parallels.com [64.131.89.6]
    over a maximum of 30 hops:

    1 Transmit error: code 65.

    Trace complete.

    I also uninstalled Kaspersky, as some have indicated this might be involved in the problem.

    Thanks.
     
  9. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Dear Ramonekalsaw,

    I have found out that you have picked up the correspondence with one of our engineers. He told he will help you. So I'm just intrusting your issue to the Support engineer and waiting for the solution.

    Everybody, I'll post the solution here as soon as it finally comes. I hope it will!

    With best wishes for a Happy New Year,
    Xenos
     
  10. jplevine

    jplevine

    Messages:
    6
    I have been reading through the thread as I have been experiencing the same issues. I cannot connect to the internet via IE or Firefox, but can via Safari (Windows version) and my SkyCaddie software also connects. So, the issue is not whether or not I get an internet connection in Parallels, but getting IE or Firefox to work. I am in the process of upgrading my version of Kaspersky which will hopefully do the trick. Any other suggestions that seem to work would be appreciated.
     
  11. jplevine

    jplevine

    Messages:
    6
    I think the post that suggested Kaspersky is the culprit was correct. I renewed my subscription and reinstalled Kaspersky. Once I completed this, the internet was working properly again.
     
  12. ramonekalsaw

    ramonekalsaw

    Messages:
    25
    Once again, I dropped off the radar of Parallel's 'support': I've worked with a couple of engineers and they suggest something, I try it, report back, and then I hear nothing more from them ... and still have no resolution to the problem: NO INTERNET CONNECTION USING PARALLELS.

    How about this for a next step: someone at Parallels writes down what my setup is and they take it into the lab and troubleshoot it that way?
     
  13. ramonekalsaw

    ramonekalsaw

    Messages:
    25
    I uninstalled Kaspersky, but that didn't help me get my internet connection back using Parallels.
     
  14. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello Ramon,

    There is some misunderstanding between us.

    Here is the letter our Support engineer sent you 13 days ago:

    Please try to use Shared Network emulation.
    Please check Parallels NAT port status as well. For this you should go
    to Mac -> System Preferences -> Network, Show: Network Status. If
    Parallels NAT or Parallels Host-Guest port is red, Show: Parallels Host-Guest and choose Off for Configure IPv4, click Apply. Then choose Using DHCP and click Apply
    again. After that Show: Parallels NAT and repeat the steps with Off and
    DHCP.


    Did you try these steps? We got no answer.

    In post #47 you write that you have DHCP set for both Parallels NAT and Parallels Host-Guest, but while "NAT" is "green" in Preferences, "Host-Guest" is "red."

    Did you try changing DHCP to Off on the Host-Guest tab, as proposed above, and then changing Off to DHCP again? Please try and let me know the result.

    Please make sure before that you have Shared Network set in you Virtual Machine Configuration.

    Try the same steps with Bridged Ethernet mode set in you Virtual Machine Configuration. In Mac System Preferences check the Built-in Ethernet tab then (will it be green or red, will DHCP -> Off -> DHCP change anything).

    If this still does not help, run sudo killall -hup pvsnatd in Terminal.
    Check the network connection after that.
    If there is no connection, reboot your Mac and check the connection again.

    Best regards,
    Xenos
     
  15. Chediski

    Chediski

    Messages:
    2
    I had the same problem -- being able to connect and then for not apparent reason not being able to connect to the Internet. I read the forum comments and just scratched my head trying a number of the suggestions.

    What I finally did that worked:

    1. Control panel in XP.
    2. Authentication tab
    3. Properties for the IEEE
    4. Select "use my smart card"

    Worked after that???
     
  16. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello Chediski,

    Thank you for your report. The steps you described made your network connections released and renewed. The same thing can be done by running in Windows Command window ipconfig /release and ipconfig /renew commands.

    This workaround is not supposed to help everybody as reasons for loosing internet connection differ.

    Best regards,
    Xenos
     
  17. guydavies

    guydavies

    Messages:
    38
    Hi jplevine,

    In post #51 you say that you think that Kaspersky was causing your problems. I've not seen any responses to my original post regarding problems caused by Kaspersky on my wife's MacBook. You mention that you renewed your license with Kaspersky. My wife's MB and the installation of Parallels were brand new, so I wouldn't expect it to require a new license. Does it need to be 'initialised' by renewing for free or are you saying that you bought the updated version 7 (rather than the 6.x that is included in Parallels)?

    Rgds,

    Guy
     
  18. ShoutingMan

    ShoutingMan Bit Poster

    Messages:
    11
    Greetings,

    I've had erratic network connections with Parallels recently and found an oddly simple fix: While Parallels is running, clicking (Parallels Menu) Devices->Network Adapter 1->en1: Airport/Wireless Adapter. XP suddenly found the network and was back to normal. It seems Parallels had spontaneously disabled the network connection.

    I'm using OS X 10.5.1, Parallels installed with Win XP SP2 on a BootCamp Partition, MacBook Pro 2.4 GHz 15".
     
  19. jeromeusa

    jeromeusa

    Messages:
    1
    Got my internet cnxn to work in XP!

    I just thought I'd let others know that I had the same problem with lack of internet connection in XP, after originally having it when I first installed Parallels. I never noticed I didn't have the cnxn until today, when I was debugging my website. My suspicion is that I lost the cnxn after upgrading to 3.0.

    Anyway, I was able to restore connection by manually choosing a network adaptor, under "Devices:Network Adaptor 1:en1: airport adaptor". The "limited or lost connection" warning showed up, but I switched the adaptor back to "default" and it was back up and running. Whoo-hoo!
     
  20. Yvon H

    Yvon H

    Messages:
    1
    XP then Firefox

    For a long time - humbling in itself - I thrashed around but only because I kept on trying to reach the Internet by first clicking on the IE icon, which seemed the natural way to go since on my PC, that is sometimes how I do it. Then I noticed that I had a Firefox icon on my desktop, clicked on that and voilà, I'm in the Internet and need merely enter an address of the webpage I want to see and there it is.It continues to work that way ever since.
    Thus, load Firefox or any other browser (from a CD) into parallels into Parallels, be sure XP's already there (don't know about Vista), click on the browser. That should be all there is to it.
    wildhobo@att.net

    Of course, I had previously loaded XP. Hope this helps.
     

Share This Page