Can't connect to Windows PC

Discussion in 'Parallels Client for Mac' started by stuartv, Oct 30, 2013.

  1. stuartv

    stuartv

    Messages:
    2
    I have just downloaded 2X Client RDP for Mac. I am trying to connect to a Windows PC (which is also on my desk, both plugged into the Gigabit switch on my desk).

    When I attempt to connect, using the PC name or IP address, I get an error dialog from 2X with title “Failed to connect to server”, and message “An authentication error has occurred. The Local Security Authority cannot be contacted.”

    When I connect to the same PC from the same Mac using Microsoft’s RDP Client for Mac, it gives me a warning about the certificate because the root is not a known, trusted root, but then it connects and works.

    The Mac is a brand new Macbook Pro Retina 15”, which came with OS X 10.9 Mavericks installed.

    The Windows PC is running Windows 7 x64 Ultimate. I also tried to connect to another PC running Windows 8.1 and got the same error message. I can also connect to the Windows 8.1 PC just fine using Microsoft’s RDP client for Mac.

    Help?
     
  2. Hi Stuart,

    Bsaed on the info provided, I think this is something related to the machine you are using to connect to, rather than an issue with the 2X Client in itself.

    The error you quoted is a Microsoft error and is documented here by MS: http://support.microsoft.com/kb/813550

    Thanks
     
  3. stuartv

    stuartv

    Messages:
    2
    Right.

    Except that the Microsoft Remote Desktop client connects from the SAME Mac client to the SAME Windows host with no problem.

    And, according to the detail information at the link you provided, none of the 4 cases mentioned there applies in this case. Did I mention the remote server is a Windows 7 x64 PC?
     
  4. fredash1

    fredash1

    Messages:
    1
    Hi,

    MacBook Pro Retina 15 with Mavericks 10.9 French System installed.

    Exactly the same problem described above by stuartv.
    Btw, the previous version worked flawlessly.

    Fred.
     
  5. dryanw

    dryanw

    Messages:
    1
    Also same problem. Running 11.0.1542 on an IMAC wiht Mavericks installed: I am attempting to connect to a remote PC running Windows7 and receive a diagnostic to the effect that the specified connection can't be found. Windows RDC software readily connects using the same set of parameters (the problem with the latter stability following an upgrade to Mavericks). Suggestions?
     

Share This Page