Can't download files to install .Net 3.5

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by SalutW, Jun 27, 2021.

  1. SalutW

    SalutW Bit Poster

    Messages:
    2
    I am trying to install a Virtual PC running Windows 10 on my new MacBook Air with an M1 chip.

    I have successfully installed Parallels 16.5.0. I have also joined the Microsoft Insider programme to download the Arm 64 version of Windows 10 (build 21354), which is up and running (this was using Windows10_InsiderPreview_Client_ARM64_en-us_21354).

    However I am unable to install Net 3.5 which I need to run an existing app. I have followed the guide in the KB to download and install it, but when I select download and install this feature, the installation fails with 'The following feature couldn't be installed: .NET framework 3.5 (includes .Net 2.0 and 3.0)' and 'The changes couldn't be completed. Please reboot your computer and try again. Error code: 0x800F0950'.

    I have also tried turning Net 3.5 on in the optional features application, run as an administrator. I get 'Windows need files' and when I select download the above errors occur again.

    I have tried to troubleshoot this using the information in KB (https://kb.parallels.com/en/125488?_ga=2.125662280.359029394.1624785499-245919735.1624637778) but I am unable to download the files.

    When I look in Settings / Update & Security / Windows Insider Program, it says 'Your PC does not meet the minimum hardware requirements for Windows 11. Your channel options will be limited', and the only channel available is Release Preview channel.

    My device and Windows specifications are these:
    Processor Apple Silicon 1.00 GHz (2 processors)
    Installed RAM 4.88 GB
    Device ID 4B94FD2C-66DD-48BF-8611-B21A1627FF08
    Product ID 00330-80841-20514-AA324
    System type 64-bit operating system, ARM-based processor
    Pen and touch Pen support
    Edition Windows 10 Pro
    Version Dev
    Installed on ‎25/‎06/‎2021
    OS build 21354.1
    Experience Windows 10 Feature Experience Pack 321.7601.0.3

    I have also checked my Optional Diagnostic Data switch which is set to On.

    I have activated the Arm 64 build 21354 version of Windows with a new Windows 10 Pro product key and also have a downloaded ISO file of Windows 10 (Win10_21H1_English_x64).

    When I open Command Prompt (as an administrator) it says C:Windows\system32>. I mounted the Windows 10 ISO file (it showed as D) and entered 'dism /online /enable-feature /featurename:netfx3 /all /source:D:\sxs /limitaccess' and got the message 'Error: 0x800f081f, the source files could not be found'. I then mounted the Windows10_InsiderPreview_Client_ARM64_en-us_21354.VHDX file (it showed as D) and entered 'dism /online /enable-feature /featurename:netfx3 /all /source:D:\sxs /limitaccess' and got the same error message.

    Thanks for reading all that! Has anyone found a way to get round this problem?
     
  2. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    558
    Yes, Microsoft blindsided Parallels with the sudden implementation of TPM as a requirement for Windows 11 and blocking the Dev Channel for new users who don't meet the requirements. So you're stuck with build 21354 and can't update to 21390. Unfortunately there's not much you can do until Parallels gets all the features needed for Windows 11 ready. I really hope they will put out an official statement soon.

    The x64 iso cannot be installed on an ARM processor
     
  3. SalutW

    SalutW Bit Poster

    Messages:
    2
    Thanks for the above Michael. It is actually very helpful as it stops me wasting any more time on this for now! I appreciate that you took the time to reply
     

Share This Page