Can't resize an VHD from an imported Bootcamp partition

Discussion in 'Installation and Configuration' started by benze., Dec 2, 2017.

  1. benze.

    benze. Bit Poster

    Messages:
    3
    I've run out of space in my Windows 7 Bootcamp partition and decided that I didn't need it as a separate partition any longer. I would rather just have it as a VM that I could move onto a separate HD. So I ran Parallels and imported the Bootcamp partition into a VM. That worked perfectly. I can now boot my VM in Parallels without issue.
    My problem comes to the VHD that was created by Parallels. My Bootcamp partition is a 40G partition sitting in a 1T drive. Parallels has imported the drive as a 40G drive, but it still shows up as a 1T partition in Windows and neither Parallels nor Windows allows me to resize the Drive.
    My whole goal is to be able to increase the size of my VM, but I can't seem to figure out a way to do that. I've tried to delete the "dummy" partitions in the partition table via Windows Device manager, but that has made no difference. I've already run a chkdsk /f/r as a windows admin. I have also ensured that I don't have any snapshots for this VM.

    This is what I see in Parallels when I try to edit the Disk:
    upload_2017-12-2_17-48-33.png

    This is the output from the Imported BootCamp VM's Device Manager:
    upload_2017-12-2_17-50-51.png

    How do I successfully delete these partitions such that I can resize this drive in Bootcamp?
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @benze., Virtual machine size is equivalent to the size of the whole drive that contains BootCamp and Mac partitions. However, the space that is not used by BootCamp partition is given to Mac partition. Windows recognize this partition as RAW partition. Please check out the instructions outlined in this article to resolve the issue.
     
  3. benze.

    benze. Bit Poster

    Messages:
    3
    Thanks Paul,
    I've gone ahead and deleted all the partitions using DiskPart, but Parallels is still showing me the disk as 930G, even though it is only a 40G partition.
    upload_2017-12-4_8-22-18.png

    I've tried tools like gparted (live ISO) to move the Windows partition to the start of the disk, hoping that I could then resize it appropriated, by moving the partition only makes it unbootable (Windows Boot loader complains that it can't find the boot partition).
    Are there other tools or anything else that can be done to resize the disk to its actual size (ie: 40G)?

    Thanks,
    Eric
     
    Last edited: Dec 4, 2017
  4. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi @benze. , please check this article and let us know if that helps.
     

Share This Page