Can't resize disk using the parallels vagrant provider

Discussion in 'Parallels Provider for Vagrant' started by james25, Jun 8, 2017.

  1. james25

    james25 Bit Poster

    Messages:
    3
    When I run

    config.vm.provider "parallels" do |prl|
    prl.customize ["set", :id, "--device-set=hdd0", "--size=150G"]
    end


    I get the following error:

    A customization command failed:

    ["set", :id, "--device-set=hdd0", "--size=150G", "--type=plain"]

    The following error was experienced:

    #<VagrantPlugins::parallels::Errors::ExecutionError: There was an error while command execution. The command and stderr is shown below.

    Command: ["/usr/local/bin/prlctl", "set", "bd344729-d7f1-4566-b672-c601b9c2c997", "--device-set=hdd0", "--size=150G", "--type=plain"]

    Stderr: Failed to resize: Unable to resize this hard disk. Its file system might be corrupted. Please try to start the virtual machine and check the file system for errors. Or you can resize the hard disk without resizing the file system and then resize it using the tools of the guest operating system.
    Failed to configure the virtual machine.
    >


    I think what is happening is that it is resizing the disk and then trying to extend the partition in one go which it can't do as I am using a linux guest. Does anybody know how I can resize a disk using a Vagrantfile and the Parallels vagrant provisioner?
     
  2. Swati@Parallels

    Swati@Parallels Kilo Poster

    Messages:
    361
    Hello james25, have you tried this article If not, please try it once and keep us posted.
     
  3. james25

    james25 Bit Poster

    Messages:
    3
    Hi Swati thanks. It says how to do it via the Parallels GUI but since I am trying to find out how to do it with the Parallels provider for vagrant the article isn't very useful in this case.
     
  4. rkulikov

    rkulikov Parallels Developers

    Messages:
    265
    James, for this you should use option "--no-fs-resize" in prlctl command.
     
  5. james25

    james25 Bit Poster

    Messages:
    3
    Thanks that did the trick
     

Share This Page