Can't start Parallels after moving pvm file to new drive

Discussion in 'Windows Guest OS Discussion' started by SteveJ17, Feb 21, 2022.

Tags:
  1. SteveJ17

    SteveJ17

    Messages:
    2
    I was moving all my virtual machines to a new hard disk and everything moved fine except for Windows10. If I double-click on the pvm file I moved, I get "Unable to connect Hard Disk 1". At that point it goes into a Parallels Boot Manager and I have no idea what to do.

    I restored my virtual machine from Time Machine but I still get the same error. I've tried deleting the virtual machine and still the same thing. I even swapped to a backup drive taken a few days ago and still the same error.

    If I open the package contents, I can see my Windows 10 hdd file. Configuring Windows10 and selecting the Windows 10.hdd file throws in a "There is no operating system installed in this virtual machine" error.

    I was able to move Mint and Windows11 without any problems so why is Windows10 being so difficult?
     
  2. SteveJ17

    SteveJ17

    Messages:
    2
    I've done some more digging and I think https://kb.parallels.com/116508 applies but there's some strange things going on.

    Opening the "Windows 10.hdd" package shows two possible drives. One from today which is ~132GB and one from 2019 which is ~49GB. I assume the ~49GB drive is an older image. There are corresponding .hds entries for both drives. If I open up the parallels.log file, I find the error in the knowledge base and this line:

    Error initializing for the /Users/stevejones/Documents/Virtual Machines.localized/Windows 10 test.pvm/Windows 10.hdd/Windows 10 New-0.hdd.0.{5fbaabe3-6958-40ff-92a7-860e329aab41}.hds
    02-21 15:03:29.521 F /dimg:4090:166ef/ Error 0x80021014 when opening the disk. Releasing image.

    I think the issue is that Parallels is looking for Windows 10 New-0.hdd.0.{5fbaabe3-6958-40ff-92a7-860e329aab41}.hds which doesn't exist. The closest I've got is Windows 10.hdd.0.{5fbaabe3-6958-40ff-92a7-860e329aab41}.hds. I tried simply renaming the file and end up with this error:

    02-21 15:07:36.515 F /LocalDevices:4126:17420/ [hdd::sata:0] Connecting device "/Users/stevejones/Documents/Virtual Machines.localized/Windows 10 test.pvm/Windows 10.hdd"
    02-21 15:07:36.516 F /vdisk:4126:17420/ No image file '/Users/stevejones/Documents/Virtual Machines.localized/Windows 10 test.pvm/Windows 10.hdd/Windows 10 New-0.hdd.0.{51ebe168-e0d5-4df4-ad08-987d878734e1}.hds'

    So it's looking for the older drive. I've tried moving the older .hds file to the trash and removing the entries in descriptor.xml as well but then I end up with:

    "PRI_ERR_DISK_IMAGES_CORRUPTED"

    Might have to see how far my Time Machine backups go but at this point, I don't think it's going to help.
     

Share This Page